Snow Leopard & Multitouch not working

Discussion in 'MacBook Pro' started by peejack, Aug 30, 2009.

  1. peejack macrumors 6502a

    Joined:
    Aug 7, 2007
    #1
    Hi I recently upgraded to SL on my new unibody MBP and now 3 and 4 finger touch gestures won't work at all. Is anyone else having this problem??]

    Thanks
     
  2. beamish Guest

    #2
    My MBP also experienced this. Two-finger scrolling has not been affected, but pinch/rotate/zoom functions are no longer working. One other thing I noticed is that the screen saver is prompting for a password...but the screen saver is not enabled. I'm wondering if there is something either in my user profile that is not working correctly, or the System Preferences got wonked up a bit.
     
  3. p3ncil macrumors regular

    Joined:
    Jul 6, 2009
    #3
    are you sure it's enabled in the trackpad pane under system preference?

    try creating a new user and enable the options under trackpad in system preference and see if they work.
     
  4. Cicero76 macrumors newbie

    Joined:
    Apr 23, 2008
    #4
    It just all of a sudden started happening to me. What is frack is going on!?
     
  5. jamoin macrumors newbie

    jamoin

    Joined:
    Mar 17, 2009
    Location:
    London
    #5
    The exact same thing has happened to me not but 5 minutes ago. Multitouch has been working fine in SL for a week or so, until today...

    Also, whether this is related or not...the whole system has suddenly become very slow and unresponsive. I'm running a repair permissions now, but I'm doubting that it'll make a difference..

    Any ideas on this?
     
  6. dohmer macrumors newbie

    Joined:
    Jul 30, 2009
    #6
    Not that it matters, but i'm also experiencing the same problem. Checked the trackpad settings and everything seems fine.
     
  7. cjacks68 macrumors regular

    cjacks68

    Joined:
    May 27, 2009
    #7
    This happened on my early 08 mbp. I went to the preferences and everything was checked still. So I unchecked and re-checked all the options and now it seems to work fine. Give that a try.
     
  8. dohmer macrumors newbie

    Joined:
    Jul 30, 2009
    #8
    Read somewhere that you need to shut down the laptop and take out the battery. It was pretty hard to do with a unibody. But I did try just shutting down and when I restarted, multitouch was fully functional again. Thought I'd share what I found.
     
  9. ///M5 macrumors 6502

    Joined:
    May 14, 2009
    #9
    The very same thing happened with me last week. A restart solved it.
     
  10. maximilianblue macrumors newbie

    Joined:
    Nov 21, 2007
    Location:
    Sydney, Australia
    #10
    Same thing here. However I was using a knockoff power adapter. Swapping the adapter solved the problem for me. So possible faulty power for the rest of you?
     
  11. mrsir2009 macrumors 604

    mrsir2009

    Joined:
    Sep 17, 2009
    Location:
    Melbourne, Australia
    #11
    SL might have done something to the system preferences. Go into them and see if the touch gestures are turned on.
     
  12. trentfoley macrumors newbie

    Joined:
    Nov 29, 2009
    #12
    Interesting problem

    I recently discovered that multitouch wasn't functioning on my '08 mbp w/ sl. The 2 finger scroll worked, but not zooming or rotating.

    As mentioned in an earlier post, I tried the fsck to no avail.

    Also, I created a new user, logged in as that user, and found that all of my multitouch functionality was restored. I logged out and then logged in as my normal user account, and again, functionality was restored.

    Following a reboot, multitouch was gone. As an experiment I deleted the new user account. I found that after a fresh boot, multitouch would not work. However, after logging out, and then logging back in, multitouch is restored.

    I have not tried turning off automatic logon to see if that is the issue, but I will try it next.

    Update: Automatic login does not appear to affect the results.
     
  13. shambo macrumors 6502a

    shambo

    Joined:
    Apr 4, 2009
    #13
    SL is 64bit and Multicluth doesn't support it. To resolve this I had to change my Safari back to 32bit.
     
  14. ricof macrumors member

    Joined:
    Nov 29, 2009
    Location:
    The Garden of England
    #14
    As mentioned above, check and uncheck.

    The same thing happens with the tap to click settings and uncheck and re-check always works.
     

Share This Page