Snow Leopard on White MacBook 2.1

Discussion in 'macOS' started by chrisdeli, Jan 12, 2011.

  1. chrisdeli macrumors newbie

    Joined:
    Jan 12, 2011
    #1
    Hi all,

    Having a problem installing Snow Leopard on my MacBook. I bought a new western digital hard drive, and retail version of the snow leopard installer. The computer has an intel core 2 duo 2.16ghz and 2gb of ram so it meets the minimum requirements. I can boot into the installer, and once i choose my language I get the notification "Mac OS X can't be installed on this computer" with 2 options - restore backup and restart. I have searched the net, and my hard drive is formatted as Mac OSX extended (Journaled), with a GUID partition table. I have zeroed all the data on the hard drive. I have run the apple hardware test with no problems. And to reiterate, the snow leopard is NOT a machine specific version, it is retail.

    I'm at a bit of a loss at what to try/do now, can someone please help?!

    Thanks
     
  2. Mactrillionaire macrumors regular

    Joined:
    Oct 16, 2010
    #2
    Do you still have the old hard disk? If so, put that in, boot into verbose mode (Command-V), take a picture and post the screenshot(s) here. Also, if nothing shows there, we might need to see something more specific from System Profiler. Just so you know, if you are using a MacBook (say, as opposed to a HackBook), generally only hardware problems (or incorrect hard disk formatting) would cause it to refuse to install. Though, you did indicate you formatted GUID partition with Mac OS X Extended (Journaled).
     
  3. chrisdeli thread starter macrumors newbie

    Joined:
    Jan 12, 2011
    #3
    Nope - I dont have the old HDD any more. What do you need to see from system profiler?
     
  4. Mactrillionaire macrumors regular

    Joined:
    Oct 16, 2010
    #4
    Well, then it is going to be difficult to troubleshoot your problem. Without some information about the state your hardware is in it is going to be difficult to tell what is holding up the show. The Apple Hardware Test is not going to always tell you when there is a problem with hardware. It is usually apparent when you boot in verbose (Command+V) and there are out of place messages (i.e., hardware matching fails), but you can't do that unless you have a bootable backup to work with.
     
  5. Miker2k macrumors regular

    Joined:
    Feb 2, 2009
    #5
    Can you get as far as disk utility in the installer? If so it would be interesting to see if the Macbook sees the disk.
     
  6. chrisdeli, Jan 12, 2011
    Last edited: Jan 12, 2011

    chrisdeli thread starter macrumors newbie

    Joined:
    Jan 12, 2011
    #6
    I can boot to the installer screen, where if I click restore from back up, I am able to access Installer Log, Disk Utility, Terminal, System Profiler etc. Yes I can use disk utility and it recognises the hard drive fine - I was able to partition, format and erase it using disk utility on the macbook in question.

    PS - I booted to the installer screen in verbose, and although I'm not too sure what I was looking for, I didnt notice any hardware matching fails
     
  7. Mactrillionaire macrumors regular

    Joined:
    Oct 16, 2010
    #7
    Ok, then there are only two other things I can think of. First of all, what is the model # (i.e., WD1001FALS is a 1TB model of Black Caviar) of your Western Digital hard disk and is the SMART status 'Verified' for it in Disk Utility? Secondly, did you try installing this MacBook's original operating system first and then try to install Snow Leopard on top of that?
     
  8. chrisdeli thread starter macrumors newbie

    Joined:
    Jan 12, 2011
    #8
    The hard disk is WD3200BPVT - Western digital 320gb 5400rpm Raptor (Blue). Yes the smart status is verified. On the Volume I created, there is "Owners Enabled: No" - Is that significant?


    Unfortunately I don't have the restore disks.


    Is there a way to sort of reset everything to factory/default? Like you would through the BIOS in a windows PC?
     
  9. Mactrillionaire macrumors regular

    Joined:
    Oct 16, 2010
    #9
    Macs use EFI instead of BIOS. Macs that run Boot Camp would emulate BIOS whereas Hackintoshes emulate EFI.

    In any event, the next step would be to run Hardware Test (boot up the computer, press and hold D). Make sure you have checked to run Extended Testing. This should thoroughly test the hard disk and memory.

    If Extended Testing finds no problem (and there is no hardware problem), it's possible that a Snow Leopard install on your computer might require a firmware update that your computer doesn't have or Apple might have wanted to ensure that Snow Leopard is being used as an upgrade to Leopard rather than for a clean install on pre-Leopard systems. As far as I know, however, Apple hasn't changed the retail disk to cause this to happen, but at this point it seems confounding why you are having a problem if you are using Apple hardware that is supported for Snow Leopard (with no hardware trouble) and your hard disk is formatted using GUID partition table with HFS+ volume.

    As far as resetting settings by clearing PRAM, you can try that, but I don't think it will help in this case. To do that, boot the computer and press and hold Option+Command+P+R until the computer reboots itself.

    The only other thing that I think could be the issue would be whether the computer runs in SATA 1.5Gb/s mode or SATA 3.0Gb/s mode. As for your hard disk, the manufacturer lists it as running in SATA 3.0Gb/s mode. Though, I know Western Digital disks can be made to run in SATA 1.5Gb/s mode by putting a jumper on pins 5 and 6. I just checked and Mactracker lists this computer as running SATA 1.5Gb/s, though I need to confirm which version of Apple Hardware Test you have because there are two computers with the identifier MacBook2,1.

    If the SATA negotiation speed is the cause of the problem, I would expect that you would have found out this problem because the computer should have given an error at power on, but some computers do try to negotiate SATA speeds and the hard disk may not respond in a helpful way. So, the best bet at this point is to jumper pins 5 and 6 on your hard disk and see if you have any luck installing.
     
  10. gorjan macrumors 6502

    Joined:
    May 16, 2009
    Location:
    CPH
    #10
    I'm sorry if this is too obvious, but have you tried installing without restoring from backup?
     
  11. chrisdeli thread starter macrumors newbie

    Joined:
    Jan 12, 2011
    #11
    Had a friend give me a torrented copy of snow leopard. Worked perfectly, first time. Thanks, Apple.. Wankers.


    Thanks for all your help everyone :)
     
  12. Mactrillionaire macrumors regular

    Joined:
    Oct 16, 2010
    #12
    You still may want to jumper pins 5 and 6 of your hard disk, though. According to the hardware database, your computer is running 1.5Gb/s SATA while the hard disk (set to run at 3.0Gb/s SATA) must be negotiating to run at a lower speed if your system is working properly. It is best to force the hard disk to run in 1.5Gb/s SATA mode as some motherboards do not handle this negotiation properly and it can result in system freezes and other instability.
     

Share This Page