Snow Leopard - Option to change Modifier Keys is broken

Discussion in 'macOS' started by klaxamazoo, Aug 30, 2009.

  1. klaxamazoo macrumors 6502

    Joined:
    Sep 8, 2006
    #1
    I just installed Snow Leopard and the Modifier Key option no longer works. i.e. I can't switch the CTRL and COMMAND keys. The option dialog still pops up, but the keys don't actually switch.

    Does anyone else have this problem? Is there a work around or a preference file I can change manually?

    Thanks
     
  2. klaxamazoo thread starter macrumors 6502

    Joined:
    Sep 8, 2006
    #2
    Never-mind. There is a new (maybe?) feature that lets you select different keyboards to have different modifier key settings.
     

    Attached Files:

  3. colinsky macrumors member

    colinsky

    Joined:
    Apr 3, 2009
    #3
    I had the same problem on my quad Nehalem. I tried installing on an erased disk, and then I could change the Modifier keys (I like to make the Caps Lock key a Control key). However, after I imported a Time Machine backup, the modifier change no longer was in effect.

    I erased and installed again, and this time I'm re-installing all my apps and utilities. So far the Modifier change is still okay.
     
  4. agnor macrumors newbie

    Joined:
    Sep 1, 2009
    #4
    I'm not sure why this worked, but: try a different mouse. I had a Microsoft 5-button mouse plugged in and experienced the same problem. Even removing the mouse from the system and trying to make changes solely ont he keyboard didn't solve anything. However, I plugged in a 3-button mouse, and I was able to change the modifier keys, have the changes stick, and have the changes actually work.

    I was then able to plug the 5-button mouse back in and it works fine still.
     
  5. Greg K macrumors newbie

    Joined:
    Nov 28, 2009
    #5
    This works in 10.6.2 on my MBP until I reset, and then my modifier key settings are lost again.

    Anyone else experience this? and found a workaround?

    So far snow leopard is a step back as far as keyboard support goes. I've not found a way to install a proper UK keyboard layout either. Alt + 3 for # gets tiresome quickly as a developer!
     
  6. cullepm3 macrumors newbie

    Joined:
    Mar 8, 2010
    #6
    Changing the modifier keys doesn't work on a Mac Mini without attached keyboard (I connect using VNC). The Keyboard Preference dialog lets me switch keys (Command and Control) but after I close the window it reverts to the defaults. Any ideas?
     

Share This Page