Snow Leopard: Preview.app, iPhoto and Aperture no RAW images

Discussion in 'macOS' started by mogli, Dec 28, 2009.

  1. mogli macrumors newbie

    Joined:
    Dec 28, 2009
    #1
    Hi guys,
    I use iPhoto to import CR2 files from an EOS. So far, everything worked great and all my current raw-photos in the iPhoto library are presented without problems.
    After installing Photoshop CS4, nothing worked, neither in Preview.app nor in iPhoto.app or Aperture.app...they don't support opening raw-files anymore.:eek: OK...iPhoto shows the former imported ones...but when i try to import new photos from Cam or Disk, there is the following message: "The following file could not be imported. (The file is in an unrecognized format.)". I even reinstalled iPhoto and Aperture, that maybe the raw driver are refreshed or settings corrected, but nothing happened.

    Do you have some ideas or suggestions how to solve this problem or what to search for in google?

    Thanks and best regards,

    mogli
     
  2. TonyK macrumors 6502a

    TonyK

    Joined:
    May 24, 2009
    #2
    This sounds like a PS CS4 tool that was installed to also do importing. I use a 3rd party Java application called Document Image Mover that handles moving the files from the memory card to the computer.

    I would suggest looking at the apps installed by PS CS4, going through preferences to turn-off any camera/card detection and see if that resolves your issue.

    Take care,
     
  3. cjmillsnun macrumors 68020

    Joined:
    Aug 28, 2009
    #3
    Agreed, it definitely sounds like something installed by PS.
     

Share This Page