Snow Leopard right click problem [Video]

Discussion in 'macOS' started by adster, Aug 31, 2009.

  1. adster macrumors regular

    Joined:
    Aug 7, 2008
    #1
    Hello peeps. Since the first moment I installed Snow Leopard, I've been having a problem with right clicking. 90% of the time when I right click either an Icon or a Folder the menu will appear, then immediately disappear. This has happened on a Snow Leopard clean format install with no other programs installed. I have since installed Steermouse to manage my Logitech Nano VX mouse that I use.

    I've searched around here and some other places quite a bit and I can't seem to find anyone else with this problem. Does anyone have any idea what might be the issue?

    Video:
    http://qik.com/video/2742618

    Thanks!
     
  2. ziggyonice macrumors 68020

    ziggyonice

    Joined:
    Mar 12, 2006
    Location:
    Rural America
  3. adster thread starter macrumors regular

    Joined:
    Aug 7, 2008
    #3
    Yes. I've used a generic USB optical mouse as well as the MacBook Pro trackpad and all 3 exhibit the same behavior.
     
  4. HLdan macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #4
    At this point since it's a new install, just reinstall the OS. It might be best at this point to do a full erase and install to be sure whatever bug caused this will go away.
     
  5. adster thread starter macrumors regular

    Joined:
    Aug 7, 2008
    #5
    I was afraid I might have to do that. I spent almost an entire day restoring and installing programs, too! lol Oh well. Such is life with computers!

    Is there anyway I can report this to apple?

    EDIT: Seems like I'm not alone! I found this on the Apple discussion forums:
    http://discussions.apple.com/thread.jspa?messageID=10085393
     
  6. fazox macrumors member

    Joined:
    Dec 16, 2007
    #6
    Disabling and enabling tap trackpad with two fingers for secondary click has
    fixed right clicking for me.
     
  7. dyn macrumors 68030

    Joined:
    Aug 8, 2009
    Location:
    .nl
    #7
    Since steermouse does something with the mouse movement settings it could be that it is causing the problems. Have you tried it without steermouse and did that resolve the problem?
     
  8. adster thread starter macrumors regular

    Joined:
    Aug 7, 2008
    #8
    Disabling and re-enabling Two Finger Secondary Click doesn't help at all. It happens if it's disabled and again when it's re-enabled. Thanks for the tip, tho!


    Steermouse didn't come into play until quite a bit after my Leopard installation. This behavior happened on the first boot of a clean system, without any apps / programs installed except for the operating system and still continues today after installation of Apps, drivers, etc...
     
  9. rustyk123 macrumors member

    Joined:
    Sep 17, 2009
    #9
    i noticed the same problem. mine is an upgrade not a fresh install. it was working perfect with the mouse until i connected my microsoft 5000 bluetooth mouse then it was not possible to right click with the mouse. i had to keep trying until it did not disappear right away, then wait a few seconds then i can move the mouse again.

    i tried disabling and re-enabling the two finger click on my macbook and it worked great.

    i was also wondering if anybody remembers if when leopard was first released it had this many issues? yes i know everyone is finding ways to solve the issues but when i reinstalled leopard it was great not one problem
     
  10. rustyk123 macrumors member

    Joined:
    Sep 17, 2009
    #10
    ok posted earlier that the solution worked, but i am now noticing that it is only a temporary fix anyone got another solution to try?
     
  11. slippy373462 macrumors newbie

    Joined:
    Sep 20, 2009
    #11
    Hi, I experienced the same problem right now after first install of snow leopard!

    I made an update like you and now ...

    specs:

    MBP C2D 2,1 GHZ

    + Apple wireless Mighty Mouse!

    Using the two finger tipp on the trackpad still works as it should, but not the mighty mouse, doesn't matter if you use the implemented right click option of the mouse, or the "Apple+Click" , neither works.
     
  12. metamorph3 macrumors newbie

    Joined:
    Sep 28, 2009
    #12

    Attached Files:

  13. adster thread starter macrumors regular

    Joined:
    Aug 7, 2008
    #13

    Attached Files:

Share This Page