Snow Leopard: Shift key only capitalizes first letter, automatically uses lower case

Discussion in 'macOS' started by PhilaRobert, Oct 28, 2009.

  1. PhilaRobert macrumors newbie

    Joined:
    Oct 27, 2009
    #1
    I'm having the same problem in ALL my typing: when I hold down the shift key for multiple letters, only the first is capitalized; the rest come out lower case. This is not a replacement behavior: I don't see the Uppercase letter get replaced by the lowercase one; only the first is uppercase.

    Is there some new text replacement routine? Can this be customized? I can't stand having to release the shift key between letters or to have to shift-lock, shift unlock.

    Thanks for any help.
     
  2. ergdegdeg Moderator emeritus

    ergdegdeg

    Joined:
    Oct 13, 2007
    #2
    I'm on Snow Leopard and my Mac/keyboard does not do this.

    The only advice I can offer is logging into another account and seeing if it happens there as well.
     
  3. elctropro macrumors newbie

    Joined:
    Jun 5, 2009
    #3
    I'm also running Snow Leopard and can confirm that this isn't default behavior. Try making a 2nd account and transferring all files and apps over...should be a quick fix. You could also play around in System Preferences, but I don't remember there being an option for your symptom.
     
  4. PhilaRobert thread starter macrumors newbie

    Joined:
    Oct 27, 2009
    #4
    Problem solved

    It was enough to know that it isn't a Snow Leopard problem: turns out I added TypeIt4Me at the same time I got SnowLeopard. TypeIt4Me captures all keystrokes and had a preference set to “no double capitals.“

    That was easy. Thanks for taking the time to answer!
     

Share This Page