Snow Leopard stuck in boot screen, Windows boots fine, need help.

Discussion in 'macOS' started by asianjello, Mar 7, 2010.

  1. asianjello macrumors newbie

    asianjello

    Joined:
    Jun 28, 2009
    Location:
    Earth
    #1
    So as the title explains, since last Friday I've been trying to figure out why my Macbook Pro started getting stuck on the boot screen with the spinning gear. Sometimes a progress bar appear and it fills like 1/20th of the way and goes back to the spinning gear. However, if I boot into Windows 7, it works fine. I tried using the Snow Leopard install disk to get into disk utility and it won't even boot from cd (For reference, I tried the hold-c command to boot into the cd). The I tried resetting the PRAM, the SMC reset and the fsk thing, no bananas. I have this Macbook Pro since June 2009. I'm shot of ideas, if you guys have no idea what's wrong its a call to Apple, or a meeting with a "Genius" ugh.

    Thanks and sorry for the long read.
     
  2. jgbhardy macrumors 6502

    jgbhardy

    Joined:
    Oct 15, 2008
    Location:
    England
    #2
    My initial suggestion would have been to boot from the CD but as you can't do that, I would suggest going to the Apple Store as your best option now. Sorry.
     
  3. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #3
    The "spinning gear" stage is when the Kernel is loading additional drivers and BSD.

    The progress bar is an indication that the booter is attempting to repair your startup volume.

    There could be a few things happening:
    1. Some vital system files are corrupt or have been removed.
    2. The volume structure is damaged/corrupt.
    3. Third party kext stalling startup.

    You said you ran fsk, but do you mean fsck? Did you do this in single user mode? If so, was the volume reported as being "OK". If your OS X volume is fine try the following:

    1. Safe Boot: Hold shift while booting your Mac. If your machine successfully makes it to the login screen, you may want to back up any critical data. If the machine does not boot, critical OS files are likely missing , corrupt or have the wrong permissions. If the machine does boot, continue to the next step.

    2. Verbose Mode: Hold Command + V while booting. You will now see what is happening during the kernel stage. If it is stopping for more than 30 seconds, note what it is stopping on as this is likely the cause.

    3. If the machine booted during Safe Boot, boot again with Safe Boot and remove or move the offending item to a quarantine folder. Try to boot again normally.

    Instead of holding C during boot, try holding option to bring up the Startup Manager and then try booting to the DVD.
     
  4. mrkitty5 macrumors member

    Joined:
    Oct 6, 2009
    #4
    hey- new to this thread, same problem as the first post, except with my 21.5'' imac.
    Safe boot doesn't work, just sticks at the loading screen.
    Verbose boot gets stuck at (first) **Rebuilding catalog b-tree.
    After some time, it then says
    Macintosh HD cannot be repaired
    Bug: launchctl.c:3818 (23930) :2: remove (de->d_name) != -1

    Then there are a lot more lines like the Bug: etc .... and then eventually it says

    Launchctl: please convert the following to launchd:/etc/mach/init.d/dashboardadvisoryd.plist
    launch_msg(): Socket is not connected


    That is where it finally gets completely stuck. I'm assuming the "Macintosh HD cannot be repaired" thing is bad, yes???
    Please help!
     
  5. Esoremada macrumors newbie

    Joined:
    Dec 5, 2009
    #5
    I did the same thing but it stopped in a different place D:

    It said:

    Executing fsck_hfs (version diskdev_cmds-491.0.2-6).
    launchctl: Dubious permissions on file (skipping): /Library/LaunchDaemons
    launchctl: Dubious permissions on file (skipping): /System/Library/LaunchDaemons
    launchctl: Dubious permissions on file (skipping): /stc/mach_init.d
    AppleIntelCPUPowerManagement: Initialization complete
     
  6. bishopazrael macrumors newbie

    Joined:
    May 31, 2010
    #6
    I just had this problem with my mbp as well. I tried pretty much everything. I finally tried repairing it from the installer disk utility but no joy. I couldn't even get it to install over itself. I wound up pulling all my data and just wiping it and reloading.

    I'm starting to get that feeling I used to have about windows back in the day. Mac is becoming more of a fussy OS now. Not sure why but I'm not terribly happy about it.
     
  7. mrkitty5 macrumors member

    Joined:
    Oct 6, 2009
    #7
    Anyone want to offer some sort of help? maybe interpret the error messages we've been getting? Please?

    EDIT:
    Ok, so I have finally managed to get it to work. The computer refused to recognise the mac osx install disk, until after an arbitrary number of tries it randomly began to show up in the boot screen you get when you hold down option on startup. Having started it up it refused to install on my partition, so I had to open disk utility in the installer. It then refused to repair the disk, so I simply had to erase and re-format the partition.
     

Share This Page