Snow Leopard: Sudo root not accepting the password I set.

Discussion in 'macOS' started by runebinder, Sep 11, 2009.

  1. runebinder macrumors 6502a


    Apr 2, 2009
    Nottingham, UK
    Ok so opened Directory Utility, unlocked it and then selected Enable Root User and set a password, locked Directory Utility opened terminal and typed sudo root.

    When I entered the password I set I just get "Sorry, try again". Have tried going back into Directory Utility and changing the password but get the same thing, any ideas?
  2. gilkisson macrumors 65816


    If you are meaning to be root in a Terminal, don't do "sudo root". Do "su -" and enter the password.
  3. electroshock macrumors 6502a


    Sep 7, 2009
    You don't need to enable the root user. All you need to do is run then do:

    $ sudo -s

    ...and enter your password.

    If that doesn't work, is the user account you're using an administrative account?
  4. steerpikegg macrumors member

    Nov 19, 2007
    Even better, don't enable root user, just type

    sudo su
  5. ebiz macrumors newbie

    Jan 20, 2013
    Same problem here

    None of these solutions have worked for me.
    I'm trying to install rails and i need sudo access.
    the command is:
    sudo gem install rails
    When prompted for the password I get: "Sorry, try again"

    I have enabled the root user through CoreServices.

    I've tried:
    sudo su
    sudo -s

    I believe that my user account had admin rights. It says "admin" under the account name in Users. Besides, if it didn't I'd expect to see some kind of permissions error when enabling or changing the root account password.

    Any help is appreciated.
  6. dontpannic macrumors 6502


    May 16, 2011
    Orpington, Kent, UK
    Disable the root account. When it asks you for a password on any sudo or Su command it's asking for YOUR password, not the root password.
  7. ebiz macrumors newbie

    Jan 20, 2013
  8. kevink2 macrumors 65816

    Nov 2, 2008
    Didn't know that one. I have always done sudo /bin/bash
    then my password.

Share This Page