Snow Leopard takes too long to sleep - how to fix??

Discussion in 'macOS' started by efplaya85, Aug 30, 2009.

  1. efplaya85 macrumors newbie

    Joined:
    Mar 14, 2009
    #1
    I recently upgrade my leopard to snow leopard and when ever i put the computer to sleep it takes quite a while for it to actually go into sleep mode.

    Now I tried pmset with no success like so: sudo pmset -a hibernatemode 0

    Why does snow leopard take so long to go to sleep, does anyone else have this issue? Is there anything else i could try to fix it. It says hibernatemode is 0 in pmset info table so I have no idea whats wrong... Any ideas?
     
  2. benlee macrumors 65816

    benlee

    Joined:
    Mar 4, 2007
    #2
    I have the same problem.
     
  3. jolleyjoe macrumors newbie

    Joined:
    Jul 17, 2009
    #3
    +1

    I also have the same problem... anyone know of a fix?
     
  4. alexandero macrumors regular

    Joined:
    Apr 19, 2004
    #4
    same - when I close the lid of my Santa Rosa MBP of 2007, it takes about 10-12 seconds until it goes to sleep. As sleep was instant on 10.5.8, I wonder what happened.
     
  5. Wotan31 macrumors 6502

    Joined:
    Jun 5, 2008
    #5
    What did you upgrade from? 10.5? 10.4?

    Sleep was nearly instant with 10.4 for me. After upgrading to Leopard, sleep took much longer. 10 seconds+. Snow Leopard feels about the same. I miss my nice fast 10.4 sleep times.
     
  6. SebZen macrumors 6502

    Joined:
    Apr 12, 2009
    #6
    I'm pretty sure this is intentional and required for the faster wake up times featured in SL.

    I'm assuming it now saves more data than in 10.5, enough data to make wake up faster than before. Hence it taking longer to go to sleep.

    I don't think it matters, though. When you put your comp to sleep you just walk away, why would you stare at it? You put it to sleep because you don't need it any more.
     
  7. efplaya85 thread starter macrumors newbie

    Joined:
    Mar 14, 2009
    #7
    well...

    The thing is, setting hibernate mode to 0 should turn off writing to disk and should be memory only , which indicated by the elongated sleep time, is obvoiusly not. In 10.5 I set my hibernate mode to zero and had virtually instantaneous sleep times but it does not seem to work that way in SL
     
  8. mac-slap-happy macrumors member

    Joined:
    Jul 25, 2007
    #8
    Had the same issue. Did a clean install, and brought everything over from Time Machine backup. Sleep took forever to actually engage - MUCH slower than Leopard. I also had a few other oddities, like volume settings not being remembered after a reboot.

    So I formatted again did another clean install, but this time did NOT bring over everything from Time Machine through the Migration Assistant. I rebuilt my profile from scratch, installing all software again, dragging only my documents over from the TM drive. I did NOT bring my entire home directory, so didn't get all of the crud buildup in ~/Library. I used MobileMe to sync my keychain, contacts, favorites, etc.

    SL is now perfect. Sleep is way faster to engage than it ever was in Leopard - probably within 3 - 4 seconds and it's winking at me. Wakeup is instantaneous - hard to tell it was sleeping. No more funny volume issues, and I couldn't be happier.
     
  9. SebZen macrumors 6502

    Joined:
    Apr 12, 2009
    #9
    Odd, in Leopard my MBP went to sleep in about 3 seconds. Today I did a fresh install (NOTHING from my Leopard install that I transferred). Now sleep takes about 8 seconds. Wake up is instant, though
     
  10. mac-slap-happy macrumors member

    Joined:
    Jul 25, 2007
    #10
    Interesting indeed. I just did a quick sleep and timed it - 5 seconds on mine from hitting the hot keys until I got the wink. Leopard was much slower than that for me, but then again I think I was packing around a lot of crud in Leopard - some of it was even migrated over from Tiger. I have a feeling the clean install probably helped me more than I realize.
     
  11. efplaya85 thread starter macrumors newbie

    Joined:
    Mar 14, 2009
    #11


    Well the thing is that I dont want to have to do a fresh install for everything to work. I know doing a fresh install will fix everything but that is besides the point. The point is that there must be some way to get sleep working fast again...
     
  12. mac-slap-happy macrumors member

    Joined:
    Jul 25, 2007
    #12
    I completely agree. I just think you eventually reach a point of diminishing returns with this approach. The time required to research and find what is killing it could take longer than simply doing a fresh install. Even with the two formats on my end, I still had it all done in a single day (albeit a long one).
     
  13. doug in albq Suspended

    doug in albq

    Joined:
    Oct 12, 2007
    #13
    I had the same issue as the OP.

    Got this tip on the Apple discussion forums from "Snoop Dog":


    "You can figure out what's delaying sleep by running the following command in Terminal.

    pmset -g log

    Look for "applicationresponse.slowresponse" and look for the "Signature" with the longest time."


    For me that tip by "Snoop Dog" tracked down "efax" as timing out after a very slow "applicationresponse" of 30,000ms...

    light bulb goes on in my head and I open up system preferences and go into "Printers and Fax"

    deleted an old fax profile set up with my external apple fax/modem that is only hooked up in the rare occurrence of needing to send or receive a fax...

    BAM!
    Time for my macbook to sleep goes from 30 seconds to about 4 seconds!!
     
  14. cameronfield macrumors member

    Joined:
    Aug 11, 2009
    #14
    Yup, takes a solid 14 seconds for me....weird.

    Tried the log thing and got this:

    * Domain: applicationresponse.slowresponse
    - Message: PMConnection AirPort configd plug-in com.apple.powermanagement.applicationresponse.slowresponse 2196 ms
    - Time: 9/1/09 2:54:39 AM CDT
    - Signature: AirPort configd plug-in
    - UUID: 06EC9CFE-3A4D-4D19-BBCB-710A64F4D69D
    - Result: Noop
    - Response time (ms): 2196

    * Domain: applicationresponse.slowresponse
    - Message: PMConnection IPConfiguration com.apple.powermanagement.applicationresponse.slowresponse 2198 ms
    - Time: 9/1/09 2:54:39 AM CDT
    - Signature: IPConfiguration
    - UUID: 06EC9CFE-3A4D-4D19-BBCB-710A64F4D69D
    - Result: Noop
    - Response time (ms): 2198


    Any idea what that is/how to disable/make it faster?
     
  15. vardamir macrumors newbie

    Joined:
    Jun 18, 2009
    #15
    There's a very good reason why you would want the sleep to occur quickly. A portable computer with a normal hard drive should not be carried around while it's turned on. If I intend to walk a reasonable distance quickly, or travel a short distance in a vehicle, I like to put my Macbook to sleep first. If it means waiting 10 seconds or more when you're in a rush, it becomes quite annoying.
     
  16. efplaya85 thread starter macrumors newbie

    Joined:
    Mar 14, 2009
    #16
    Nice!

    Ok the pmset log helped me track down the problem. The problem was the google talk plugin for firefox I simply had to disable it and now sleep is instantaneous.

    For those who might be having trouble you simply have to run pmset -g log and look for the application that has the longest time - like 30000ms in the response time field. The app with the large response time is the culprit.
     
  17. SebZen macrumors 6502

    Joined:
    Apr 12, 2009
    #17
    I can't figure it out. Doesn't seem to be anything out of norm except for Hibernatestatistics, but I don't know what that is:

     
  18. doug in albq Suspended

    doug in albq

    Joined:
    Oct 12, 2007
    #18
    Your computer is set to hibernate (hibernate=3).

    For you, that is why the longer time to sleep.
     
  19. SebZen macrumors 6502

    Joined:
    Apr 12, 2009
    #19
    How do I switch? I don't think I changed anything, and going to energy saver, I don't see anything of that nature.

    http://www.geeked.info/make-my-macbook-pro-hibernate/

    Hrmm, that says 3 is the default.

     
  20. doug in albq Suspended

    doug in albq

    Joined:
    Oct 12, 2007
    #20
    3 is the default, which is to hibernate if battery is low.
    this default is still slower than setting hibernate to 0, even though there is no hibernating unless low battery.

    default of 3 is taking you anywhere from 8,000 to 13,000 ms (milliseconds)--which is 8 to 13 seconds--to do its thing for your machine.

    do this in terminal:

    sudo pmset -a hibernatemode 0
     
  21. SebZen macrumors 6502

    Joined:
    Apr 12, 2009
    #21
    Yeah I got http://www.jinx.de/SmartSleep.html earlier today.

    But why was it so much faster in Leopard? Was Leopard 0 by default?
     
  22. mnpmac macrumors member

    Joined:
    Sep 1, 2009
    #22
    I dont see the "log" option in Leopard.
    If I do a man on pmset, the only options with log are "pslog" and "rawlog".

    Is this specific to SL?
     
  23. jiro macrumors newbie

    Joined:
    Oct 15, 2009
    #23
    very slow sleep time

    Hey guys,

    I have a new MBP and for some reason, in the last couple of days, the sleep time has gone from about 3 secs to 30+ secs??? Tried all of the remedies listed above, but no luck.. this is the message I get when I try to change the hibernation mode to 0..

    Warning: Idle sleep timings for "Battery Power" may not behave as expected.
    - Disk sleep should be non-zero whenever system sleep is non-zero.
    Warning: Idle sleep timings for "AC Power" may not behave as expected.
    - Disk sleep should be non-zero whenever system sleep is non-zero.



    any ideas?

    From looking at the log, the hibernate mode is 0 but it is still taking ages..

    * Domain: applicationresponse.timedout
    - Message: Kernel cupsd com.apple.powermanagement.applicationresponse.timedout 30000 ms
    - Time: 15/10/09 3:43:00 PM AEST
    - Signature: cupsd
    - UUID: 682DD764-F26B-4440-ACA9-BE53321745D0
    - Result: Noop
    - Response time (ms): 30000

    * Domain: sleep
    - Message: Sleep: Success - BATT 10 - Software Sleep
    - Time: 15/10/09 6:51:45 PM AEST
    - Signature: Success
    - UUID: 1087823F-A23B-4C7B-AFF4-B405A5C6B5A1
    - Result: Success
    - Sleep count : 4

    * Domain: wake
    - Message: Wake: Success - BATT 10 - PWRB
    - Time: 15/10/09 6:51:45 PM AEST
    - Signature: Success
    - UUID: 1087823F-A23B-4C7B-AFF4-B405A5C6B5A1
    - Result: Success

    * Domain: hibernatestats
    - Message: Hibernate Statistics
    - Time: 15/10/09 6:51:45 PM AEST
    - Signature: hibernatemode=0
    - UUID: 1087823F-A23B-4C7B-AFF4-B405A5C6B5A1

    * Domain: applicationresponse.timedout
    - Message: Kernel cupsd com.apple.powermanagement.applicationresponse.timedout 30000 ms
    - Time: 15/10/09 6:51:45 PM AEST
    - Signature: cupsd
    - UUID: 1087823F-A23B-4C7B-AFF4-B405A5C6B5A1
    - Result: Noop
    - Response time (ms): 30000

    * Domain: applicationresponse.slowresponse
    - Message: PMConnection AirPort configd plug-in com.apple.powermanagement.applicationresponse.slowresponse 1469 ms
    - Time: 15/10/09 6:51:45 PM AEST
    - Signature: AirPort configd plug-in
    - UUID: 1087823F-A23B-4C7B-AFF4-B405A5C6B5A1
    - Result: Noop
    - Response time (ms): 1469
     
  24. pezsma macrumors newbie

    Joined:
    Nov 16, 2009
    #24
    I had the same problem, with 30-second sleeps caused by cupsd timing out. It turned out that back in August I accidentally sent a document to an old printer that I never turn on anymore, and ever since then the job has been patiently sitting in the printer queue. It looks like cupsd (the printer daemon) tries to prevent the system from sleeping while there are documents to print---which doesn't sound like an unreasonable policy in the usual case.

    Deleting that silly print job fixed the issue: my 4 GiB MBP now goes to sleep in under 2 seconds!
     
  25. akadmon macrumors 68020

    Joined:
    Aug 30, 2006
    Location:
    New England
    #25
    Give it some mellow yellow. Failing that, a healthy hit with a 20 lb sledgehammer should put it to sleep in under half a second (collateral damage notwithstanding).
     

Share This Page