snow leopard two finger right-click does not work for white macbook

Discussion in 'MacBook' started by qliu34, Aug 28, 2009.

  1. qliu34 macrumors newbie

    Joined:
    Aug 28, 2009
    #1
    Hi folk,

    I upgraded my white macbook to snow leopard today. I noticed that two finger right click does not work. The only option on touchpad settings is two finger and then a click for right-click. In leopard, I was able to use two fingers to touch the touchpad and that's it. Now with SL, i have to use to fingers to touch, and then another click???

    Does anyone know how to fix this?

    Thanks,
     
  2. jrosmiles macrumors newbie

    Joined:
    Aug 28, 2009
    #2
    Uclick the option and then re click

    I was having the same problem and I just unclicked the option and then reclicked it. It is now working. Good Luck
     
  3. Jannemans macrumors newbie

    Joined:
    Sep 11, 2009
    #3
    Hey guys
    Just wanted to say that I was having this problem as well (also on a white macbook) and unchecking and rechecking it solved the problem here as well.
    Thanks!
     
  4. kbfref macrumors newbie

    Joined:
    Sep 1, 2009
    #4
    Thank You!!

    I've been having this problem myself, never occurred to me to un-tick and re-tick the box, just thought I was at fault!! :)
     
  5. TheRenfro macrumors newbie

    Joined:
    Sep 14, 2009
    #5
    I didn't have this problem when I upgraded to Snow Leopard. Hopefully un-clicking and re-clicking the box will fix it because that is a really handy feature.
     
  6. bluebottle macrumors newbie

    Joined:
    Feb 1, 2010
    #6
    I also had this problem and found that the fix was different. Under trackpad preferences you have to tick the checkbox 'Clicking', to allow click by using the trackpad.

    Then the option for two fingers right click changes so you only need to tap two fingers instead of use two fingers and click.
     
  7. nagromme macrumors G5

    nagromme

    Joined:
    May 2, 2002
    #7
    None of the above helped me (and I’m not sure if my problem started with Snow Leopard or later). My problem is that right-click by two-finger tap USUALLY fails, but if you try it a bunch of times it sometimes works. (Ctrl-click always works. So does two-finger-hold-click.)
     
  8. katakis1 macrumors newbie

    Joined:
    Mar 18, 2010
    #8
    You have to recheck the option "Secondary Tap" not the first option "Tap to click"
     
  9. biter macrumors newbie

    Joined:
    Aug 22, 2011
    #9
    Must disable "Smart Zoom"

    Disable "Smart Zoom" under System Preferences->Trackpad->Scroll & Zoom. After disabling smart zoom the problem entirely goes away. The issue was caused because after the first two-finger-tap the OS was waiting to see if there would be another one for a "double two-finger-tap," which would cause a smart zoom to happen. Disabling that feature solves the problem.
     
  10. benquan macrumors newbie

    Joined:
    Dec 26, 2011
    #10
    Be sure that Tap to click is enabled, otherwise, you need to actually click with two fingers instead of tapping with two fingers.
     
  11. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #11
    Although this thread hasn't been active for 503 days and it was created 1,227 days ago, the answer does not apply to the white non-Unibody MacBook the OP has, since that white Unibody MacBook was introduced in late 2009 and already came with Mac OS X 10.6 Snow Leopard preinstalled. The white non-Unibody MacBook does not have a clickable trackpad, only a button, but it registers two fingers for right click, and as far as I can remember, one did not have to set something, but maybe the installation frelled up.

    May we, or I, know how you come upon this thread and decided to resurrect it? I mean, you registered over a year ago and this is your first post, it just got some of my hair in a weird angle. ;)
     

Share This Page