Snow Leopard Upgrade Broke Tiger FileVault

Discussion in 'macOS' started by mahanso1, Aug 30, 2009.

  1. mahanso1 macrumors newbie

    Joined:
    May 3, 2008
    Location:
    Arizona
    #1
    I recently upgraded my iMac from Tiger to Snow Leopard. My Home Folder in Tiger was encrypted with FileVault. The OS install itself went fine, and afterwards I could access my Home Folder (music, photos, etc.) without issue in Snow Leopard.

    Then I rebooted the computer. At the login screen, I selected my User Account (which is, of course, an Administrator account, but not the only one on the computer). I typed the correct password. After several seconds, an error message pops up, stating: "Your home folder, which is protected by FileVault, didn't open. It needs to be repaired."

    Clicking "OK" yields another error message: "You are unable to log in to the user account <USERNAME> at this time. Logging in to the account failed because an error occurred. There is no description of the error.

    I have tried typing in the master password, resetting the password, and get the same results. I have attempted to access the Disk Repair Utility through another Administrator account. Disk Repair then quits unexpectedly.

    Any ideas for how to regain access to my Home Folder and to be able to log in normally? Thanks!
     
  2. threeapples macrumors newbie

    Joined:
    Aug 31, 2009
    #2
    same problem

    I have the same problem. I can get in through another admin account, by my photos and music are safely locked away in a filevault that i can't access. I hope someone can help... :(
     
  3. rachelrichards1 macrumors newbie

    Joined:
    Jan 8, 2010
    #3
    im having exactly the same issue, cannot login to my main account at all! someone please help us!:confused:
    is there any way to disable file vault from another account?
     
  4. iVoid macrumors 65816

    Joined:
    Jan 9, 2007
    #4
    Have you tried logging in with a different account and then manually mounting the sparseimage file for the user? May have to do it in terminal or enable showing invisible files in Finder.
     

Share This Page