Snow Leopard & Windows 7 - Service Pack 1 failed install

Discussion in 'Windows, Linux & Others on the Mac' started by ENKI2012, Jul 15, 2011.

  1. ENKI2012 macrumors newbie

    Joined:
    Jul 15, 2011
    #1
    Hello...I have been reading threads on this forum, and found some really great articles & tips, so I thought I would post this in the hope of some advice/help/whatever you are prepared to give

    Now for some background:

    Previous Situation - needed a larger Windows Partition:
    MacBook Pro 13 inch 4Gb Ram 250Gb hdd P8600 Duo 2.40ghz - running Bootcmap:
    Snow Leopard - 220Gb for Mac
    Windows 7 - 30Gb for Win

    Used the process mentioned on this forum to enlarge the partition it worked like a treat until the restore, that failed for me:

    reporting errors with restore...

    Long story Short:

    After some research, I found out that I failed to run a chkdsk and repair on the Windows 7 partition before running a Winclone (backup - Image) of that partition (shame for me as I had toasted the Windows 7 Partition at this point), but again I came to the forum and found that if I change the preferences in Winclone to ASR for restoring I may be able to get back the partition - Data (downside it restores the partition as saved and reduces the size of the partition to match what was saved, even after I enlarged the partition in Bootcamp)... so I did the following:

    1. Changed the preferences in Winclone to ASR
    2. Restored the Winclone image I had on external USB drive (the one that failed from before to the larger partition)
    3. After a successful restore - With NO ERRORS :D
    3. Booted into the Windows 7 partition
    4. Selected a check disk from windows My Computer > Properties > Tools > Check Now (will delay to next boot up) make sure you click and check to 2 boxes 1- Automatically fix file system errors, 2 - Scan for and attempt recovery of bad sectors
    5. Shutdown and re-boot
    6. Let the chkdsk compelete all phases
    7. Once it boots into Windows Shutdown and boot to Mac
    8. From Mac Run Winclone and create a new image of the Windows 7 partition (bootcamp)
    9. From Mac Run Bootcamp and toast the Windows 7 partition (selecting restore will make the drive one partition) and close out of bootcamp
    10. From Mac Run Bootcamp again and create your desired size for the Windows partition (80Gb - in my case fully loaded with most of the office suite, visio, Project, Infopath, onenote, as well as countless windows apps for Prohect management, documentation etc)
    11. From the Mac when the Bootcamp prompts for Installing Windows exit Bootcamp
    12. From the Mac Run Winclone and change the preference to not restore ASR, then select restore of the newly created image to the newly created partition
    13. Shutdown the mac
    14. Boot up and hold option key down and select the Windows partition to boot
    15. Should boot into Windows check your data and install - Hopefully life should be good now larger partition and your data as you left it...

    Now to:

    Current Situation:
    MacBook Pro 13 inch 4Gb Ram 250Gb hdd P8600 Duo 2.40ghz - running Bootcmap:

    Snow Leopard - 170Gb for Mac
    Windows 7 - 80Gb for Win

    All was running fine with my setup that was until a couple of days ago when I had Windows Update prompt for important updates to install (Service Pack 1 for Windows 7) this is where my fun - NOT started... since then I cannot get Service Pack 1 to install successfully, I have tried:

    1. Disabling all Virus, web, script shields, most other non MS programs, running Windows Update of SP 1 only
    2. Safe Mode install of SP 1
    3. Clean boot and install of SP 1

    Nothing, nada, zip - all ending the same...

    My Question is has anyone successfully run a Windows Startup Repair on this kind of setup and do you reccommend it, to see if there are any issues with Windows that could be interferring with the SP 1 install and configuration ?

    HELP PLEASE... I'm out of options I think unless you have some...Should not be this hard...

    Cheers
     
  2. munkery macrumors 68020

    munkery

    Joined:
    Dec 18, 2006
    #2
    If you are proactive in your installation of optional hotfixes from Windows Update, then SP1 will not install.

    http://krebsonsecurity.com/2011/02/before-you-install-windows-7-service-pack-1/

    I have seen several systems exhibit this issue. After one failed update, automatic update will no longer attempt to install SP1. It will try to install it during manual updates so make sure to uncheck it when doing manual updates.

    Apparently, the content of many hotfixes are the same as SP1. So, not installing SP1 is not that much of an issue. I suspect MS will fix this eventually.

    If this is not the issue, then the only other solution is to uninstall all third party drivers, install SP1, and reinstall the needed drivers. I have had success installing SP1 using this method.
     
  3. ENKI2012 thread starter macrumors newbie

    Joined:
    Jul 15, 2011
    #3
    munkery... Thanks very much for the info, yes I have kept uptodate, and read the article you kindly included, in this instance I think I am going to grin and bare the fact that I am skipping this SP... and just see what happens to the next round of win updates...

    Cheers again
     
  4. munkery macrumors 68020

    munkery

    Joined:
    Dec 18, 2006
    #4
    It annoyed me tremendously until I found that article.

    Hopefully MS figures out a way to reconcile hotfixes and third party drivers with the installation of service packs.
     
  5. thepsychopinkie macrumors member

    Joined:
    Jul 7, 2010
    Location:
    Fayetteville, NC
    #5
    too late to be proactive

    Ok I have the same problem, I finally got most everything working nicely with Win7 on my MB Pro, with the major exception of printing. That was my mission until SP1, which I thought it would help, so I said go ahead and install all. Dum..Da..Dum..Dumb..DUMB, the sad thing is I know better but I only have Win7 on my machine for gaming through Steam. I found a post on a blog site that described deleting and replacing some elements in the registry through recovery mode using CMD line. I was unable to locate those elements in my registry, also I have no restore point to revert to. Any other ideas, I dont really want to do a wipe and reinstall.
     

Share This Page