Snow Leopard with time machine & smb shares not working

Discussion in 'macOS' started by sejanus, Aug 27, 2009.

  1. sejanus macrumors regular

    May 3, 2005
    hi guys

    On 10.5 I used to have time machine backing up to a remote smb share using the time machine hacks to create a sparsebundle image on the smb share

    No longer working with 10.6 - always get an error. Is it working for anyone else?

    Why apple couldn't make time machine get along with smb shares natively out of the box is simply beyond me.
  2. sejanus thread starter macrumors regular

    May 3, 2005
  3. pmb333 macrumors newbie

    Mar 9, 2009
    What's your error? I can't connect to my DNS323 samba shares at all.
  4. sejanus thread starter macrumors regular

    May 3, 2005
    it says it can't create the disk image.

    The old way of doing it was creating an image based on the computer mac address manually with disk utility.

    10.6 seems to do away with the mac address stuff, and it ignores whatever image you already have there and tries to make a new one and fails.
  5. drlunanerd macrumors 68000


    Feb 14, 2004
  6. pos macrumors newbie

    Sep 3, 2009
    It works for me.

    I upgraded from a fully patched Leopard to Snow Leopard yesterday. I noticed time machine against my smb backup share didn't work anymore. However... It seems like it just has forgotten how to find and connect to the smb time machine drive.

    I simply opened the time machine smb share in finder and authenticated. Then I choose it again in time machine (didn't pop up as a possible time machine drive if it was not opened in finder first). Now it works like a charm on 10.6 as well.

    I did _not_ change any name or so on the sparebundle file or changed any system settings at all. The system setting to accept unsupported smb drives is not changed by snow leopards during the upgrade.

    Hope this helps

  7. strawman macrumors newbie

    Sep 6, 2009
    Hurray, it works now again!!!!!


    I desperately tried to make the TM work again after my 10.6 upgrade. I had the same problem as many users here, too: TM could not mount my TM image from an smb/windows share anymore. With 10.5 everything had worked like a charm for a many months though...

    So much I know now: it is definitely a network authentication issue - the sparsebundle needs not to be changed, recreated, or renamed!

    After many hours of trial and error the following worked for me (but I am not sure which of the steps are really necessary and which not!):

    - connect the share via Finder Go To -> Connect with server (sorry, have a German version here...)
    - use the IP address instead of the network name for this share
    - use a username/password which works with the default domain on the smb server, so don't use any domainname prefix for the username
    - don't click "add to key chain" (sorry, again only German here...) for this login
    - afterwards connect the volume in TM as usual, as a new volume, and use the same username/password as above

    Afterwards, everything was working for me again (using the same sparsebundle from 10.5)!

    have fun and keep trying....;)
  8. flakker macrumors newbie

    Sep 10, 2009
    Got it working

    Here's what I did to get Time Machine on Snow Leopard to backup to a CentOS 5.3 machine over AFP. I had the same problems as everyone else here but managed to get it working. I hope it helps you. It assumes you have successfully managed to do everything necessary to connect to your linux server from the Mac using "connect to server" from the Finder.

    1. On the Linux box: Run the command "touch" at the top level of the filesystem you are exporting to your Mac.

    2. On your Mac, create a sparse bundle image called Computername_macaddress.sparsebundle (ie, Applecore_002500d1c6f0.sparsebundle) using Disk Utility. It should have a name of "Backup of Computername". The size should be the maximum size the sparsebundle can grow to on whatever linux filesystem it is going to live on. Set the filesystem type appropriately for your Mac "MacOS Extended Case in/Sensitive (Journaled)". Image format should be "sparse bundle disk image". Then create the file.

    3. On your Mac, Mount the sparse disk bundle and from a terminal, cd to it. Run "touch" at the top level.

    4. Unmount/eject the disk bundle .

    5. Use "connect to server" from the Finder to open the linux share where the sparse bundle will be located and copy your sparse bundle to the share (do not try to mount the sparse bundle when you are done)

    6. Go to the Time Machine prefs and select your Linux share and then tell it to do a backup. My Mac found the sparse bundle and started using it.

    The key seemed to be to add the file to both the top level of the linux share AND the top level of the sparse bundle. Without either, I kept getting errors. You also need to run "defaults write TMShowUnsupportedNetworkVolumes 1" on the Mac. I did it both from my own user account and via sudo....just to be thorough.

    Good Luck
  9. a.boulton macrumors newbie

    Sep 25, 2009
    After much tinkering and googling I found this thread on another set of forums. I tried out the 'manual' process and it worked perfectly.

    I'm pretty new to the Mac Scene and I couldn't figure out how to make shell scripts work which is why I went for the manual version.
  10. skarocks47 macrumors member

    Sep 26, 2008
    help! i have the same problem. I am running 10.6 and i am trying to TM to a Iomega Network Storage and i keep getting the (Error45). and the insanely mac links are broken for me. Please help
  11. t.sjogren macrumors newbie

    Mar 23, 2010
    Sweden, Gothenburg area
    I have a newly bought iMac 21" and a erlier bought 'Iomega StorCenter ~350GB'
    I am also running 10.6.2 and trying to setup TM with no luck.
    After your posting, have you solved this? Then please let me know the solution?
    General question: If the NAS dont support AFP ist there eny chance to solve TM backup? Guide?
  12. t.sjogren macrumors newbie

    Mar 23, 2010
    Sweden, Gothenburg area
    Do you know if the drive have to support AFP? I can only use SMB!
  13. votdfak macrumors 6502


    Mar 15, 2011

    It is working!!! Thanks strawman!

Share This Page