Snow Leopard won't install, says "this disk cannot be used to start up your computer"

Discussion in 'macOS' started by kis, Aug 28, 2009.

  1. kis macrumors 65816

    Aug 10, 2007
    Ok, this isn't an isolated issue - there are threads about this over at Apple and InsanelyMac:

    I'm unable to install Snow Leopard. When I run the installer, it'll tell me that "Mac OS X cannot be installed on "Macintosh HD", because this disk cannot be used to start up your computer" (Macintosh HD being my OS X volume, obviously).

    I'm seeing this issue on a relatively new 1.8ghz Macbook Air with a 128gb SSD - however, as far as I can tell from the other threads, the problem also affects iMacs and Macbooks.

    Some people apparently attributed the issue to a PGP installation they had on their harddrive. Others found a file called backup.backupdb in their root - deleting it fixed the problem. However, most people don't have any of that installed on their computers and the upgrade still won't work.

    So - if anyone has found a solution to the issue, please let me know :-( I'm stuck here. I don't have an external drive for the MBA and booting from a network drive has never worked on this particular machine - so I can't do a clean install, either.

  2. r.j.s Moderator emeritus


    Mar 7, 2007
  3. kis thread starter macrumors 65816

    Aug 10, 2007
    10.5.8, using a retail upgrade disk of Snow Leopard
  4. kis thread starter macrumors 65816

    Aug 10, 2007
    fixed (for me)!

    I was able to fix the issue by creating a 5gb Windows partition in the Bootcamp utility. After that, the installer now works. Will delete the 2nd partition once SL has finished upgrading.

  5. eme jota ce macrumors regular

    Jul 26, 2005
    Same problem

    Installing on an iMac that is less than 6 months old.

    Receiving the same installation error when clicking on the "Install Mac OS X" icon and trying to select my startup disc.

    Tried using system preferences to select the Snow Leopard DVD as the startup disc, which allowed me to boot from the SL DVD, but reached the same result / roadblock with a similar but not identical error message.

    I've called Apple support, they are having me repair disc permissions, which I had already done, but they are making a point of directing me to repair by selecting the top level of the Disc listed in Disk Utility, not the lower & indented disc.

    She has mentioned that it may be necessary to reformat the drive, then install if this does not work.
  6. haxderek macrumors newbie

    Dec 6, 2007
    Panama City, FL
    I'm having the same problem here on my Aluminum Macbook. I'm wondering if it has anything to do with the linux partition I have. I'm trying to delete the partition now to see if that is the case.
  7. eme jota ce macrumors regular

    Jul 26, 2005
    Apple support had me repair the disc three times. Problem persisted.

    The are suggesting reformat my hard drive, then install. I'm reluctant due to the hassle or reinstalling other apps, finding registration codes...

    I'm wondering if I could use the Snow Leopard DVD to "restore" from my time machine backup as a work around.
  8. haxderek macrumors newbie

    Dec 6, 2007
    Panama City, FL
    Problem Fixed

    Booted up using the leopard install disc and deleted the linux partitions and formatted the Mac HD partition. Clean install worked like a charm.
  9. david803sc macrumors member


    Jul 11, 2008
    Lake Wylie, SC
    eMail from PGP Corp regarding Snow Leopard

    Had the same problem, with Leopard 10.5.8 also had the latest version of PGP installed, tried removing PGP, rebooted still no luck, I bit the bullet and had to repartition from the Snow Leopard install DVD and than it finally worked.

    After all of that I received the following email from PGP Corp tonight:

    PGP Corporation does not recommend using PGP® Desktop with Mac OS X 10.6 at this time, neither the 32 bit nor 64 bit versions of Snow Leopard are currently supported by PGP Corporation. This includes PGP® Whole Disk Encryption, PGP® Desktop Professional, PGP® Desktop Home and PGP® Desktop Email.

    This email is to advise you that if you are running PGP® Whole Disk Encryption, PGP® Desktop Professional, PGP® Desktop Home or PGP® Desktop Email, you should NOT upgrade to Mac OS X 10.6 (Snow Leopard).

    If you intend to upgrade to Snow Leopard, you must decrypt all PGP® encrypted drives and uninstall PGP® Desktop before upgrading the system to Mac OS X 10.6.

    After upgrading your system you should not attempt to re-encrypt any disks with PGP® Whole Disk Encryption as it is likely to lead to potential data loss or other system and data issues.

    We expect support for Mac OS X 10.6 to be available in the next major release of PGP® Desktop (10.0). PGP Corporation recommends waiting until PGP® Desktop 10.0 is available before upgrading to Mac OS X 10.6. If you would like to be notified when the beta version becomes available, please register at

    If you have questions about PGP® Desktop and Mac OS X 10.6, please visit our support site

    PGP Corporation announced PGP WDE for Mac OS X last year - a native Mac application that was designed from the ground up for the Mac. PGP Corporation is committed to providing Macintosh users the best possible encryption solutions and we’ve been building them since re-starting the company in 2003.

    The overall experience of PGP WDE for Snow Leopard will be the same. You’ll notice PGP WDE for Mac OS X is controlled using PGP Desktop, which can be expanded to secure email and files as well.

    Users of PGP WDE for Mac OS X will have a new pre-boot authentication screen that protects access to the machine before the operating system loads. To see some of the work so far we have posted screen shots to the PGP Perspectives blog.

    PGP® Worldwide Support Team
  10. eme jota ce macrumors regular

    Jul 26, 2005
    Apple Forum has posted a quick fix to this problem

    Looks like several people have had success with a fairly approach.

    In Disk Utility, select your boot disk at the top level (not the lower, indented name but the higher drive identifier), then click on partition. In the lower right hand corner of the partition window, make the partition a little smaller. Some are saying just a1GB, some are saying just adjust it smaller, then adjust it back.

    Hope it works...
  11. Guy Mancuso macrumors 6502a

    Mar 28, 2009
  12. craignied macrumors newbie

    Aug 29, 2009
    10.6 procedure

    Just moving around the partition then returning it to its original size didn't work for me, and I'm not running PGP. How I got 10.6 to install:
    1. Boot into 10.6 install DVD
    2. Run the disk utility from there, resize the primary partition (don't add a new one) by decreasing it about 5 gigs
    3. Commit the change by hitting "Apply"
    4. Reboot, again into the 10.6 install DVD
    5. You can then install 10.6
    6. Once 10.6 is installed, use the disk utility on the desktop (you can boot into the primary HD at this point) to resize the primary partition to its original size.
    Hope this helps others...
  13. mapilla macrumors newbie

    Aug 29, 2009
    10.6 Procedure

    Hi craignied,

    Your remedy worked perfectly. I did not use PGP. The only thing I did on my 1 year old MacBook was to swap out the original hard drive for a larger one.

    I found that I did not need step 4 in your instructions. After I hit "apply" to make the partition change, I went back to the install instructions and the "!" was gone as well as the error message.

    Thanks very much.
  14. craignied macrumors newbie

    Aug 29, 2009
    10.6 procedure

    Thanks, Mapilla :) For me, step 4 was necessary--although at that point the exclamation point was gone, the install button was ghosted and would not let me click it until I rebooted into the DVD. Just to let others know if they experience that ghosted install button... :)
  15. h2fnd macrumors newbie

    Oct 26, 2009
    I research this issue when I purchase my SL, i tried to install it on my MBP 2.0 ghz core duo it's about 4 years old but still works like a charm... Anyway, some article mentioned about removing PGP, this is not the case. Repartition and revert it back, nope not even I went on for 1 day researching this and decided to go back to the apple store at Cuppertino, talk to Erez (Apple Employee) and decided to replace the my SL with a different disk and EUREKA... it WORK!!! so my suggestion is if you purchase SL and are having this same issue just replace it the disk. A friend of mine had the same issue and I loan him my DVD for SL and it work...
  16. kuprion macrumors newbie

    Dec 8, 2009
  17. xxundrclssherox macrumors newbie

    Feb 11, 2009
  18. bungiefan89 macrumors 6502a

    Apr 5, 2011
    I absolutely HAD to make an account on this website so I could THANK YOU for helping me out here. Your instructions worked beautifully, and now I have a beautiful desktop computer that started off as a lower-end Tiger-running iMac and has now changed into a high-powered Snow Leopard-running iMac that I can play all my Steam games and Starcraft 2 on.
    Follow these instructions people, they really do work!
  19. BoricuaDna macrumors newbie

    Jul 18, 2011
    Won't Let Me Use Disk Utility

    I heard that this has worked but do you have another suggestion? I booted from the DVD but it says I cannot install this OS on this computer, thus, I can't access the disk utility. It's blanked out so I can't click it.

    Trying to reinstall OS on MacBook Air and the external cd drive doesn't work. Using Remote Install
  20. binhex12 macrumors newbie

    Aug 4, 2005
    Tried this on my iMac running 10.5.8 and still can't get it to install Snow Leopard.
  21. pinetops, Aug 18, 2011
    Last edited: Aug 18, 2011

    pinetops macrumors newbie

    Aug 18, 2011
    Also works with OSX Lion Install

    I ran into this issue when upgrading Snow Leopard to Lion. I had BOOTCAMP and Linux partitions with rEFIt setup to triple boot. However, I do not use the Linux nor Bootcamp partitions anymore because they stopped working correctly at some point and I never needed them enough to fix them. I was fine simply deleting them and using iPartition to remove the partitions and max out the size of my OSX partition. However, OSX Lion install still did not want to install to my updated OSX partition saying that the system could not boot from this disk. So I created an OSX Lion boot USB drive following instructions found on the internet, booted this USB drive and used the OSX Lion Disk Utility to lower the size of the OSX partition by 5 GB. Once Lion installs, I will use the desktop Disk Utility to put the partition size back to the maximum. (Thanks for the tip, Craignied!)

    Forgot to mention that I did run Snow Leopard Disk Utility on my OSX partition to repair a bunch of errors prior to reducing its size via the Lion Disk Utility. That may have been a factor in this method working for me.
  22. SweetzDesigns macrumors newbie

    Aug 27, 2011
    Thank You!

    I too had to create an account just to say thank you, I was trying to solve this for ages and this worked Flawless! Remember after resizing the partition you have to restart your computer and run the installer for the changes to take affect.:D
  23. Polska macrumors member

    Mar 9, 2008
    Rio de Janeiro - RJ
    I tried this solution but still did not work. When I try to resize my partition, when Disk Utility is resizing, it stops in the middle saying it cannot resize it. I even formatted the hard disk already and still says it cannot install Snow Leopard on that hard disk. The problem is it runs 10.5.8 flawlessly and the hard disk does not seem with any problem. Any suggestions?

  24. palomino0513 macrumors newbie

    Mar 26, 2011
    I also get and error message when I try and partition it. How do I fix this issue?
  25. RossanaR macrumors newbie

    Jul 18, 2012
    Just wanted to say thank you. After 18 hours of frustration and trying every other suggeston posted here And elsewhere, your instructions did the trick. The re-partitioning did the trick. Thanks a million.


Share This Page