Snow Leopard(?) won't recognize external DVD drive

Discussion in 'Mac Accessories' started by zzzuppp, Sep 24, 2009.

  1. zzzuppp macrumors member

    Joined:
    Sep 17, 2004
    #1
    I have a Pioneer DVR-106D external DVD drive/burner,Firewire (only).Used to work just fine under Leopard,but since Snow Leopard upgrade,the System Profiler only sees it as 'Unknown Device' and DVDs etc loaded into it do not mount in iTunes/DVD player etc.

    This is what Sys Profiler says:-
    FireWire Bus:

    Maximum Speed: Up to 400 Mb/sec

    Unknown Device:

    Manufacturer: Mapower
    Model: 0x1
    GUID: 0x48300500098BE
    Maximum Speed: Up to 400 Mb/sec
    Connection Speed: Up to 400 Mb/sec
    Sub-units:
    Unknown Unit:
    Unit Software Version: 0x10483
    Unit Spec ID: 0x609E
    Firmware Revision: 0x130
    Sub-units:
    Unknown SBP-LUN:


    Is it a Snow Leopard/Firewire problem? My other FW external HDs are working fine...
    Is there something I can do?
    The firmware available for the drive only seems to be for PCs (.exe file) and I'm not sure what to do with it even if I could open it.

    NB The internal DVD that came with my Mac has never worked properly,so that isn't a solution.
    __________________
    1) OS X 10.6.1 iMac 5,1 Intel Core 2 Duo 2.16 GHz
     
  2. goMac macrumors 603

    Joined:
    Apr 15, 2004
    #2
    Why did you never get your internal DVD fixed under AppleCare?

    For the external, did it always just work out of the box, or did you have to use something like PatchBurn?
     
  3. zzzuppp thread starter macrumors member

    Joined:
    Sep 17, 2004
    #3
    It always just worked.
    Haven't done an Apple Care because I got my iMac as a refurb and the warranty was only a year,in which time I didn't notice that it had the problems.
     

Share This Page