Snow Leopard -> Yosemite Migration. MAIL does not open / mail index damaged

Discussion in 'OS X Yosemite (10.10)' started by fyrebear, Nov 4, 2014.

  1. fyrebear macrumors newbie

    Joined:
    Nov 4, 2014
    #1
    Got a new 2014 rMBP (10.10 Yosemite) and did a Apple Migration from a 2007 MBP running 10.6.8 Snow Leopard.

    But I am unable to open MAIL. I get the message: "Your Mail index has been damaged.* To repair it, quit Mail.* Mail will repair the index the next time you open Mail.* Your mailboxes and messages will be preserved."

    I quit MAIL, open up again and get the same message.

    I am nowhere close to an APPLE Store so any suggestions on how to fix this is very much appreciated!
     
  2. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
  3. fyrebear thread starter macrumors newbie

    Joined:
    Nov 4, 2014
    #3
    Bruno09, thanks for responding and posting that link. I have in fact tried that solution and still get the same result. MAIL tries to rebuild the index and I still get the error and the endless loop of options.

    I have about 7 POP accounts.

    I have seen some other posts similar to my issue on the Apple Discussion forums so I know some others are having similar issues. But I have not been able to find a solution to the problem.

    I am hoping the fine folks of MacRumors Forums can offer some ideas! :)
     
  4. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #4
    Another way would be deleting one existing mail account in Yosemite, then re-creating it, then using : File / Import mailboxes, from : Apple Mail.

    Browse your old computer to ~/Library/Mail/Mailboxes, select and import.
     
  5. fyrebear thread starter macrumors newbie

    Joined:
    Nov 4, 2014
    #5
    Bruno09, that won't help me in this situation as I can't even open the Apple Mail application to do the "File / Import mailboxes."

    Before I can even get to the step of running MAIL, the program wants me to fix the damaged indexes. I click through the process like in the OP and it just is the same loop. :(
     
  6. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #6
    I understand.

    Wouldn't you be interested in turning your POP accounts into IMAP accounts (*) ?

    This would solve the problem, since when using IMAP you no longer need to import existing mailboxes....

    As for being unable to launch mail, this can be solved by deleting the :

    ~/Library/Mail folder.

    After deleting this folder, Mail will launch "as new" and offer to configure new mail accounts.

    (*) may sound strange, but is actually easy to do.
     
  7. pen-helm macrumors newbie

    Joined:
    Jul 9, 2013
    #7
    Snow Leopard -> Yosemite Migration. MAIL does not open / mail index damaged

    I have got the same problem! Help!
     
  8. pen-helm macrumors newbie

    Joined:
    Jul 9, 2013
    #8
    I got it to work. If I remember correctly, I Migrated from Tiger to a Snow Leopard machine.
    Then I had to Export my mail, contacts and calendars (see Mac Help), copy the exported files, and Import.
    Six thousand email messages were missing, but I got someone to write a Perl script that compares my Mail with my backup, and saves the missing messages for import.
     
  9. Calion macrumors newbie

    Joined:
    Jan 27, 2013
    #9
    Fixed!

    Fixed (for me at least) in 10.10.1. I reinstalled Yosemite, used Migration Assistant to bring over my data, upgraded to 10.10.1, then opened Mail. It converted, then quit, then converted *again* on relaunch…and worked. YMMV.
     

Share This Page