So, apparently Lion has removed the Quit confirmation in Safari.

Discussion in 'Mac OS X Lion (10.7)' started by benguild, Aug 19, 2011.

  1. benguild, Aug 19, 2011
    Last edited: Aug 28, 2011

    benguild macrumors 6502a

    Joined:
    Jul 29, 2003
    #1
    Try accidentally hitting Cmd+Q while uploading a video. Yay.

    Is there any way to turn this back on? I have auto-resume disabled.
     
  2. C64 macrumors 65816

    C64

    Joined:
    Sep 3, 2008
    #2
    This used to worked in Snow Leopard. Run in Terminal:

    Code:
    defaults write com.apple.Safari ConfirmClosingMultiplePages 1
    Haven't tested on Lion, so no idea if it works.
     
  3. benguild thread starter macrumors 6502a

    Joined:
    Jul 29, 2003
    #3
    Doesn't work :(
     
  4. danpass macrumors 68020

    danpass

    Joined:
    Jun 27, 2009
    Location:
    Miami, FL
    #4
    If I re-open Safari everything comes back to where it was; the same pages, same tabs, etc.

    Is that auto-resume?
     
  5. tootall macrumors regular

    Joined:
    Apr 17, 2011
    Location:
    Quebec, Canada
    #5
    It's odd, in my case quitting while downloading always results with a confirmation in Safari (I am running the latest Lion update).
     
  6. QuarterSwede, Aug 20, 2011
    Last edited: Aug 20, 2011

    QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #6
    This doesn't help your specific issue but you can disable or enable auto-resume on a per app basis.

    To disable - From Mac OS X Hints:

    If you've got auto-resume off system wide then to enable per app just change YES to NO.

    That's auto-resume.
     
  7. benguild thread starter macrumors 6502a

    Joined:
    Jul 29, 2003
    #7
    This works:
    defaults write com.apple.Safari NSQuitAlwaysKeepsWindows -bool true

    But if you do this:
    defaults write com.apple.Safari ApplePersistenceIgnoreState YES

    ... It doesn't. — So don't do the second one. :)
     
  8. benguild thread starter macrumors 6502a

    Joined:
    Jul 29, 2003
    #8
    OK, this is really starting to piss me off.

    Today I was filling out a long form on a website.
    Accidentally hit Apple+Q instead of Apple+Tab to switch Apps ... BOOM, everything gone. Sure, it reloaded a fresh copy of the page when I reopened ... but WTF!!!

    :mad::mad::mad::mad::mad::mad::mad::mad::mad:
     
  9. WytRaven macrumors 6502

    Joined:
    Mar 19, 2009
    Location:
    Orbiting Mercury
    #9
    OMG... So you can't operate a keyboard correctly and that means that everyone else using Mac OS should be encumbered by an unnecessary extra step every time they want to close a browser? Yeah, damn you Apple. Damn you to hell.
     
  10. Dale Sorel macrumors 6502a

    Dale Sorel

    Joined:
    Jan 12, 2003
    #10
    Interesting... you can set Chrome to warn you before quitting :cool:
     
  11. paulsalter macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #11
    Have you heard of options?, just like we had in snow leopard

    It's no extra step for you because you have the option turned off, those that want the confirmation have the option turned on
     
  12. benguild thread starter macrumors 6502a

    Joined:
    Jul 29, 2003
    #12
    They removed a useful feature.
     
  13. 3bs macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #13
    I know exactly how you feel! For the people who don't want to be asked if they want to close or not they can just turn it off but now the people who do want it don't have it. I just started a thread asking about it because I didn't see your thread here
     
  14. phunkie macrumors newbie

    Joined:
    Apr 24, 2012
    #14
    Hello,
    I encountered similar behaviour, really not sure what Mac OS X team was thinking about when they removed this feature. Safari sucks anyway, Chrome is like light years ahead in terms of UI.

    Nevertheless, I have to use Safari sometimes, here's a quick workaround for Command-Q ordeal: go to System Preferences -> Keyboard -> Shortcuts -> Application shortcuts, Add a shortcut for Safari "Quit Safari":

    [​IMG]

    Done! No more accidental escapes.
     

    Attached Files:

Share This Page