So did apple finally fix the SATA-II/firmware 1.7 issues?

Discussion in 'MacBook Pro' started by jjahshik32, Aug 2, 2009.

  1. jjahshik32 macrumors 603

    Joined:
    Sep 4, 2006
    #1
    I bought a 15" 2.8GHz mbp just a couple of weeks ago and did the 1.7 firmware upgrade (didnt know at the time that it could render your mb/mbp useless with 3rd party sata-II hdds).

    Anyway I tried installing a few 3rd party SATA-II hdds and they all didnt work. Well they did work except that I get a freeze under OSX every minute or two with the color wheel popping out rendering the mbp useless.

    So I came to my own conclusion that the 15" and 13" mbps all have a SATA-I controller and does not accept SATA-II hdds.

    Now I'm starting to look at the 17" mbp as this issue does not affect the 17".

    So what do you guys think? I know there were some 13" and 15" users of the new unibody mbp that applied the 1.7 firmware that can upgrade to an SSD or any other SATA-II hdd and worked fine.
     
  2. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #2
    Apple issued a firmware patch to enable the 3.0GBps speeds for the new 13/15.4" Unibody Pros shortly after their launch. I haven't heard of any issues with HD models, but the WD Scorpio/Seagate Momenteus lines are highly recommended as OEM replacement units.

    You probably should have posted this in the Pro forum though...
     
  3. Wicked1 macrumors 68040

    Wicked1

    Joined:
    Apr 13, 2009
    Location:
    New Jersey
    #3
    How do you get the new firmware my cousin just bought a new 13" and I want to make sure she gets the new firmware
     
  4. goMac macrumors 603

    Joined:
    Apr 15, 2004
    #4
    The 15" MBP has a SATA2 controller, it's just a firmware bug.

    Last I heard, a fix is coming...
     
  5. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #5
    I just got a 2.8 GHz MacBook Pro, put in my X25 and it would appear that the drive is running at full speed.
     
  6. mac jones macrumors 68040

    Joined:
    Apr 6, 2006
    #6
    just bought this last week


    Vendor: NVidia
    Product: MCP79 AHCI
    Speed: 3 Gigabit
    Description: AHCI Version 1.20 Supported


    apparently they were before:


    Vendor: NVidia
    Product: MCP79 AHCI
    Speed: 1.5 Gigabit
    Description: AHCI Version 1.20 Supported
     
  7. maxsquared macrumors regular

    Joined:
    Jun 27, 2009
  8. CompanionCube macrumors regular

    CompanionCube

    Joined:
    Aug 3, 2009
    #8
    This is a wrong conclusion. Please list specifically which drives you were trying to install.
     
  9. Nautigar macrumors regular

    Joined:
    Oct 4, 2007
    #9
    It seems only some MBPs are affected. I am running a new MBP 13" with a 2nd gen Intel X15-M 160G without any problems so far. The MBP came with Firmware 1.7 preinstalled.
     
  10. daxomni macrumors 6502

    Joined:
    Jun 24, 2009
    #10
    You download and install it just like any other update.
     

Share This Page