So far an unsolvable OSX Problem?

Discussion in 'macOS' started by saunderscc, Aug 28, 2009.

  1. saunderscc macrumors newbie

    Aug 28, 2009
    I know a lot of folks are discussing Snow Leopard, but I have a real problem I just can't resolve in 10.5.8.

    I have a 13" macbook that I take to work everyday. At my office, I have the 24" Apple LED monitor which I plug into each day. I shut my notebook off when I leave work. When I use it at home, I simply put it to sleep and plugging it into the monitor wakes it up.

    OK, sometimes application windows "forget" where they were positioned when going from 13" display to 24" display and vice-versa. Usually, this only results in a minor inconvenience of resizing or repositioning application windows on the desktop.

    However, last night when I got home and turned on my notebook, one of my applications actually opened outside of the boundaries of my 13" screen (along the left edge).

    When I use Expose', the window flies in from the left. When I select the application, the window returns outside the boundaries of my screen. I can not move the application back to my desktop because my mouse can't reach it.

    I've uninstalled/reinstalled. No dice. I've looked at the .plist file, but I don't know enough to determine if I could "force" it to open within the borders of my desktop. I've deleted the .plist file, but it regenerates. I've opened like 20 applications hoping my mac would "forget" the settings associated with this application (I think my machine remembers the last 10).

    I've searched the internet, but I've found nothing. Apple was a complete waste of time.

    Please help.
  2. fehhkk macrumors 6502a


    Jun 11, 2009
    Chicago, IL
    I've had that happen a couple times when waking up from sleep after using an external monitor. Since my monitor has larger resolution than the LED display, things tend to shift.

    I have noticed that, and it gets resolved by closing the lid, sleeping, and waking up.

    Doesn't happen every time, but I've noticed it...
  3. larkost macrumors 6502a

    Oct 13, 2007
    There are two solutions to this:

    1) Trash the preference file for the app while it is off and re-start it. Window positions are saved in that file.

    2) Change the resolution of your monitor. All windows (unless the developer has done a lot of work to undo this) will re-position themselves to be on-screen.
  4. saunderscc thread starter macrumors newbie

    Aug 28, 2009
    Neither of these work.

    It's maddening because I can see the "shadow" of the application window along the left edge of the screen when it's active.

    As for the sleep, reawaken, it doesn't work. I'm trying to get this fixed before I go to work on Monday.
  5. benj07 macrumors member

    Oct 26, 2007
    This sounds stupid...but make sure you aren't extending your desktop to the internal macbook screen or vice versa... It's weird how it positions off and you can still see the shadow.

    Also... you could try 'Window' -> 'Zoom'
  6. saunderscc thread starter macrumors newbie

    Aug 28, 2009
    Zoom doesn't help. What's strange is that "secondary" windows open on the desktop, but the "primary" application window is still stuck.

    I don't know how to "extend" my desktop. I can't find the option. Under system preferences, the max resolution is the resolution of the notebook screen.

    I just keep thinking there has to be a way to "force" the primary application window onto my desktop using XCode, or something. Clearly, my mac is putting it into the same location each time regardless of what I do.
  7. kasakka macrumors 68000

    Oct 25, 2008
    Have you tried going to Displays and hitting the Gather windows button? I think this only works with multiple displays connected though...
  8. saunderscc thread starter macrumors newbie

    Aug 28, 2009
    Thanks for the suggestions.

    I ended up downloading MercuryMover and moving the window using keystrokes.

    Once I had the main application window on my viewable desktop, I was able to close it and reopen in the viewable area.

Share This Page