So frustrated by disappearing mouse cursor (and Time Machine still) - new 15" MBP

Discussion in 'MacBook Pro' started by MareLuce, Dec 16, 2016.

  1. MareLuce, Dec 16, 2016
    Last edited: Dec 16, 2016

    MareLuce macrumors 6502

    Joined:
    Sep 26, 2010
    #1
    I am so frustrated right now. This new MacBook Pro is starting to feel like an endurance test.

    And I'd bet I have a higher than average tolerance for the need to overcome technical problems.

    Config is a 2016 15" MBP 2TB. I am new to Mac OS; coming from a Thinkpad / Windows.

    I experienced the Time Machine problem where the MBP rebooted constantly when attaching an external hard drive. Just installed the latest Mac OS that fixes that problem.

    My guess is my Time Machine problems are my fault because I can't figure it out, but the disappearing mouse cursor makes figuring it out impossible.

    Problems:
    - When I launch Time Machine with a new Seagate 4TB Backup Plus drive attached, I only see a screen like this. No mouse cursor ever becomes available to me. I double-tap, triple tap, do all sorts of gestures. No mouse cursor. Just the screen. I try to guess menu commands. Nothing works. I reboot.

    [​IMG]

    Is this how it's supposed to work?

    Is time machine automatically doing something when I'm frozen at that screen?

    2) When I blamed the drive for these problems, I was using a new Western Digital My Passport 3TB Ultra.
    So I bought the Seagate instead. (before reading here that it was MacOS problem, not the drive)

    Now - with the Seagate, I'm looking for a format command or how to make it work with the Mac. I don't see a format command in Disk Utility. Just Erase.

    I did eventually install the Seagate app shown below, It's supposed to let it work with Windows. I installed it to see if that would fix the mouse cursor problem. It doesn't. I don't really care if the drive works with Windows or not. I just want to dedicate that drive for MBP backups.

    Now after I rebooted and re-launched Time Machine and I see this

    [​IMG]

    but still my mouse cursor has vanished.

    I have > 1 TB of data on the MBP now. I do not think I've had a drive attached long enough to do a full Time Machine backup.

    Does what you see on that screen mean that my Mac thinks it has full backup at those intervals on the right side?
     
  2. leman macrumors 604

    Joined:
    Oct 14, 2008
    #2
    Sounds very annoying :( I never use the TM app, so I can't really help you here. But I find it much easier to recover the data from finder. Simply open your TM backup in Finder and navigate to a respective folder (they are named after backup dates).

    Yep, erase does a format. Its the same thing. Just the question of terminology.
     
  3. MareLuce thread starter macrumors 6502

    Joined:
    Sep 26, 2010
    #3
    How do you do your backups if not via Time Machine? Did you buy something?
     
  4. Sohappy macrumors member

    Sohappy

    Joined:
    Nov 19, 2016
    #4
    I'm new to Mac too. I used My LaCie for Time machine and it went smoothly. You have apple assistance for 3 months even if you didn't take apple care. Why don't you have them help you.

    When choosing when you format you must opt for Mac OS Extended (Case Sensitive, Journaled). But I didn't even used Disk utility. When you choose your disk in Time Machine, it formats it for you if it's not in the correct format.
     
  5. leman macrumors 604

    Joined:
    Oct 14, 2008
    #5
    Using time machine does not require you to use the time machine app. You set up the backups via the system preferences and you can recover backups via terminal.
     
  6. pm3009, Jan 22, 2017
    Last edited: Jan 25, 2017
  7. myscrnnm macrumors 6502a

    myscrnnm

    Joined:
    Sep 16, 2014
    Location:
    Seattle, WA
    #7
    I also get the disappearing cursor when I restart my system. But fortunately it appears when I do multitouch gestures. Still annoying though, and hopefully something that's rectified in the next iteration of macOS. I am very happy with the state of Apple's hardware at this point, but it feels like their software has gotten sloppier (e.g. macOS and iOS).
     
  8. Sanpete macrumors 68020

    Joined:
    Nov 17, 2016
    Location:
    Utah
    #8
    Not quite the same thing, but I've had the cursor disappear from time to time too. It works, in that I can see when it passes over something that it would alter, or if I click on a button or link it functions as normal, I just can't see the cursor itself. If I move it to the dock, it reappears. That's not new with the 2016 or Sierra. Same thing happened in Mountain Lion on my 2011.
     
  9. pm3009 macrumors newbie

    Joined:
    Sep 20, 2006
    #9
    --- Post Merged, Jan 25, 2017 ---
    I purchased a brand new late 2016 model 15" MacBookPro this week (Jan 18, 2017). It has a Intel i7 Quad Core CPU with a 1TB SSD drive and is running Mac OS Sierra v10.12.2. Every time I entered Time Machine, I had the exact same problem as the user in this post had. At first I thought entering Time Machine was causing my Mac to freeze, but I realized that Siri was working fine, so the Mac wasn't really frozen. The issue was that my mouse vanished every time I entered Time Machine and I couldn't input anything from the track pad. It took me several days to get the issue resolved and it was driving me crazy. I'm posting this because others are obviously experiencing this too, so I hope to save others a lot of frustration.

    Every time I entered Time Machine, my mouse cursor vanished. Exactly like in the screenshot the user posted below. The only way I found I could get it back was to either hit the escape button or close the lid for a second and reopen it. But the problem with those solutions, was that it exited time machine and seemed to dump me into the File Finder. My Mac behaved normally after getting existing out of Time Machine. The issue was very reproducible and occurred 9 times out of 10.

    I have a brand new 2TB "Seagate Backup Plus Slim For Mac" external drive with a brand new genuine Apple USB 3.0 to USB-C adapter.

    - First thing I tried was shutting down the MAC and restarting it. Same Problem
    - I tried all 4 USB-C ports, Same Problem
    - I tried a different external drive - a 128GB Thumb drive, Same Problem.
    - Tried formatting the 2TB three different times (Mac OS Extended (Journaled) / GUID) - Same Problem.

    I finally called Apple Support. The first thing they suggested that I do, is everything I had already done above. They then had me restart my Mac in Recovery Mode. To do this, they told me to start up my Mac with the Option Command P and R pressed, but from what I have found on the Web, this resets NVRAM.
    The command to restart a MAC in recovery mode seems to be Command and R. NVRAM is "non-volatile random-access memory," a small amount of your computer’s memory that stores certain settings in a location that macOS can access quickly. I can see why they might want me to reset NVRAM, but they stated they were having me do that to reboot the MAC in recovery mode. Issue was still present after resetting NVRAM.

    Next thing they had me do was restart my Mac in Safe Mode by holding the shift key when starting up the Mac. (Safe mode, sometimes called safe boot, is a way to start up your Mac so that it performs certain checks and prevents some software from automatically loading or opening). Issue did not occur. Mac was very sluggish but support said this is normal when in safe mode.

    Next thing they had me do was to restart the Mac and log into a different user account. Luckily I had a second account with admin rights set up. I didn't even set this second account up intentionally. When I first brought home my new Mac and went through the setup Wizard, I ended up with two user accounts with Admin rights and one guest account. Looks like it's a very good idea to have a second user account set up with Admin rights for testing. No software or any changes should ever be made in this second user account so that you have a clean system for testing. The Problem was not present under this second user account, so this pointed to a corrupt user account. Apple told me the issue appeared to be a corrupt file, and I could either reformat my Mac and copy all of my files back to it, or delete my main user account and copy all of my data to the second user account. That logic didn't make sense to me if it was a corrupt file because I would likely be copying the same corrupt file back to the Mac. I really had to narrow it down to what file(s) was causing the issue.

    Resolution:

    - I copied all of my data to my external drive (straight copy, not Time Machine).
    - Deleted my main User account as it appeared to be corrupt.
    - The only software I had installed on my new Mac was Microsoft Office 2016 for Mac. First thing I did on my new User
    Account was to re-install MS Office to it to make sure that wasn't the problem. No issues with Office installed on my
    new User account.
    - Instead of copying all of my data over to my new User account, I copied one large folder at a time and retested before moving to the next folder. First I copied over all of my photos which was the bulk of my data. (maybe 75% of more of my data). I figured I'd really narrow down the problem file(s) if the issue didn't occur with all of my photos copied over. I tested Time Machine and it behaved normally. No disappearing cursor. I then copied over all of my Music and retested. Time Machine still behaved normally. That left just my documents. Which was a small amount of my data. Copied over my documents and retested. Time Machine still behaved normally and been working great since I did this.

    So bottom line... issue was caused by a corrupt User Account. Why the user account was corrupt on my Mac that was only a few days old...is a mystery. It was a good lesson though on steps to troubleshoot and I'll always make sure now to keep a clean user account with Admin Rights which will only be used for testing.

    Pam



     
  10. GatorGhost macrumors regular

    GatorGhost

    Joined:
    Jun 30, 2014
    #11
    Just a wild guess....but in an earlier thread some users found when they went to accessibility properties and increased the size of the mouse cursor...the result was temporary mouse and screen locks. Not sure for your issues, but if you have changed your mouse cursor size...maybe reduce it to default and see if makes a difference. As I said...just a wild guess.
     
  11. wilsonlaidlaw, Apr 25, 2017
    Last edited: Apr 25, 2017

    wilsonlaidlaw macrumors 6502

    wilsonlaidlaw

    Joined:
    Oct 29, 2008
    #12
    I too have been having cursor problems in Time Machine and Photoshop. I had an enlarged cursor in accessibility properties and when I reset it to normal, the problems disappeared. Pity Apple Tech did not know about this one and have been asking folks to pretty much wreck their machines and rebuild for a bug that is Apple's fault. The bug reporting system seems to work pretty well if you are in Beta OS software, otherwise I suspect bug reports get filed in the ground level cylindrical filing system.

    PS Filed a full Serious Bug report - will see what action ensues
     

Share This Page