So I screwed up... Some help would be greatly appreciated! :p

Discussion in 'Windows, Linux & Others on the Mac' started by Reach, Jan 6, 2012.

  1. Reach, Jan 6, 2012
    Last edited: Jan 6, 2012

    Reach macrumors 6502a

    Joined:
    Sep 7, 2006
    Location:
    Norway
    #1
    Well, short story - tried to install Windows 7, didn't do it through BootCamp, and now my Mac is acting very strange...

    Setup: Lion, Mac Pro, Windows 7.

    1. I first started to install windows via the Bootcamp-assistant. But when it started the windows setup thing and I chose the free disk I wanted to use, I got an error 0x80300024. Googled, and found out that I should remove my Mac-disks while installing. Well, silly me, I did, and it fixed that, because when I started blank from the disk now I could install Windows alright.
    End of stage 1: windows works, everything nice and dandy.

    2. Now I shut it down, wanting to start in my Mac. Reinserted the three other disks I had removed, rebooted and held down the option-key. No luck, still started in windows. Strange, I thought, and I couldn't see any disk but the Windows-disk... Shut down, removed the windows-disk and restarted, thinking that would get me back to my Mac. No such luck! Blank underscore blinking, then "No bootable device...." etc. What... Tried several times holding the option-key, but no - no Mac! Wouldn't boot to Snow Leopard disk either... (When holding "c" while starting.)
    End of stage 2: Can't boot OSX...

    3. Back in with the Windows-disk, and now it boots again. To windows of course, but with the Snow Leopard-disk I can at least install the Boot Camp-tools. Did that, and was relieved to see I got the "Startup disk" in the BootCamp control-panel! When I chose the Mac-drive there I finally got back to my Mac. When I restart, and hold alt, still goes to Windows...
    End of stage 3: I can get to OSX via Windows...

    ---

    So, my question is: what have I really done here? Is there some part in the machine that was PC'ified by me messing this up, so that it won't work properly no more (as in, booting to my Mac without having to go through Windows for example...) I have heard of EFI, but really have no idea what I does. The only thing I can think of is that Windows has somehow overwritten some Mac-code in some bootpart of the Mac that is not on a disk or something.

    Any tips on how I can fix this mess is greatly appreciated!
     
  2. Reach thread starter macrumors 6502a

    Joined:
    Sep 7, 2006
    Location:
    Norway
    #2
    Sorry for the bump, but no one has done/seen something like this?
     

Share This Page