So I'm guessing I shouldn't upgrade to 2.1

Discussion in 'iPhone' started by macfearless, Oct 2, 2008.

  1. macfearless macrumors regular

    Joined:
    Jan 15, 2008
    #1
    Yeah, so I'm about to be on my third iPhone 3G (I know, I know... many others have gone through quite a few) Regardless, the first one I got worked fine up until a couple of weeks ago when I upgraded to 2.1. Then it decides to give me this error "The iPhone _ cannot be used with iTunes because the information required for activation could not be obtained from the iPhone." Take it in, get it replaced for a new one. Now, after upgrading to 2.1 on the new one that has been working fine, I'm getting the same error. This sucks.
     
  2. rockinrocker macrumors 65816

    rockinrocker

    Joined:
    Aug 21, 2006
    #2
    that's weird. 2.1 fixed most (if not all) of the problems i was having.

    itunes itself up to date?
     
  3. mcdj macrumors 604

    mcdj

    Joined:
    Jul 10, 2007
    Location:
    NYC
    #3
    sounds like a computer and/or iTunes problem to me.
     
  4. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #4
    +1. I haven't heard about anyone else having this problem. You could avoid upgrading to 2.1, but that might only delay the inevitable. Also, I have a feeling that by now, replacements come with 2.1 pre-installed.
     
  5. macfearless thread starter macrumors regular

    Joined:
    Jan 15, 2008
    #5
    I don't know, 2.1 had been out maybe a week and a half before I got this current one, and it had 2.0 from the store. However, while I was standing at the genius bar, the genius helping the guy next to me (who was having the same problem) said that this was becoming a common problem with the update to 2.1. Could very well be a coincidence... Either way, got my appt. for this afternoon to take the gamble on getting a new one. Yippee:rolleyes:

    Oh yeah, both times that it has done this i was browsing in safari and safari froze. any insight to that?
     

Share This Page