So is my iPod Touch truly broken?

Discussion in 'iPod touch' started by hotheadedjonny, Oct 24, 2009.

  1. hotheadedjonny macrumors newbie

    Joined:
    Oct 17, 2008
    #1
    I honestly believe my iPod is broken. I know how to reset an iPod Touch, by holding down the two buttons at the same time and such. I know to connect it to the computer, how to recharge it etc.

    This is what happened. I went over to a friend's house, and plugged my iPod touch into her speakers. I believe that her speakers use the old charging method (the one with a firewire cable) because after plugging in my iPod, a message came up on the screen that 'charging is not supported by this accessory' for a second, then my iPod shut off. It just died. I've tried resetting it, plugging it into my USB wall charger, plugging it into my computer. Nothing works.

    So my theory is that her speakers overloaded my iPod with power, blowing out something inside. In which case, is there anything that I can do? My warranty has run out already, what's my best course of action?

    Thoughts?

    EDIT: I'm particularly annoyed because this really shouldn't happen, I've plugged my iPod Touch into my Altec Lansing iM7 speakers many times before, which runs on the old charging method, yet it hasn't broken my iPod.
     
  2. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #2
    Try plugging it in and holding down the lock and home buttons until it turns on.
     
  3. hotheadedjonny thread starter macrumors newbie

    Joined:
    Oct 17, 2008
  4. instaxgirl macrumors 65816

    instaxgirl

    Joined:
    Mar 11, 2009
    Location:
    Edinburgh, UK
    #4
    You know, a friend of mine's iPod broke when she took it out of my speakers (this was years ago, 2007). It just died the moment she took it out of them and it never worked again.

    Not the same, but I've always been a bit suspicious since then :(
     
  5. lozzy1234567890 macrumors member

    Joined:
    Jul 9, 2008
    #5
    try holding them both down, for 5 seconds then taking on button off, and hold the other for another 5 seconds, and vice versa. if the apple appears, u can take ur fingers off :)
     
  6. hotheadedjonny thread starter macrumors newbie

    Joined:
    Oct 17, 2008
  7. dukebound85 macrumors P6

    dukebound85

    Joined:
    Jul 17, 2005
    Location:
    5045 feet above sea level
    #7
    it may be low on batt

    let it charge for an hr and then retry holding the buttons
     
  8. Mlrollin91 macrumors G4

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #8
    Make sure its completely off, in which I would assume that it is.

    Hold down the home button for 3-5 seconds, without releasing, plug into the computer, continue holding for another 8-10 seconds and the iTunes logo should appear, putting it in recovery mode. I had the same problem with an old dock and that seemed to fix it for me.

    Good luck
     
  9. hotheadedjonny thread starter macrumors newbie

    Joined:
    Oct 17, 2008
    #9
    tried everything suggested in this thread, nothing.
     

Share This Page