So many problems with FCE4 (Most importantly I can't import)

Discussion in 'Digital Video' started by FroColin, Apr 25, 2010.

  1. FroColin macrumors regular

    Joined:
    Jun 4, 2008
    #1
    I have a 20" Aluminum iMac, 3 gb RAM, Intel Core 2 Duo 2.4 GHz. It's about two and a half years old. I have had Final Cut Express 4 for a couple years, and every once in a while it has major problems. I am trying to decide if I should just go back to iMovie (Which I hate) until I buy production premium CS5 or if I should reinstall. (This would be the fourth time I have reinstalled FCE)

    The problems include, crashing, this happens when I'm not using it or when I am. I can open it up, walk away from my computer and then come back ten minutes later and it will have crashed. Also it just stopped recognizing my camera, I have an Canon Vixia HF10 which is AVCHD so I have to log and transfer it. I did check and iMovie is recognizing the camera so it's not the cameras fault.

    Why does this keep happening to me? It it because I am doing stupid things or is my computer too old. Could the fact that I installed a very old version of Final Cut Studio have any thing to do with it? I thought I deleted all the files but maybe not.... Any help would be very much appreciated.
     
  2. puckhead193 macrumors G3

    puckhead193

    Joined:
    May 25, 2004
    Location:
    NY
  3. FroColin thread starter macrumors regular

    Joined:
    Jun 4, 2008
    #3
    Oh yes I forgot to mention this, I have a terabyte hard drive that I use for my capture scratch and also for the files them selfs. It has about 200 gbs left. The computers hard drive only has 15.
     

Share This Page