So the iPad wont get iMessages unless the message is sent to email?

Discussion in 'iOS 5 and earlier' started by bbplayer5, Oct 17, 2011.

  1. bbplayer5 macrumors 68030

    Joined:
    Apr 13, 2007
    #1
    Is this a bug? No phone contact I have is going to select "email" when texting me... Isnt it supposed to take ANY iMessage sent to you and convert it to something your iPad can sync with?
     
  2. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #2
    Text is sent over phone lines to the phone number. iMessage is sent over the internet (iCloud) and is linked with an email(s) address. Apple has combined the 2 but text is green and iMessage is blue. Apple has no way or right of aqquring the phone companies text message and sending it to an iPad.

    You can only receive iMessage (blue) messages on your iPad.
     
  3. Geckotek macrumors G3

    Geckotek

    Joined:
    Jul 22, 2008
    Location:
    NYC
    #3
    That's not the question being answered.

    And yes, it appears that iMessages directed to a phone # do not deliver to the iPad.

    I have setup my caller ID on my iPhone to be my Apple ID e-mail address. This way I will hopefully begin to get all my iPhone friends to use that instead.
     
  4. Menel macrumors 603

    Menel

    Joined:
    Aug 4, 2011
    Location:
    ATL
    #4
    It's not a bug, it's a deficiency in the design of their service.

    On your phone, go into settings -> messages -> Receive At -> Caller ID

    Set this to your AppleID, or any email that you configure to receive at both devices.

    When you respond to a blue iMessage, their end will pick up on that, and shift response path accordingly.

    You have to start a conversation with your phone, but you can continue it on your iPad.
     
  5. bbplayer5 thread starter macrumors 68030

    Joined:
    Apr 13, 2007
    #5
    The phone picks up conversations started on the ipad regardless. The problem is, some of my contacts dont know my apple ID email address, so they dont know who is sending them the message.. I guess they can get used to it though being that it will continue to do so.. Hopefully they add my email to my contact so they wont know the difference.

    Thanks!
     
  6. DotCom2, Oct 17, 2011
    Last edited: Oct 17, 2011

    DotCom2 macrumors 68030

    Joined:
    Feb 22, 2009
    #6
    Just make sure your friends have your Apple ID email address in their contacts as well as your phone number. Now on you iphone in Receive At: have both your phone number and your Apple ID email address listed and have a check mark on your Apple ID email address for the "Receive At". That way you will receive iMessages on both your iphone and your ipad. Obviously your ipad doesn't have a phone number but your iphone does. So when someone iMessages you, it will go to your iPad because you have set it to go to your apple id email address and it will go to your iphone because on your phone you have both the phone number AND email address listed which are tied to each other. You will see a blue bubble in both your phone number and Apple ID email address indictating they are set up for iMessage.
    You can also do the reverse. Say you have a family iPad that your whole family uses and you don't want your iMessages going to the ipad for everyone to see. In this case, on the "Receive At;" put a check mark next to your phone number and it won't go to the iPad.
     

Share This Page