General So this is bad

Discussion in 'Jailbreaks and iOS Hacks' started by td1439, Sep 22, 2014.

  1. td1439 macrumors 6502

    td1439

    Joined:
    Sep 29, 2012
    Location:
    Boston-ish
    #1
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Damn, is that patched on ios 8?
    Is it only applicable to ios 7.1.x?
     
  3. HenryLong macrumors 6502

    HenryLong

    Joined:
    Apr 11, 2013
    Location:
    Germany
    #3
  4. Exploding Hat macrumors newbie

    Joined:
    Sep 17, 2008
    #4
    I guess there's next to no chance that they'll release a security update to 7.x for people like me who want to keep their phone on 7?
     
  5. Asator macrumors 6502a

    Asator

    Joined:
    Apr 8, 2011
    Location:
    Australia
  6. some1uDNTknow macrumors regular

    some1uDNTknow

    Joined:
    Sep 27, 2009
    Location:
    United States
    #6
    Apple does notice major security flaws, they will most likely release an update to resolve this issue, but no one knows when...
     
  7. Dwalls90 macrumors 601

    Dwalls90

    Joined:
    Feb 5, 2009
    #7
    If it was realized a day ago, then it wasn't patched in iOS 8. It probably won't be in iOS 8.0.1 either since that's due for a release any day now.

    Probably in 8.1 which is due out with Yosemite and the new iPads in mid/late October.

    Unfortunately, I can't see an iOS 8 jailbreak before mid/late October, but who knows.
     
  8. IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #8
    One of the comments in that link mentioned it was already patched in 8 & linked this doc: http://support.apple.com/kb/HT6441?viewlocale=en_US&locale=en_US There's certainly a Core Graphics exploit listed in there that deals with malicious PDF files.

    Apple seems unlikely to go back and fix this for us who want to stay on 7, though there was some discussion in the comments indicating that perhaps they'll fix it for those using the iPhone 4, which can't update to iOS 8. But for JBers on 7, I think we're stuck hoping for a patch to pop up really soon...
     
  9. td1439 thread starter macrumors 6502

    td1439

    Joined:
    Sep 29, 2012
    Location:
    Boston-ish
    #9
    My guess would be any 7.1.3 would be for pre-4S only.
     
  10. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #10
    I doubt it.
    There was plenty of bugs and security exploits on other last kind of ios versions. They never updated those unsupported devices any more. They just patched up the holes on the latest ios version and left the old unsupported devices high and dry on old firmware.
     
  11. srf4real macrumors 68030

    srf4real

    Joined:
    Jul 25, 2006
    Location:
    paradise beach FL
    #11
    I don't think it's much to be concerned about. I have an old G5 Power Mac running OS 10.5.8 and it is not infected with any malware or viruses never has been. Yep still stable rocksolid without any Apple patches for years now. I wouldn't be scared to keep an old phone on old firmware vulnerabilities or no.
     

Share This Page