So this is Weird - Click problems in Lion

Discussion in 'Mac OS X Lion (10.7)' started by Romf, Aug 22, 2011.

  1. Romf macrumors regular

    Romf

    Joined:
    Jun 11, 2011
    Location:
    Paris, France
    #1
    Hi everyone

    So I'm creating this thread because I've seen noone with the same problem as I have.

    I have a late 2009 iMac and installed Lion like 2 weeks ago.
    It's basically working great except for one thing. I have a magic mouse and a magic trackpad.
    Sometimes (but quite often in fact, as I noticed it and now notice it often) my clicks just don't work.
    It is not specifically a double click, it is basically any click or tap on any of the devices (everything is ok under system preferences, devices have plenty battery, are not far from the mac...). I just have to try a 2nd time and it works.
    It is getting really annoying...

    Anyone aware of such a problem?

    Thanks!
    And I've NEVER had such a problem in SL, with exact same configuration...
     
  2. basher macrumors 6502

    basher

    Joined:
    May 27, 2011
    Location:
    Glendale, AZ USA
    #2
    I use the Magic Trackpad, Magic Mouse and a Logitech mouse all hooked up to my iMac running Lion and I've had zero input device issues.
     
  3. Romf thread starter macrumors regular

    Romf

    Joined:
    Jun 11, 2011
    Location:
    Paris, France
    #3
    Still having this problem.

    I reseted th pram and thought it helped but in fact it didn't... Anyone with an idea?
     
  4. paulsalter macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #4
    not sure of a fix, but think I have similar and cant see what causes it

    occasionally if I go to click on a link on a web page, nothing happens, try clicking again and it just highlights the link

    move the pointer away and back onto the link and it works fine
     
  5. Romf thread starter macrumors regular

    Romf

    Joined:
    Jun 11, 2011
    Location:
    Paris, France
    #5
    Yeah that's it.

    The thing that's worrying is I didn't find anything on Apple forums... I might send them a word
     
  6. paulsalter macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #6
    Only seen this happen to me once today, earlier on, cant see any pattern to it

    I don't think its anything to do with the external devices as my inbuilt trackpad has the same issue when I see it
     
  7. uludag macrumors newbie

    Joined:
    Oct 24, 2011
  8. yawns macrumors member

    Joined:
    Oct 12, 2011
    #8
    I get something similar from time-to-time, particularly when things are loading or moving under the cursor. It happens a lot when I'm trying to close tabs in any browser, and sometimes on links. I need to move the cursor away from the link or tab I'm trying to click (or close), and then come back to it.

    I could be totally wrong (maybe I'm not even describing the same thing as OP), but I assumed it was an annoying "feature," that tried to prevent accidental clicks. I've seen this subtly implemented elsewhere (so well that I pretty much never notice it), where you can't click "close," or whatever for .5 - 1 second after the thing becomes active under the mouse. It seems like Apple tried to copy that, and were either over-zealous with the hand-holding or forgot to re-enable the clickable thing.
     
  9. folder dude macrumors newbie

    Joined:
    Dec 7, 2010
    #9
    Same here

    I have the same issue and haven't been able to solve it yet.
     

Share This Page