So, who said 3TB-Drives in a PowerPC are ok?

Discussion in 'PowerPC Macs' started by Cox Orange, Apr 6, 2013.

  1. Cox Orange macrumors 68000

    Jan 1, 2010

    once someone said you can easily use in and put 3TB HDDs into PowerMacs, as long as you format as GUID (which is the partition scheme for Intel Macs, so you will be able to write all data to it, but won't be able to start the OS from it, which is not a purpose for that big of a Drive, my opinion).

    In other Forums I read, that only 2,2TB will be recognized.

    If you are in a hurry jump to Conclusion!

    What did I do?

    Put the 3TB Drive in my G4. started with 10.4.
    3TB were recognized in disc utility. I do not know, but I guess I then formatted it under 10.5 with GUID to one 3TB partition.
    I then strated 10.4 again and wrote data to it. After I had filled it and 900GB were left, I got a kernel panic, which resulted in my Boot-Drive being unsusable from then after repair trys. Well, the drive had allready 26 dead sectors, so this might be coincidense. The Pending bad sectors increased from 0 to 50 to 70 and then I stopped using it.
    I put in another drive with 10.4.11.
    When I the drive had just about less than 800GB free space, copiing data always stopped (error -36).
    I then booted into 10.5 and tried to copy the data, that worked fine. Then started into 10.4 again. All data is DV-movies from iMovie. Before, I was able to play these, now no file be it at the beginning of the drive or not could be played, I got the iMovie window with the thumbs, but the play button did not work.
    Went back to 10.5, every file was playable!

    Under 10.4.11 PPC
    - 3TB can only be used up to about 1,9TB space (Like other Forum's said: 2,2TB barrier).
    - data will only be readable, if you stay there and do not add data beyond that under 10.5. As long as you stay in the 2TB range, everything seems ok under 10.4
    Under 10.5.8 PPC:
    - full 3TB is usable
    - no problems so far.

    When I have filled up all the 3TB to the end, I will reformat it into two partitions and try, if that works for 10.4 to write to the part beyond the 3TB.

    So far, 3TB und 10.4 no, under 10.5 yes.
  2. Themacmang4 macrumors newbie

    Feb 19, 2012
    Are you using Sata III drives? As I was wondering whether they would work in my Powermac G5 7,3 Dual 2ghz. Thanks
  3. MisterKeeks macrumors 68000


    Nov 15, 2012
    He is using a SATA card in a G4.
  4. Themacmang4 macrumors newbie

    Feb 19, 2012
    So do you have any idea if Sata III drives would work?
  5. Cox Orange thread starter macrumors 68000

    Jan 1, 2010
    Yes, SATA-III on a Sonnet-SATA-I-PCI-Card in a PowerMac G4 AGP.

    This one

    There is a person Japamac in the apple support discussions forum who is very knowledgable (he didn't recommend 3TB!).

    He said any (in the sense of every) 7200rpm drive from Hitachi and WD (Toshiba is ok, too since Hitachi belongs to them partly) will work in G5s and G4s. Green Drives and Seagate and Samsung drives are known for making problems. Especially Green Drives (modern ones with 5400rpm) will suddenly disappear and can only be "talked" to, by rebooting.
    The sleep problems appear with and without expansion card (i.e. it appears on the native SATA-I port of the G5, too)

    WD drives have jumpers, which you can set to let the SATA-II or III drives work as SATA-I drive (you will make a SATA-III to a II drive and it will work on a G5 as SATA-I).

    I for a strange reason had a Sonnet-SATA-Card and a Macally SATA-Card in my G4, but no drives connected and used two IDe drives on the onboard ATA-66 BUS and from the time of the Cards being installed on, the PowerMac would freeze after finishing a task (like it did burn a DVD and was showing "writing lead out" for hours, when I restarted the Mac the DVD was readable. The same for iMovie converting a file, when it had finished the file, the bar stayed at the full position, but the bar would not disappear and the Mac would not respond, -> restart). I then disabled the energy saving settings and everything would work fine.
    Allthough the Cards state to support deep sleep clearly. But that issue is well documented over Forums (, but some did have this problem and some not, it was never found out why that is. Maybe people used a different Firmware. I have the newest on the Sonnet and the old on the Macsense, since Macsense doesn't talk to you, if one writes an email.
  6. Jessica Lares macrumors G3

    Jessica Lares

    Oct 31, 2009
    Near Dallas, Texas, USA
    Forget about 3TB, I wanna know if you can RAID 6TB! :D
  7. MisterKeeks macrumors 68000


    Nov 15, 2012
    Get one of these, 5x 1TB SSDs, and put them in RAID0. It would fly!
  8. Intell macrumors P6


    Jan 24, 2010
    WD Green drives don't have any problems in PowerPC Macs once they're jumpers are correctly set. I have one as a boot drive in my G5. I find it to be fast and responsive and have never had any problems with it.
  9. Themacmang4 macrumors newbie

    Feb 19, 2012
    Are you using the Sata III version of the Green Drive?
  10. Cox Orange thread starter macrumors 68000

    Jan 1, 2010

    Last evening at about 1 o' Clock (Berlin time), I started filling the rest of the 3TB (the last 766GB) with 725GB). When I woke up this morning the screen was showing the kernel panic again "you need to restart your computer or press the power button for several minutes).

    It would start to a flashing mark, so I tried holding "alt" (option key in english?) under start up, no drives recognized.

    I unplugged the 1TB (source drive) and the 3TB (target drive). Started, same result.

    I have two drives on the onboard ATA-66 controller:
    Master: 10.5.8 ->old 74GB Raptor I was given time ago and using it with a SATA-to-IDE adapter
    Slave: 10.4.11 -> IDE-Drive (remember first got totally trashed with the last attempt), I then had another IDE drive used here. Both drives were used without problems long time before! Copying 1TB of data to another 1TB drive for example, or having 3x 1TB drives used at the same time, no problem.

    I now unplugged the IDE-Drive (which I was not using, when copying files under 10.5 from the 1TB drive to the 3TB drive!).
    Now the Mac would start.

    I opened the log and it showed an error that is not relevant, for what I am elaborating here, but I will list it, it is similar to that one (I had a greyed out file in the trash with cryptic letters, not chinese, but nearly the same, that I could delete, but would come back. Now it was away.
    There was another error in the log, it said the night before (at 11 pm): iMovieHD[187] Warning once: this application, or a library it uses, is using NSQuickDrawView, which has been deprecated. Apps should cease use of QuickDraw and move to Quarz.
    This might be the log of the attempt last night, when I tried to open file in iMovie under 10.4 from the 3TB drive and it would only show the thumbs and the whole iMovie window, but it couldn't play. But under 10.5 it was played, as I might have to remember you.

    I tested the volume, everything ok! I then tested permissions. It felt like taking hours. It should a lot and repairing took a while, too (in fact the whole process took 5-10minutes or so, I'd say).

    Now, the Raptor with 10.5 has it's permissions repaired.
    Next check: does the 3TB show the rest of the files (answer: yes, only 30GB space left) - does iMovie play the last copied file? (answer: yes).

    I will now restart and try, if the IDE-Drive is seen and look into SMART to see if it has gotten bad sectors, like the other drive or if I even get a "drive has to be repaired message" without even opening disk utility, like I got with the other drive after the kernel panic.

    Result follows:

    PS: WD strongly recommends not using 3TB under PowerPCs on their website. So where, did the people have their experience from, that said it would work.
  11. Intell macrumors P6


    Jan 24, 2010
    Yes, and the jumper puts it into SATA II mode.
  12. Cox Orange, Apr 7, 2013
    Last edited: Apr 7, 2013

    Cox Orange thread starter macrumors 68000

    Jan 1, 2010

    1. shut down 10.5
    2. open door, reconnect IDE Drive (10.4 volume)
    3. disconnect 3TB drive (for savety and because SMART Utility will proceed but constantly say that there is an error detecting SATA drives and I wanted to be sure that this SATA-error behaviour wouldn't result in SMART Utility reading the SMART data of the IDE drive wrong)
    4. closed door and started
    5. 10.5 loaded, opened disc utility and tested 10.4-Volume (IDE Drive) = everything ok. Opened SMART = Drive ok, only the 1 pending bad sector that was there like always.
    6. Opened Disk Utility. test permissions, that takes a bit and doesn't show anything so far, but the IDE drive is constantly making a sound like retracting power and spinning up again. That retracting was the same with the first IDE drive that got defective since the 3TB adventure, but it did it doing nothing at the same time.
    The permissions test progress bar is still progressing.

    I do not want to test this with another IDE Drive, if there is a chance that this will destroy a third one.

    What do we have:
    - problems started with using 3TB drive. But that could be coincidental.
    - the first now defective/useless IDE Drive worked a long time, before that. The IDE Drive in there now, worked a long time, too.
    - They worked also with the Raptor being present via SATA-IDE-adaptor
    - I have a Samsung Spinpoint P80 SP0842N (P80VEM) that does not work with 10.5 on it. I have a Seagate 160GB Barracuda 7200.7 (ST3160021A) IDE that has problems, when using only 128GB (due to the limit of the onboard controller. Yes, I know there firmware hacks, but I do nto want to test this).

    What will I do next?
    - wait till permissions test and repair has ended (EDIT: two permissions to repair, repaired.)
    - start SMART "long offline test". (EDIT: does the spin down and spin up thing again, test is still running).
    - then reformat the 3TB into 1x 1,8TB and 1x 900GB (= 2,7TB total capacity) and copy 850GB to the 2nd partition and see results
    - if problems appear again, I will change the motherboard and start from the beginning.

    Oh man, I should better not think about counting "lost" time...


    I read that before from you and I believe you. It seems that with Macs it is very strange, along common problems, everyone can experience, there are problem some have and some never have. As stated on about the SATA-PCI-cards about some people ahving problems with deep sleep and some not, this might be the case with WD Green drives, too.

    Do you have energy saving settings enabled? (have "pause drives, when ever possible" activated and "set Mac to sleep when not used for x minutes"?)
  13. Intell macrumors P6


    Jan 24, 2010
    Nope, it spins along as long as the G5 is on. It sleeps when the G5 sleeps, and wakes the the G5 wakes. It's a 1TB model.
  14. GermanyChris macrumors 601


    Jul 3, 2011
    I did, they worked just peachy in my departed Quad..2 of them as a matter of fact..
  15. Cox Orange thread starter macrumors 68000

    Jan 1, 2010

    Had to restart the Mac, because SMART (under 10.5 and testing the 10.4 volume) had frozen.

    After restart, I tested the volume and repaired permissions under disc utility. The drive is shown, but the volume on the drive does not get activated after repair or test ("mounting point not activated" or something like this) and it does not appear on desktop. It did make these constant power spin down and spin up sounds (just like the other did before it died).
    Then I did test the drive again with disc utility, hoping it would appear again, but then I got the grey window in front of a dark screen that says "you have to restart your computer or hold down the power button several seconds".
    After that it start and the 10.4 volume was not there again, I started again and then I got the loading cycle plus the famous traffic sign (circle with line in it, saying "you can't park here, at least in Europe).
    I shut down the Mac and connected both drives to another PSU cable. Now I get the question mark folder.

  16. Cox Orange thread starter macrumors 68000

    Jan 1, 2010

    I now tried this:
    - unplug everything (3TB was allready unplugged), so unplugged 120GB IDe and Raptor.

    THE SATA-IDE-adaptor connecting the Raptor to the onboard ATA-66 has a powercable on it (no, I am not so stupid using the drives own power connection plus the one on the adapter).
    The powercable is Y shaped. Call it A and B on the top and C at the end.
    So A goes to the adaptor, B goes to the IDE Drive. C goes to the stock powercable from the G4.
    There are two stock molex 4-Pin powercables in the G4 that each have two connectors.

    I now connected the first G4 stock powercable to the adaptors cable and the second power stock power cable, which I had in use for the SATA drive before, to the IDe drive.

    Now everything is great, no problems.

    I repaired permissions. But I realized that on the raptor (10.5) it keeps saying that the permissions were repaired, but in the next test it lists the same as wrong (without me having done anything, not moved data or restarted). I can repair them numerous times and they come back with the next test.
    Many are concerning front row which I don't use on a G4, of course. Only three are for:
    1) system/library/coreservices/Menue extras/,
    2) system/library/privateframework/versions/a/coderesources,
    3) Library/internet Plug-Ins/JavaPluginCocoa.bundle/contents

    (I have 10.2 and OS 9 on a second partition on the raptor btw.).

    I realized something additionally. The folders open faster (both under 10.4 and 10.5)??? Why's that and what does that have to do with it???

    I now did the connection (both cable of the Y adapter to the drives other end to the G4 power cable) again, that I had before and that I thought was causing the problems, but nothing. It works without problems. ... So far.........

    I do not understand this.

    I actually do not like these testing sessions... but task for tomorrow will be partitioning the 3TB into 1x 1,8TB and 1x 900GB (as said above), that will give me the chance to observe, if the current status will stay. - and of course I want to know, if 10.4 can read it, if I do this.

    I reread some other forums threads and saw someone mentioning 3TB SATA-II drives cause problems internally. But the lasst times I had the problem of the IDE drive spinning up and down the 3TB drive wasn't connected anymore. So I am still unaware of what could have caused the problem.
  17. Cox Orange, Apr 8, 2013
    Last edited: Apr 8, 2013

    Cox Orange thread starter macrumors 68000

    Jan 1, 2010

    3TB 10.4 = no / 10.5 = yes.

    PowerPCs with 10.4 can't write to or read data from space behind 2,2TB. No matter, if it is GUID or APM.
    The latter doesn't work anyway, since ApplePartitionMap has a limit to 2,2TB you will be prompted with a message in disk utility, when trying to partition it, telling you so and you will not get it start partitioning).

    If you use 10.5 to make two drives of lets say 1,8TB and 900GB and use GUID or APM, you will be able to write/read it under 10.5 on a PowerPC - but still not be able to access the space behind 2,2TB under 10.4 (although you would think, if you made two smaller partitions with APM it should work).

    How do PowerPCs with 10.4 behave:
    - PowerMac G4: will see both partitions and see the data even in the space behind the 2,2TB barrier, but as mentioned above, it will not read/write to it.
    - ibook G4: in an external case, you will not even see the drive but will be told to choose from "initialize, ignore or eject".

    So, 3TB only works under 10.5 for PowerPCs. Since I do not have and will not do long time testing any further, I can not give you the advise to do so, because I do not know, if data corruption will not take place somewhen in the future.

    Well, now I will have to decide what to do with my new 3TB drive. Only use the data under 10.5 or sell it and use a 2TB drive, to be able to use the data under both OSes. Oh and I like making decisions...:rolleyes:

    Edit: Maybe there is a way.

    Now, this is very strange. While the combination 1,8TB and 900GB didn't work
    and the combination 2TB and 700GB resulted in 10.4 not seeing the second partition (nevertheless, it doesn't matter, since it can't write there fully), I found a combination that is as follows:

    1. part. 1.98TB
    2. part 765GB (or something like that)

    the iBook now sees the 1.9TB partition on the desktop (while it did only see a ˜700GB partition in the first results and that only in disk utility).
    PowerMac G4 sees both as before.

    I wonder, if that will stay that way (I mean, whether it will keep recognizing it).
    So, now one can put data you want to use under 10.4 on the first and the rest on the second. (Oh and it is APM partitioned now, did it under 10.5).
  18. Cox Orange, Sep 27, 2013
    Last edited: Sep 29, 2013

    Cox Orange thread starter macrumors 68000

    Jan 1, 2010


    - I have had the 3TB drive in my closet for some time, since I had no data to move around or look at. I now have put it in my external case again and under 10.4 it could not open a few files. THE "catalogue B-Tree" is defective. On top after a restart the first partition is not even recognized under 10.4 (mounting point not activated). Under 10.5, if I wait long enough I get a Finder message, that teh drive has to be repaired immediately, but both partitions will be shown. You can copy (make a backup of) the files, but you can not alter them (e.g. delete them / put them in the trash).

    So it does not work! Allthough WD and say that it is possible. Well macstrategy makes some remarks, but WD says it is ok, as long as you use GUID and format it under system 10.5 upwards. (Funny thing you can find different support documents going in detail at different degrees).

    As Macstrategy suggests not the 3TB (btw. a Toshiba) are the problem, but the Advanced Format.

    - Unfortunately, since my first solution worked (1,9TB + 700GB, 1,9TB will be seen externally under 10.4), I ordered a WD 2,5TB. My thinking was. Maybe I can use it like a 160GB drive under older G4s with the 128GB limit, as a 128GB Drive. I had hopes, because the 2,5TB were so close to the 2,2TB barrier that exists under 10.4 and so the system would just not care about the rest and leave it unformatted.

    Result: 2,5TB can be formatted as 280GB and will be seen externally under 10.4. It can otherwise be formatted under 10.5 as 2,5TB and will be seen under both 10.4 and 10.5, but only internally. I stopped filling it when I reached 800MB of free space. Now that it is formatted as a 2,5TB drive, it will be seen internally, but 10.4 does not see it at all, when connected externally via firewire/usb.
    The 2,5TB does not say anything about advanced format on its label, but I think it must have the AF, too. It's the WD2500EZRX model.

    PS: additional Infos (that makes you scratch your head):
    WD says it is no problem. Here is Hitachi saying the same, even mentioning the 700+GB appearance: (look third line and expand).

    Hm, curious why that does not function. Maybe they forget the Advanced format part, that is mentioned at macstrategy as an issue that might cause problems.

    Here is the WD stuff, in variations:

Share This Page