iPhone So WiFi Calling just broke handoff...

Discussion in 'iOS 8' started by scaredpoet, Sep 17, 2014.

  1. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #1
    I figured I would give WiFi calling a try on T-Mobile, so I turned it on. As soon as I did, I got a message that turning WiFi calling on means that handoff of voice calls will be unavailable to all my other devices. Bummer, I think, but if I want it back I can probably just turn Wifi calling off and get it back, right? Well...

    [​IMG]

    This after I turned WiFi calling off, and turned hand off off and then back on. Even after rebooting the phone and iPad, still no go.

    So have I just wrecked handoff forever, or is there some way to get this back? Never would've even tried Wifi calling if I had known this was gonna happen.
     
  2. Yun0 macrumors 65816

    Yun0

    Joined:
    Jun 12, 2013
    Location:
    Winnipeg, Canada
    #2
    id take wifi calling over handoff any day..why and HOW, would i answer a phone call on an ipad..(i dont have one, they arent affordable except for the rich), but still

    anyway did you toggle handoff on the other devices? you didnt clearly specify, did you relog your apple id on the devices? pull the sim & reinsert?
     
  3. powerstrokin macrumors 6502a

    powerstrokin

    Joined:
    May 18, 2013
    #3
    I think maybe it just means hand off is unavailable WHILE you're on a WiFi call. I could be wrong.
     
  4. scaredpoet thread starter macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #4
    Speakerphone, or if I'm already wearing headphones using my iPad. Also, it stopped working on my Mac running Yosemite. This after handoff successfully worked BEFORE Wifi calling was turned on and off.

    Yes I did.

    Yup I did.

    Yup, that too. Still no joy.

    ----------


    No, I mean, Wifi calling is turned off again, and I still get the above message. Handoff is now permanently disabled no matter what I do or what settings are configured.
     
  5. deviant macrumors 65816

    Joined:
    Oct 27, 2007
    #5
    Haha, that's a good one. Ipads have twice the bigger screen and always cost 200 euros less. Except for the phone module, they are exactly the same, but bigger (and sometimes it's better). How is iphone not for rich people but ipads are...is beyond my imagination.
     
  6. scaredpoet thread starter macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #6
    Okay, found the problem.

    Turns out, turning handoff on isn't enough. There's the "iPhone cellular calls" toggle that, instead of being in the same area as handoff (because it IS a part of handoff, so I thought) is inexplicably placed under FaceTime. After I found that and turned it on, things started working again.

    I'll take some of the blame on this for not looking around enough. But Apple really needs to be more coherent about where handoff features are instead of scattering them all over different categories in Settings.
     
  7. Yun0 macrumors 65816

    Yun0

    Joined:
    Jun 12, 2013
    Location:
    Winnipeg, Canada
    #7
    not everyone buys an iphone without a contract? ipads have no contract?
     
  8. deviant macrumors 65816

    Joined:
    Oct 27, 2007
    #8
    So what? By buying with a contract you end up spending even more. It just SEEMS that you're buying an iPhone with 199$. In the end you end up paying 2000-3000$ for it.
     

Share This Page