So Yosemite appears to have ruined my Mac. Help?

Discussion in 'OS X Yosemite (10.10)' started by virginblue4, Oct 17, 2014.

  1. virginblue4 macrumors 68000

    virginblue4

    Joined:
    Apr 15, 2012
    Location:
    United Kingdom
    #1
    So I've just installed OS X Yosemite on my iMac and having running it for just 10 minutes I seem to be having no end of problems.

    1. All seemed to be going well until I opened Safari. It then crashes after 10 seconds. I have to force quit otherwise the beach ball just continues to spin. This happens every time. I've restarted my Mac etc.

    2. Thee appear to have been some weird graphical glitches when entering / leaving launchpad.

    3. I read online on the apple discussions site to enter safe mode. Well I can't do that because my keyboard now longer turns itself on when turning my Mac on, I have to manually do it, by which point I've missed the opportunity to enter safe mode. Plus the green light on my keyboard no longer lights up when I'm using capitals on the lock screen.

    4. I then tried to enter safe mode using the terminal command, however it's warning me that there may be data loss.

    I don't kmow what to do short of a clean install. Any advice?
     
  2. ABC5S macrumors 68040

    ABC5S

    Joined:
    Sep 10, 2013
    Location:
    Florida
    #2
    This is why I do a complete clean install, nothing else, and start from scratch. I don't put on loads of stuff I've collected over time, apps/programs, and such that might not be compatible now, not to mention any changes that are made over time, and using a Carbon Cloner or Time Machine that has these changes that might screw up the OS X. Or your download went bad ????

    My system is running very well. I've done the clean install, not update.


    Others having no real issues.

    http://forums.macrumors.com/showthread.php?t=1802825
     
  3. virginblue4 thread starter macrumors 68000

    virginblue4

    Joined:
    Apr 15, 2012
    Location:
    United Kingdom
  4. hleewell macrumors 6502a

    Joined:
    Oct 22, 2009
    #4
    Yosemite erases login info when you clear your history. The option to clear history in Safari also clears all your website data (login data). You have to login to Facebook everytime you clear your history.....
    Am I missing something...??
     
  5. Dokk macrumors regular

    Joined:
    Jun 20, 2010
    Location:
    IA, TX ... I never know
    #5
    Have you tried repairing permission using Disk Utility?
     
  6. virginblue4 thread starter macrumors 68000

    virginblue4

    Joined:
    Apr 15, 2012
    Location:
    United Kingdom
    #6
    So I went into extensions and turned markup off, Safari seems to be absolutely fine now. Strange.

    I also repaired disk permissions, everything seems fine at the moment, guess we will wait and see.

    Thanks for the advice :)
     

Share This Page