SODIMM user slot memory not showing up?

Discussion in 'iMac' started by Vasherized, Mar 7, 2008.

  1. Vasherized macrumors newbie

    Joined:
    Mar 6, 2008
    #1
    800MZ iMac G4.
    After putting in the 512MB PC133 SODIMM next to the airport adapter, I rebooted and the new RAM is not showing up in system profiler.

    I replaced the internal 256MB with a 512MB without any issues and this seemed relatively easy compared to that process.

    Any ideas why it's not showing up?

    Already tried zapping the PRAM at startup and that didn't work.

    Defective RAM? I ordered it from Memory Ten but their tech support hasn't gotten back to me yet.

    Thoughts?
     
  2. Cave Man macrumors 604

    Cave Man

    #2
    Are you sure you have the right kind of RAM? Back in those days there were common problems with chips (e.g., parity, etc.).
     
  3. rpaloalto macrumors 6502a

    rpaloalto

    Joined:
    Sep 19, 2005
    Location:
    Palo Alto CA.
    #3
    I just did the same with my imac g4 1.25
    512 MB Lifetime brand for both the SODIMM and DIMM slots.
    I tried both kingston and a special so called apple branded ram, sold under the corssair brand. Both did not wok. I think these imacs are just super sensitive to what ram you feed them.
    The lifetime brand ram, I purchased at my local microcenter in their apple section

    http://www.microcenter.com/single_product_results.phtml?product_id=0222279

    Did you let the pram reset it's self 3 times. Just let it cycle 3 times before you let go of the keyboard command.
     
  4. Vasherized thread starter macrumors newbie

    Joined:
    Mar 6, 2008
    #4
    I did cycle the PRAM three times. Tried it twice and I heard the sound but my clock never reset which is usually a sign it worked. I have the right kind of RAM just not sure if this brand is any good. I ordered it from Memory Ten and have had fine results from them before. I was always under the impression RAM was fairly generic and platform independent. Having reinstalled it twice with no luck I'm probably going to send it back and reorder through Crucial, OWC, or TigerDirect.
     
  5. Vasherized thread starter macrumors newbie

    Joined:
    Mar 6, 2008
    #5
    Just realized mine is an Apple Branded RAM. Never heard of it but had a decent price ($69). Looks like Lifetime is the same so if you're saying that worked I'll give it a shot. Thanks.
     

Share This Page