Software Update can't find internet!

Discussion in 'Mac Basics and Help' started by Gosh, Sep 30, 2006.

  1. Gosh macrumors 6502

    Aug 14, 2006
    Hi All, Hi Al!

    The Software update utility on my Intel iMac doesn't work at home after the software has been updated in the Apple Store. Only a re-install of the OS X gets it up and running - as advised by AppleCare.

    Twice now, first when I got the machine then again when it had a repair and now it's got to go in again I'm worried that it will happend a third time.

    Got to be a reason for it! Something they do in-store (or don't do). Software update advises that I don't have an internet connection but I can get iTunes, etc. Two long stints on the phone to Applecare exhausted every knowledge base idea except Archive and Install.

    Anyone else had software updated at an Apple Store and found Software Update disabled when they got home? Should I just ask them to leave it alone? It's going in this time as there's a 1/4 inch gap at the top of the screen so they shouldn't need to do any software updates.
  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Are you using a strange set of proxies on your connection? Can you manually download updates from :)
  3. Gosh thread starter macrumors 6502

    Aug 14, 2006
    No problem with manual updates or iTunes etc! Straightforward Belkin Modem/Router and it makes no difference if wireless of ethernet connection.

    It's as if Software Update is looking for the route to the Apple Server it had in store. It's obviously a buggy program and it's a shame it can't be re-installed on its own!:confused:
  4. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    You can kinda reinstall it by trashing its preference files. There's a folder named Preferences in your Home folder's Library, within which is a file named and another named (where XXX is a series of numbers). Drag these files to the Desktop and see if it gets any further. :)
  5. Gosh thread starter macrumors 6502

    Aug 14, 2006
    Thanks for your replies!

    We did this with AppleCare - it didn't make a difference unfortunately, only the re-install did the trick which is labourious even with Archive and Install. Shouldn't have to - it should just work!
  6. Lurch_Mojoff macrumors member

    Apr 21, 2005
    Closer that you might expect!
    Hi there,

    does anyone have any *other* suggestions for a solution (or at least an explanation) of this problem. The other day (02.10.2006) I did a "scheduled" (that is, it wasn't the suggested above solution) reinstall and all of a sudden I didn't have Software Update. Before the reinstall I have never had any issues with Software Update and besides the fresh install nothing has changed since. I tried using Software Update on several different network connections from different ISPs. I also tried getting it to work on all versions of Mac OS X 10.4 (all after format and reinstall and updated with through the respective combo update) but I still get "no connection" message (error -1001).

    It really is not that big of an issue for the time being for I download can download all updates from Apple's Support/Downloads webpage, but I like getting updates "automagically".

    Any possible solution or explanation is welcome.
  7. Gosh thread starter macrumors 6502

    Aug 14, 2006
    It seems that Software Update utility is rather buggy! Certainly fragile and somehow easily loses its path to the server. From several conversations with Apple Care it seems that it isn't a high enough priority and the last guy I spoke to admitted that his own Software Update hasn't worked for ages and he just uses downloads.

    For me, I think it ought to work and its nice to just get the updates you need without scrolling thro and picking them out especially with so many updates going on recently.
  8. Vhadakhan macrumors newbie

    Oct 6, 2006
    software update :mad:

    Just annoying.. downloaded the 10.4.8 combo intel and it still didn't fix the software update. You'd think with all of the vulnerabilities coming out of the woodwork that it would be a first priority.
  9. Gosh thread starter macrumors 6502

    Aug 14, 2006
    Totally agree! I'd say Software Update was essential to new and most mainstream users - I bet there are alot of users oblivious to the fact that we are now on 10.4.8!

    I guess there is a minimum figure for complaints to reach before they make it more rugged and reliable. Or maybe in Leopard!

    Archieve and Install will get Software Update running again though but annoying to have to do that!
  10. MACDRIVE macrumors 68000


    Feb 17, 2006
    Clovis, California
    Gee this is puzzling. I have no trouble with Software Updates. I'm running 10.3 and use the updates to get to 10.3.9 :confused:
  11. Gosh thread starter macrumors 6502

    Aug 14, 2006
    Puzzling - yes! In my case it reliably won't work if it has been updated in the Apple Store. It won't accept that I am connected to the internet. I believe it's looking for the server it had in the store.

    There-in is the answer. I'm just not clever enough to see it - and neither is AppleCare!
  12. Edelritter macrumors newbie

    Oct 11, 2006
    I apologize if this is a bit late, but I might just have a solution to your Software Update problems.

    Rather than running it from the preference pane, try running it from the Terminal (without quotation marks) as:
    "sudo softwareupdate -a -i"

    I started having the same problem maybe 3 or 4 weeks ago- I noticed just when the newest system update was available. At first I simply assumed that Apple's servers might be overloaded (something that's never happened before, and was even less plausible given that there's 4 Macs at home, and it was only on mine that Software Update didn't work immediately), and decided to try again at a later date. Waiting didn't fix anything.
    It's easy to lay the blame for most OS X problems to an incompetent user- as God is my witness, I'm the local computer shaman for my relatives and friends, and most of the bad voodoo I have to fix is caused by negligence and user mistakes. Of course, things occasionaly break without any apparent reason, but such events are rare and so far they hadn't happened to me. As far as I know, there was no reason for Software Update to break on me like it did. Maybe if I was a Windows user I could have put it down to virus/spyware-induced spirits or arcane conflicts in the registry, but I don't expect these issues from Apple- my machine is well-maintained and carries no modifications that could cause an important system conflict. None of my attempts to discover what caused the problem or how to solve it worked.
    I still have no idea what was wrong, or why invoking Software Update as root from the Terminal worked while doing it as an admin from the System Preferences panel produced a timeout error.

    I merely followed the same suggestion from (under "ERROR: None of the checked updates could be installed. Make sure you have permission to write to /tmp/501/TemporaryItems/, then try again."), and my delayed updates (system update, Pages, Keynote and iTunes) downloaded and installed without a glitch. Receipts show up in Software Update as normal. If one is to believe the rest of the entry, then my Software Update will also be mysteriously fixed next time I try to use it from the preferences panel- I have no way to verify it given that I have no new updates to get.

    I hope this works for everyone else who's having trouble, and I hope someone can figure out what is wrong based on the solution.
  13. frans macrumors newbie


    Jan 25, 2007
    Sydney, Australia
    I had a similar problem with one of 4 MACs, where Software Update stopped working on one machine, an iMac G5. Unfortunately the suggestions, including the terminal command "sudo softwareupdate -a -i" did not rectify the problem. That command still encountered a timeout.

    Given the problem was an inability of the software to find the internet connection. I changed the IP address of the iMac on the router and, hey presto, Software Update was in business once more.

    Still aggravating that Apple had no solution. :)
  14. kermit4161 macrumors regular

    Dec 18, 2006
    I'll resurect this thread to add my problems with Software update. I have inherited a Mac Lab that contains some 22 Intel iMacs, a couple of PowerMacs and an Xserver (which isn't configured properly... another story).

    I went in on Saturday to update the lab for the new DST issue and found that Software Update would not work on almost all of the iMacs. It would work on one of the lab iMacs that I did a complete restore on my first day at work, the instructor iMac and the PowerMacs... but none of the other student iMacs... :mad:

    I searched high and low on the Apple Support forums, but never found a solid answer to the problem. Just from a process of elimination, I thought it was some kind of configuration issue... but I compared the iMac I restored to the one sitting next to it and they appeared identical in settings :confused: .

    I did not try to invoke the Software Update from the Terminal... and will give it a shot when I get back from Spring Break. I also have an Apple Systems Engineer coming in after break to look over the Xserver and help me get it configured properly (I'm a newbie to Tiger Server). I'll ask him if I haven't found a solution by then.

    Has anyone else found a solution???
  15. Cadence macrumors member

    Jul 17, 2004
    Los Angeles, CA
    I've never had a problem with Software Update until now. Everytime I try to download Itunes 7.1.1 and Security 2007-003 it locks up at about 40% so I end up just cancelling it. Anyone have any ideas or just another bug?
  16. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Cadence, what have you tried from this thread in order to get it working? Can you manually download the updates? :)

Share This Page