Software Update crashed and will not show my available update

Discussion in 'macOS' started by m i k e, Aug 22, 2009.

  1. m i k e macrumors member

    Joined:
    Aug 10, 2007
    #1
    Yesterday I ran a "Software Update" on my MacBook Pro (Santa Rosa chipset). The updater found one update that was for the remote desktop software. When I clicked install, the beach ball showed up and after about 10 minutes of it spinning I forced quit the program. I tried opening Software Update again but it just bounced in the Dock and wouldn't open so I forced quit again and attempted to restart the computer. When I clicked restart, the computer froze. This was very surprising to me as my laptop has never frozen on me in the two years I've had it. I did Control-Command-Power to restart the machine and everything seemed okay. I checked "Installed Updates" in System Preferences and the most recent update, that I referred to earlier, was not installed. I fired up the Software Update utility to try the update again yet it found no updates available.

    Why has this happened? How can I get it to show the update that should really be available to me?
     
  2. m i k e thread starter macrumors member

    Joined:
    Aug 10, 2007
    #2
    Update: I tried the Software Update utility a couple of days later and the update in question did appear.
     

Share This Page