Software Update error (-3001)

Discussion in 'Mac Apps and Mac App Store' started by Frits, Jun 18, 2009.

  1. Frits macrumors member

    Joined:
    Jan 30, 2009
    Location:
    Holland
    #1
    Hey all,

    Today when I tried to download the new safari 4.0.1 and bluetooth 2.0 update, I lost my connection in the middle of the process, after which Software Update returned to the main window (from the download pop-up) indicating that the connection to the internet was lost and displaying a red exclamation mark before the names of both updates. When I managed to get the connection up again, I tried starting the download again. This time the Safari update downloaded properly, but when it finished and SU was about to start downloading the bluetooth update, I got this error:

    My connection was of course working. I tried again and this time, as Safari was already downloaded I presume, I got the error message immediately. I tried repairing permissions, rebooting and a different user account but none of these worked. I searched around on forums a little and it seems that this is a common problem. There were also multiple threads on it on these boards, but none of those, or any of the threads from other forums, contained a solution for the problem. Apparently, there are workarounds available, which is good, but I would really like to have the root cause of this problem solved and be able to update normally through Software Update again.

    I'm on a 2.8GHz aluminum intel iMac with OSX 10.5.7, all updates to this date apart from these two installed.

    Many thanks in advance,
    Frits
     
  2. Frits thread starter macrumors member

    Joined:
    Jan 30, 2009
    Location:
    Holland
  3. HyperWake777 macrumors newbie

    Joined:
    Jul 1, 2009
    #3
    I Have The Same Problem

    I'm just popping in here to get a reply whenever your question gets answered. I'm trying to update my Mac to 10.5.7 so I can upgrade to Safari 4 but after a few seconds of "Checking for new software...", it says "A network error has occurred: (-1001). Make sure you can connect to the internet and try again". I went through all of the steps with the network diagnostics to find that my internet was working perfectly. I'm confused about this. Any help would be excellent.

    Thanks,
    Charlie Wood
     
  4. HyperWake777 macrumors newbie

    Joined:
    Jul 1, 2009
    #4
    I Have The Same Problem

    I was trying to update my software so I could upgrade to Safari 4 when this happened as well. My problem is a little bit different from yours though. I can't even get to see the updates I need like you can. I can't get that far in the process. It stays on the "Searching for updates..." screen and then, eventually, after I wait a while, it comes up with a screen that says "A networking error has occurred: timed out (-1001). Make sure you can connect to the internet, then try again. I have a different problem but I think they might be related. If you have any clue why this would be, help would be much appreciated.

    Thanks,
    Charlie Wood
     
  5. HyperWake777 macrumors newbie

    Joined:
    Jul 1, 2009
    #5
    Just Realized I Posted That Twice

    So I'm posting a third one just to be more obnoxious. I was so giddy and impatient that I went ahead and downloaded the Alpha version of Google Chrome for Mac. I would advise you not to do so unless you love having your computer crash every other minute.

    Cheers
     
  6. mba538 macrumors newbie

    Joined:
    Jul 26, 2009
    #6
    Exact same problem here

    Hello,

    I experience exact the same problem on my MacBookAir when updating to Safari 4.0.2: File cannot be opened (-3001).

    Strangely enough, two other updates (of iTunes and iMovie) caused no problems: they performed just as expected.
    I have this problem for this specific Safari update already for several weeks, cannot remember when it started. I do know how it started though: something went wrong during the first time I tried to update. Also at that time, two other updates did perform as expected (cannot remember which ones, probably another iTunes update with Quicktime). Also, the same Safari update on my iMac went without problems via the same network.

    Now I assume that some file got corrupted during the first erroneous attempt and I would not be surprised if removing that file would solve the problem, but can anyone tell me where those files are, and how they are called?

    Another solution might be to await version 4.0.3 update of Safari. Does anyone know if that might ignore the current problem?

    Any help greatly appriciated!
     
  7. etf macrumors newbie

    Joined:
    Aug 6, 2009
    #7
    The issue with Error -3001 is usually a result of permissions on /var/folders

    From the terminal window, try "sudo chmod -R ug+rwx /var/folders"

    That worked for me.
     
  8. Bouldry macrumors newbie

    Joined:
    Jun 5, 2007
    Location:
    Salem, MA
    #8
    sudo chmod -R ug+rwx /var/folders

    Been looking everywhere for a solution -- but that worked perfectly -- Thanks!


     
  9. dsarah3 macrumors newbie

    Joined:
    Sep 12, 2009
    #9
    Same problem - not sure how to proceed - please help! Thanks

    Kind of a newbie...not sure how to post the fix in "Terminal". Don't want to mess up. Can you lead me step by step? I'd SO appreciate it!!! I opened Terminal and pasted "sudo chmod -R ug+rwx /var/folders" (minus quote signs:) but that didn't do it so I must be missing something here. THANKS!!! You can email to me directly if you prefer.

    ...Do you go to Shell > New Command and then enter the script? I got a warning that I could lose data if I do this...

    UPDATE: OK somehow I managed to do the fix without screwing up anything:) I put the command in and it kept asking for a password, yet wouldn't let me type one. Nonetheless, when I tried Software Update, it works now! Thanks!!!

    Any comments/follow-up is welcomed.
     
  10. alenkaja macrumors newbie

    Joined:
    Oct 8, 2009
    #10
    it worked for me as well!!!

    thanks!!

    Originally Posted by etf
    The issue with Error -3001 is usually a result of permissions on /var/folders

    From the terminal window, try "sudo chmod -R ug+rwx /var/folders"

    That worked for me.



    to get to your Terminal Window go to "Macintosh HD"--->"Applications" ----> "Utilities" ---> then "Terminal" then just paste

    udo chmod -R ug+rwx /var/folders

    and type your password


    Good luck!!!
     
  11. Manulilla macrumors newbie

    Joined:
    Jan 6, 2011
    Location:
    Italy
    #11
    Unfortunately it did not work for me. Have tried it to download the Utility Airport update but can't do it because of error 3001. Needless to say I could download other updates without any problems.

    Any other suggestion?
    Thanks for your help
     
  12. sdbluestem macrumors newbie

    Joined:
    Jan 17, 2011
    #12
    Can't download software updates on OS 10.5

    I tried the suggestion below and I still cannot download software updates. Anyone have an idea for a fix?:confused:

     
  13. atila macrumors newbie

    Joined:
    Jul 12, 2011
    #13
    hi, im new.

    this didn't work for me.




    my error says:
    "The update “Security Update 2011-004” can’t be saved. A networking error has occurred: Cannot open file (-3001). Make sure you can connect to the Internet, then try again."

    i tried restarting my mac after doing the solution that I mentioned before but didn't work (I also tried wireless and conected with a wire to the network)

    can somebody help??
    thanks
     
  14. cfs macrumors 6502a

    Joined:
    Feb 8, 2008
    #14


    Did anybody ever find a solution who couldn't get the above advice to work out as a fix?

    cfs
     

Share This Page