Software Update won't update Safari, iTunes, possibly others

Discussion in 'macOS' started by NathanA, Jul 30, 2012.

  1. NathanA macrumors 6502a

    Joined:
    Feb 9, 2008
    #1
    Okay, OS X gurus, I've run into a problem that I can't solve and that is driving me CRAZY.

    Working on a friend's Mac Mini running Snow Leopard. Was in desperate need of updates, and Software Update showed a bunch of 'em, including 10.6.8 (I can't remember which 10.6.x release it was on when we started all of this). I let it process all of them, rebooted, ran SU again, found a couple more updates, installed those, rebooted one final time, and now SU shows "Your software is up to date." Great!

    The only problem is that it's lying.

    I realized this after I started up iTunes and noticed it was running an ancient release (10.2.2). iTunes told me there was an update and prompted me to download it. I clicked the Download button, and it launches Software Update again, which proceeds to tell me that "Your software is up to date."

    Uh...okay.

    I then noticed that Safari was sitting at 5.0.5, whereas the latest version of Safari for Snow Leopard is 5.1.7. Again, though, Software Update says there are no available updates left for me to install.

    In researching this issue, I found 4 possible causes for where Software Update misreports a machine as being up-to-date when it isn't:

    1. Certain updates have been inadvertently set to be "ignored." You need to reset ignored updates.

    2. You have multiple copies of a given app (Safari, iTunes, whatever) -- perhaps even multiple versions of that same app -- in various places on your hard drive. You need to remove the duplicates and only leave one.

    3. The Software Update plist preferences files have become corrupt. You need to delete them and run Software Update again, which will regenerate new versions with the default settings.

    4. The content distribution network that Apple uses to distribute updates to users (Akamai?) has a bad node, and your computer is being directed to use that node. You can try forcing it to use a different node by editing /etc/hosts

    I have tried every single one of these solutions, and none of them have worked. I have even gone above and beyond these solutions:

    1. The "Reset Ignored Updates" menu item is grayed out for me, which I assume means that no items were set to be ignored. Besides, #3 should have also taken care of resetting this if that were the problem.

    2. I searched the entire drive for other copies of Safari and iTunes, and came up empty. The copies I do have are in their proper place, in the Applications folder.

    3. I trashed 3 plist files related to Software Update: the one under ~/Library/Preferences, the one under ~/Library/Preferences/ByHost, and the system-wide one under /Library/Preferences. Didn't change a thing.

    4. I found several other IP addresses for valid Apple content distribution nodes on the 'net, and edited /etc/hosts to override DNS. I had the exact same results. I then took the machine over to another network which is connected to another completely different ISP, undid the changes to /etc/hosts, and ran SU again. STILL it reports that the machine is up-to-date.

    5. I decided to try moving all of the files in /var/db/recepits and /Library/Receipts to a different location to see if that changed anything. It did: Software Update now saw 2 updates (a security update and one other thing I can't remember off the top of my head), but Safari and iTunes were not on the list. I put the receipts back where they belonged, and now SU is again reporting "Your software is up to date."

    6. Because I was desperate and couldn't think of anything else to try, I did a Repair Permissions on the volume. No change.

    @%#$%#^

    At this point, I could do one of two things which likely will take care of the issue:

    1. Just upgrade both iTunes and Safari manually. Yeah, I could do this, but if either one gets updated again in the future by Apple, then this computer is going to have to be manually updated EVERY TIME.

    2. Wipe the drive and reinstall the OS. Would that fix it? Yeah, probably. But at this point, it's become personal. :p I want to know *why* it is happening and how to fix it relatively non-invasively. Having to do a complete OS wipe and reinstall in order to fix a software update issue is ludicrous and overkill.

    I did try one other thing: instead of upgrading iTunes and Safari to the latest versions, which won't tell me anything, I decided to upgrade them to something newer than what was currently installed, but something that still wasn't the absolute latest. I thought maybe perhaps doing so would overwrite some corrupt file or install receipt somewhere and fix the issue. So I updated Safari from 5.0.5 to 5.1(.0), and iTunes from 10.2.2 to 10.5.3. But Software Update STILL DOESN'T SEE THE LATEST UPDATES!! Aaargh!

    I have searched high and low, and cannot find ANYONE who has come up with a working fix to this issue once it develops.

    So, Apple: WTF? It "just works," does it? :p

    What the heck does Software Update look for in order to determine whether or not a particular piece of software is up-to-date? What could possibly be broken? Where do I look next?

    Thanks for reading,

    -- Nathan
     
  2. Mr. Retrofire macrumors 601

    Mr. Retrofire

    Joined:
    Mar 2, 2010
    Location:
    www.emiliana.cl/en
    #2
  3. NathanA thread starter macrumors 6502a

    Joined:
    Feb 9, 2008
    #3
    Thank you! I fired up Wireshark and can confirm that it is downloading a catalog file from swscan.apple.com, which is a DNS alias for the content distribution server network. I also see by looking at the catalog file that each product to be updated has a 7-digit product key in the format ###-####.

    What I'm still not quite clear on is how it maps the product key to the actual product. How does SU know what version I currently have, or that I even have the given product installed? I'm guessing it has something to do with the installation package receipts.

    In any case, this whole time I have been operating under the assumption that it was a problem with this specific Snow Leopard installation on this specific computer; it didn't occur to me that this could actually be a problem on Apple's end of the network. I figured if it really were a problem on Apple's software update servers, there would be a lot more people complaining about the problem, and it would have been fixed by now (I have been fighting this issue since Friday).

    I don't have access to any SL computers that aren't already fully up-to-date other than this one, so the only way to really test this theory would be for me to do a clean install on another drive (external USB, perhaps), boot off of that, and see if it also doesn't have Safari and iTunes updates pushed to it. I *did* take a look at the catalog file straight off of Apple's server, though, and when I searched through it, I noticed that it has Safari entries for Tiger and Leopard, but none for Snow Leopard. So I think you may be on to something here.

    Also, thanks for the direct link to the 5.1.7 download, but I specifically picked 5.1.0 to install because if I had gone to 5.1.7, I would never know if Software Update was still broken. :)

    -- Nathan
     
  4. NathanA thread starter macrumors 6502a

    Joined:
    Feb 9, 2008
    #4
    Well, it's been confirmed: Apple screwed up their Snow Leopard software updates on their server.

    I just finished a virgin install to an external drive from a 10.6.3 disc. Came with Safari 4 and iTunes 9 out of the box. Software Update picked up the 10.6.8 combo, but not Safari or iTunes updates. I let it update to 10.6.8. The 10.6.8 update includes Safari 5.0.5, so Safari got updated to that, but after the upgrade finished, iTunes was still stuck at 9.0.2, and Software Update still showed no further Safari or iTunes updates. I finished the remaining updates (Java, security update 2012-002, and a couple other misc. things), and after that, Software Update told me everything was up to date.

    Ridiculous. Can't believe I was chasing my tail on this all weekend and it turned out to be a problem on the update server after all. I wonder how long it will take for them to A) realize it's broken, and B) get it fixed.

    -- Nathan
     
  5. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #5
    "Its not broken you need to upgrade to our latest and greatest OS 10.8 Mountain Loin" -Apple
    I just went through the same thing. They pulled all the individual installers as well.
     
  6. SlowX macrumors member

    Joined:
    May 16, 2001
    Location:
    Minneapolis-Saint Paul, MN
  7. NathanA thread starter macrumors 6502a

    Joined:
    Feb 9, 2008
    #7
    This is beyond ridiculous. I submitted feedback right after I posted this. It is still broken.

    -- Nathan
     
  8. torres86 macrumors newbie

    Joined:
    Jul 14, 2012
  9. Ward Clark macrumors newbie

    Ward Clark

    Joined:
    Feb 27, 2010
    #9
    Old Safari & latest iTunes after fresh install of Snow Leopard

    For the record:

    About a week ago, I did a fresh install of Snow Leopard from my 10.6.3 DVD, followed by rounds of Software Update until there were no more updates.

    I just discovered I have Safari 5.0.5, and I'll be manually installing 5.1.7 as soon as I post this note.

    Unlike others, I have iTunes 10.6.3, which appears to be the latest.

    I'll be watching this thread for other items missing from Software Update for 10.6.8.

    -- Ward
     
  10. torres86 macrumors newbie

    Joined:
    Jul 14, 2012
    #10
    Itunes 10.6.3 appears for me on software update too. I only miss safari 5.1.7 which I had to manually install it.
     
  11. Curves, Aug 18, 2012
    Last edited: Aug 18, 2012

    Curves macrumors newbie

    Joined:
    Aug 18, 2012
    #11
    problems with gmail

    I recently update to Mountain Lion 10.8 and now when i open an attachment or link in gmail or safari and then close it, the entire window closes instead of the just the attachment or link.

    Does anyone have an answer?
     
  12. NathanA thread starter macrumors 6502a

    Joined:
    Feb 9, 2008
    #12
    Weird. I've tried two installs: one pre-existing and one brand-new-from-scratch 10.6.3. Neither one is offered iTunes.

    I just checked/tried again, too.

    -- Nathan
     
  13. Sonic Purity macrumors newbie

    Joined:
    Feb 17, 2006
    Location:
    Pasadena, California
    #13
    Working on a client’s MacBook on 10.6.8. I did not go to the great reset lengths that you (Nathan) did. Here too, Safari is stuck, in this machine’s case at 5.1.1. iTunes is at 10.6.3 and from what i vaguely remember about a recent clean Snow Leopard install on a different MacBook, everything else looks up to date in the Software Update Installed Software listing.

    Just finished submitting a bug report to Apple, via the link above (Mr. Retrofire…*why doesn’t vBulletin list the post numbers in this composition view, fer chrissakes?!). I hope everyone reading this who has been affected by this bug does so…*my experience is that Apple really does respond to different squeaky wheels squeaking, by number of reports.

    ))Sonic((
     
  14. gumblecosby macrumors 6502

    Joined:
    Jun 22, 2010
    #15
    I submitted a bug report for this last month. Previously Aperture and
    Iphoto 11 would not update from their 9.0 versions on 10.6.8 . This was fixed recently so hopefully Safari and Itunes will follow soon.
     
  15. killerrobot, Aug 31, 2012
    Last edited: Aug 31, 2012

    killerrobot macrumors 68020

    killerrobot

    Joined:
    Jun 7, 2007
    Location:
    127.0.0.1
    #16
    I never had any problems with the software updates on 10.6.x. The iTunes and Safari have always popped up and I remember them installing the latest versions 10.6.3 and 5.1.7 respectively the last time I did the software updates, which was a few weeks ago - which I guess would indicate that the issue has been resolved.
     
  16. justdoesntwork macrumors newbie

    Joined:
    Sep 8, 2012
    #17
    Nope - Still does not work

    Same problem here.

    Updating OS now and will see if it works then
     
  17. NathanA thread starter macrumors 6502a

    Joined:
    Feb 9, 2008
    #18
    Well, interestingly, I just tried it again, and this time Safari showed up in the updates! Still no iTunes, though.

    That's progress, at least.

    -- Nathan
     
  18. torres86 macrumors newbie

    Joined:
    Jul 14, 2012
    #19
    I checked it yesterday and the updates worked fine. Itunes 10.7, safari 5.1.7 and the others -> ok.
     
  19. Buddhann macrumors newbie

    Joined:
    May 26, 2011
    #20
    Same problem!

    Just found your link to update Safari 5.0.5 to 5.1.7 and it works! The +(Add) button is back! :)

    Thanks a lot!

     

Share This Page