Software Updater suddenly slow/not downloading in snowleopard

Discussion in 'Mac Basics and Help' started by Wie Gehts, Jun 18, 2010.

  1. Wie Gehts macrumors 6502

    Joined:
    Mar 22, 2007
    #1
    I don't know whats going on. My SU was working fine until i noticed last night when I went to download iTunes 9.2, the downloading speed was real slow....like an hour or more on the timer. I tried multiple times then went to bed.
    My internet connection is fine because today I've been downloading stuff on my other computer and just used software update to download iTunes on this machine that has both my Tiger partition and an SL partition, and it downloaded fine on that.

    However, I tried downloading some software app from apple directly form their website and the speed is fine. And now also, trying to download iTunes from the updater aborts about halfway saying it can't be verified or corrupted.

    I don't get it...what the heck could be wrong?
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    My guess would be network congestion. There's been a number of updates lately and they have been large so it could be that there was just a lot of other people connected as well. Downloading from Apple's site likely connects to a different server so the speed was different. My software update downloads were a little slow too yesterday.
     
  3. davedelag macrumors newbie

    Joined:
    Jul 25, 2010
    #3
    Mine was slow too but then I ran Applejack and it seems to have fixed the issue with the software update running slow. However I've been trying to update my iPhone in itunes and it says like 300 hours just to download the update... I've been trying for several days now and can't do it. Same problem with updating my Apple TV.

    My internet runs great and fast even on the same mac computer... Any thoughts????
     

Share This Page