Software Updates are failing frequently

Discussion in 'macOS' started by Moof1904, Sep 25, 2005.

  1. Moof1904 macrumors 65816

    May 20, 2004
    Ever since I've upgraded my Dual 2.5 G5 to 10.4, Apple's Software Updates are failing about 50% of the time. After they've run, I get a dialog that says "None fo the checked updates could be installed. The digitial signature for this package is incorrect. The package may have been tampered with or corrupted since being signed by Apple."

    Sometimes I rerun the installer immediately and it works fine. Sometimes it takes a few days before I can run it successfully.

    I've attached a screen capture.

    Any thoughts?

    (BTW, I've repaired permissions and it seems to have no effect on the frequency of the failure.)

    Attached Files:

  2. DarkNetworks macrumors 68000


    Apr 12, 2005
    Yeah thats hell. i've experienced it a few times since i switched to Tiger. My Software Update runs extremely slow and i've got this problem popped up a few times...this is irritating...
  3. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Try repairing permissions (although it probably won't help) and then maybe delete the Software Updater preferences. Use Spotlight to find Updater and PLIST.
  4. iMeowbot macrumors G3


    Aug 30, 2003
    If a digital signature works sometimes and not other times on the same data, it's time to start wondering about hardware, esp. memory.
  5. Moof1904 thread starter macrumors 65816

    May 20, 2004
    Repaired Disk

    I seemed to have solved this particular instance by rebooting from an external drive and running disk repair. The disk repair utility found "minor problems" that it successfully repaired. After rebooting from my original startup drive and running the software updater again, it worked fine.

    I'm wondering if this was coincidence or if this minor disk problem has been causing my software update woes for some time now.
  6. Mitthrawnuruodo Moderator emeritus


    Mar 10, 2004
    Bergen, Norway
    Another thing you can try is to download and reinstall the latest updater, 10.4.2 Combo, and then try again.

    From memory: There were some reports of trouble with Software Update for some people after upgrading to 10.4.1 and/or 10.4.2, which was resolved by reinstalling the latest combo without using Software Update.
  7. maya macrumors 68040


    Oct 7, 2004
    somewhere between here and there.
    Had this problem once, however it was due to a busy server. :)

Share This Page