Solidworks crashes after 40 sec on IMac

Discussion in 'Windows, Linux & Others on the Mac' started by redynvre, Nov 4, 2010.

  1. redynvre, Nov 4, 2010
    Last edited: Nov 4, 2010

    redynvre macrumors newbie

    Joined:
    Apr 30, 2004
    #1
    hello all!

    I am having a slightly frustrating situation:

    I have installed SolidWorks 2010-11 64bit with Windows 7 64bit on an IMac Mid 2010 27" Intel Core I5 2.8 4G Ram with the ATI Radeon HD 5750 1G option. Running Boot Camp.

    Windows 7 Ultimate installed normally and seems to run fine.

    Solidworks install with first 4G of Ram:
    Install went fine no issues.
    Licensing process went fine no issue.
    SW launches normally ... and freezes after about 3 operations or 40secs.

    I considered: Not enough Ram. Upgraded IMac to 16G (Max allowed)

    Clean installed SW again.
    Exact same issue!

    Not sure what is happening. SolidWorks told me to just buy a new computer!! ... Right...

    Did anybody have a similar problem and found a solution?

    Thank you!!
     
  2. Yakob macrumors member

    Joined:
    Mar 13, 2010
    #2
    huh thats weird... i run 2010 SW (64 win7) on my i5 MBP with no problems, it actually runs very well (for a notebook)

    The only thing i could really recommend is that you update to SW service pack 4 if you haven't already. :confused:
     
  3. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #3
    There was a thread recently about SW and it ended up being that the poster needed to install the OEM video drivers over the BC ones. Have you tried the drivers from AMD.

    B
     
  4. redynvre thread starter macrumors newbie

    Joined:
    Apr 30, 2004
    #4
    I have not tried that actually, I take I will find it on the AMD website, thanks I'll keep you posted
     
  5. redynvre thread starter macrumors newbie

    Joined:
    Apr 30, 2004
    #5
    :( No dice. Installed the latest driver. No change. Still freezes just like before.
     
  6. redynvre thread starter macrumors newbie

    Joined:
    Apr 30, 2004
    #6
    Thats the driver I used:

    AMD Catalyst™ Accelerated Parallel Processing (APP) Technology Edition
     
  7. toxic macrumors 68000

    Joined:
    Nov 9, 2008
    #7
    might just be an incompatible video card. professional applications can be stupid like that.
     
  8. redynvre thread starter macrumors newbie

    Joined:
    Apr 30, 2004
    #8
    Yes, I would agree with you, but the problem is many people are running it without issues on the same machine :(
     
  9. Nebukadnezar macrumors newbie

    Joined:
    Nov 22, 2010
    #9
    I want to post here that I'm having very similiar issues with Solidworks 2010 x64 on my i5 Macbook Pro.

    I haven't found a solution as of yet..
     
  10. Goofjuzo macrumors newbie

    Joined:
    Nov 11, 2008
    #10
    Hello,

    Exactly same problem with Solidworks 2011 x64 on both of my iMac iCore7 4GB and my MBP Core2 Duo 4GB when I boot directly on Win7.
    But when I start the Win7 bootcamp partition through Parallels, it working fine ! It's better than nothing.:(
     
  11. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #11
    Further indications that it has something to do with the drivers. have you tried the latest drivers from Nvidia/AMD.

    B
     
  12. Goofjuzo macrumors newbie

    Joined:
    Nov 11, 2008
    #12
    Yes, I have the lastest drivers from Nvidia on the MBP and AMD/ATI for the iMac.
     
  13. Goofjuzo macrumors newbie

    Joined:
    Nov 11, 2008
    #13
    I've upgraded to SW2011 x64 SP1.0 but no improvement, same problem ! :mad:
     
  14. Rich C., Jan 4, 2011
    Last edited: Jan 4, 2011

    Rich C. macrumors newbie

    Joined:
    Nov 10, 2010
    Location:
    people's republic of Berkeley
    #14
    fraking Parallels...

    I seem to have isolated this issue to a problem with the Parallels Tools.
    I did a clean windows 7 install and then installed the boot camp tools and update after which I did a clean install of Solidworks 2011 SP 1.0. Relevant rebooting of system for all of the system and graphic driver updates and I had a nicely functioning copy of Solidworks with "Realview Graphics" on my newly installed Quadro 4000.
    Next step was to reboot into OS X and set up a new virtual machine based on my boot camp partition. This went cleanly and I was able to get SW running on the virtual machine.
    Reboot into windows, fire up Solidworks, load a model and 41 seconds later it crashes...
    Since the only thing that changed in the configuration was the creation of the virtual machine and installation of the Parallels tools, the fault pretty clearly lies with Parallels...

    Filed a trouble report with Parallels detailing what I did to recreate this issue. Maybe they will know how to fix it?

    and BTW: The Quadro is fast, and shiny and so much better than the ATI 5870 that came with the system.
     
  15. Ultimate Shield macrumors newbie

    Joined:
    Feb 5, 2011
    #15
    New guy here
    Has anyone had any updates on this? I was all set to buy a 17in MacBook Pro until I found this thread. I'm a collage student and need to run Solid works and Master CAM and needless to say cash is not an easy thing to toss around for a student like myself. I wanted to get away from PC's as I'm sick and tired of the issues they have but at the same time I'de rather save myself the $2,500 if the computer is going to be incapable of running the programs I need it to.
     
  16. guenoc macrumors newbie

    Joined:
    Feb 17, 2011
    #16
    prl_cc.exe ?

    Based on Rich C.'s suggestion, I ended prl_cc.exe and prl_tools.exe and it seemed to improve my system performance. At first I thought this solved the problem, but it turns out it just made solidworks a lot faster for the 41 seconds it took to crash again. Apparently the prl_cc.exe process is the cause of a variety of issues but Parallels support has failed to come up with a reasonable response to the issue. I can't find anything else parallels-related running on my machine, so I'm out of ideas again...

    Edit: Is anyone having this problem with 32-bit windows? I'm running 64-bit, yet parallels' tools are 32-bit programs. Perhaps this is part of the conflict.
     
  17. houseofdan macrumors newbie

    Joined:
    Feb 25, 2011
    #17
    Confirming Parallels...

    Confirming the parallels issue!

    I've been using SW successfully for many weeks with Boot camp. Then yesterday, after installing parallels SW began to crash after 5-30 sec after opening. Not good!
     
  18. chrism74 macrumors newbie

    Joined:
    Mar 6, 2011
    #18
    Thanks for finding this

    Thanks all for finding and verifying this. I just got a smokin' new MBP and spent most of today setting up windows (Of course the Mac stuff transferred seamlessly in about an hour).

    I was excited to test out the speed improvements in SolidWorks and ran into this problem. I started doing memory checks and disabling anti-virus etc but a Google search brought up this thread.

    I will pile on to Parallels support.

    Thanks again,
    Chris
     
  19. strompebukse macrumors newbie

    Joined:
    Mar 11, 2011
    #19
    Confirming problem - temporary solution

    Uninstalling Parallels Tools got SolidWorks back to normal in Boot Camp, but made Parallels less user friendly.

    Thanks for reporting the problem.
     
  20. chrism74 macrumors newbie

    Joined:
    Mar 6, 2011
    #20
    Passable work-around

    I submitted a ticket to Parallels. They asked me to stop all Parallels services and kill prl_cc.exe to confirm it was a parallels issue.

    In doing that I ended up in a state where there are no Parallels services running but prl_cc.exe is. This allows Solidworks to run and when virtualized Coherence Mode doesn't work but pretty much everything else does. E.g. I can run Windows in a window and the mouse transitions seamlessly etc. The network share points between OSes don't work. Cutting and pasting does work.

    You stop services by running msconfig.exe and going to the "Services" tab.

    Note: I didn't do a completely scientific (change one thing, test, repeat) process to end up where I am. I tried uninstalling Parallels Tools at one point. That failed because of a registry permissions issue. It looks like the uninstall failed completely so I should be back where I was and stopping the services is the ticket but I can't be 100% sure.

    Chris
     
  21. QuantumLo0p macrumors 6502a

    QuantumLo0p

    Joined:
    Apr 28, 2006
    Location:
    U.S.A.
    #21
    I know this is a bit late but since there has been a bit of resurgence of this thread...

    This may not be what you want to hear but you need to make sure the hardware is supported. Generally gaming cards are not supported by major CAD/CAM/CAE software because they lack some of the strict graphics standards requirements of workstation cards, such as OpenGL standards. Locking up while playing Crysis is one thing but locking up while working on multi-million dollar projects is another. You have to take a peek at a hardware compatibility list. Again generally, graphics drivers have to be a supported driver as well. This may not mean "the latest and greatest" driver. It is not uncommon for the newest driver to not be fully supported until the software company has time to test out various hardware/software configurations.

    I have been a NX user since the Unigraphics v11 days and currently are starting beta testing for NX8, which would be UG v27. That software has always been strict on graphic requirements, sometimes behaving quite weird if a user strays from the support path. There were some Mac users running NX in boot camp which was recommended much higher than parallels. However, when a NX port to OS-X became available, running natively in OS-X became the standard method to run on Macs. (The word is Apple was using NX to do their hardware design and His Steveness wanted NX to run on Macs if they were to continue using NX to design their products.)

    The bottom line is, you have to use supported hardware, software and drivers.
     
  22. chrism74 macrumors newbie

    Joined:
    Mar 6, 2011
    #22
    SolidWorks does not support the graphics hardware in Macs. However, it mostly works fine in my experience. I used SolidWorks on my 2006 vintage MBP for a couple years. I've read that a downside is that you only get good 3D acceleration in the active window.

    So, not perfect but not a showstopper like we got from Parallels Tools.

    Chris
     
  23. Chester88, Mar 17, 2011
    Last edited: Mar 17, 2011

    Chester88 macrumors newbie

    Joined:
    Mar 17, 2011
    #23
    Hello Chris,
    I'm planning to buy a brand new macbook pro 15 inch and 2,2 Ghz. And I need to run Solidworks on it.
    Did Solidworks run via Bootcamp or Parallels on it or not? I didn't really get it, cause my English is not the best. I would be very happy if you could give me an answer on my question.

    Or maybe there is someone else who can tell me if solidworks will work on the newest macbook pros?
    Chester
     
  24. Chester88 macrumors newbie

    Joined:
    Mar 17, 2011
    #24
    So is there nobody who has a new macbook pro and solidworks running on it?
     
  25. strompebukse macrumors newbie

    Joined:
    Mar 11, 2011
    #25
    I'm using SolidWorks in Boot Camp on a 2.8 GHz Core 2 Duo 15" Macbook Pro. Both SW 2010 and 2011 works well. SW works in Parallels, but is quite slow on my laptop.

    Check out this site for benchmarks and some examples of Macs running SolidWorks (search for macbook or mac):
    http://www.solidworks.com/sw/support/shareyourscore.htm
     

Share This Page