SolidWorks XP to Win7 slowdown

Discussion in 'Windows, Linux & Others on the Mac' started by dlyndaker, Oct 7, 2010.

  1. dlyndaker macrumors newbie

    Joined:
    Oct 7, 2010
    #1
    For the last several months I've been running SolidWorks 2010 on a new MacBook Pro (Core i5 M 520 @ 2.40GHz) dual booting into XP. It's been running fine and outperforming my couple year old Dell Xeon Workstation by a few percent when benchmarked using Anna Wood's CPU intensive punch holder, averaging about 88. I decided to upgrade to Win 7, which I've been very happy with on the desktop and showed consistant performance with XP. However, I was very disappointed and confused to find that the Win 7 on the MacBook slowed down to 112 for the 32 bit install and 126 for x64. Test were run with consistant settings and on AC power. I've fiddled with the Windows settings to maximize performance. The windows experience scores, for whatever that's worth, are higher than the desktop. I'm a bit confused as to what's going on. Anyone have any thoughts or suggestions?


    Thanks,

    Dave
     
  2. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #2
    Even though you say the benchmark is CPU intensive, my bet is on the GPU driver being the problem. Can you use the latest Nvidia driver instead of the one Apple provides with Boot Camp?

    B
     
  3. dlyndaker thread starter macrumors newbie

    Joined:
    Oct 7, 2010
    #3
    Thanks, good tip. But, no. Just installed the latest drivers with the same result.

    SW is not very efficient with multiple cores either. The couple different Dells that I've been using are 2 core, 2 thread machines (Xeon 5150, Core 2 Duo E8500) and they show running around 60% total CPU usage during the test. The MacBook Pro i5 M520 is 2 core, but 4 threads. It only indicates a usage of about 40%, in W7 at least, never paid attention in XP. Seems low, but I've got no other comparisons. I've tried setting processor affinity, but it does nothing but get worse. Urgh.
     

Share This Page