Solution for Exchange bug where deleted mail isn't really deleted

Discussion in 'iPhone' started by edmartin, Sep 27, 2007.

  1. edmartin macrumors member

    Jul 23, 2007
    I was hoping that this bug would have been fixed in the new 1.1.1 firmware release but it wasn't. So I got creative and found a pretty simple but effective solution.

    Here's the bug I'm talking about...

    If you are an Exchange server user, when you delete a message on the iPhone, it doesn't really delete the message on the Exchange server. So, when you fire up your e-mail client on your computer (e.g. Outlook), you end up still seeing all of the mail that you thought you deleted via your iPhone. Those "non-deleted" messages show up as "read" but they are still there. So you have to delete them again in your computer's e-mail client.

    Here's my fix...

    In addition to my normal Exchange e-mail account in Outlook on my computer, I created a new IMAP account which hits the same Exchange server. As soon as I did that, it fixed the problem of deleted mail still hanging around. What seems to happen is that when Outlook hits the Exchange server, both the Exchange account and the IMAP account check for mail and update their respective inboxes (obviously). Well, the Exchange account on Outlook doesn’t know what to do with the “deleted but shown as just read” stuff from the iPhone. But the IMAP account does know what to do with it. It goes ahead & purges the deleted stuff from the iPhone and presto!, the Exchange account inbox on Outlook also loses the iPhone-deleted items.

    I really hope we get real Exchange integration some day (I know, I know, "the iPhone isn't a business-user device"). But in the mean time, this solves what (in my opinion) had to be the most annoying bug out there related to using the iPhone with an Exchange server.
  2. d21mike macrumors 68040


    Jul 11, 2007
    Torrance, CA
    Cool. Nice find.
  3. dmn8 macrumors member

    Sep 27, 2007
    With the 1.1.1 update the messages deleted on the iPhone are now being deleted on Exchange. This work around is not necessary. This was one of the first things I noticed with this update. Great news.
  4. edmartin thread starter macrumors member

    Jul 23, 2007
    Then you have something different than me. Like you, it was one of the first things I tested and it failed - email deleted on the iPhone still lived-on on the Exchange server and appeared as "read" in Outlook.

    Interesting that it's working for you. What version of Exchange do you run? What e-mail client? My company is Exchange Server 2003 and I'm running Outlook 2007 on Windows Vista.
  5. dmn8 macrumors member

    Sep 27, 2007
    Our server is 2003 and I have Outlook 2007 on Vista as well.

    I tried this right after the udpate and was shocked. It has been working great all evening. Did you check the settings for the deleted items folder?

    If you want to send me a PM I can try to help.
  6. BamaATL macrumors member

    Sep 7, 2007
    I'm interested in this as well. My exchange email is still not deleted when I delete it via my iPhone running 1.1.1.

    My work around was to run a fetchmail daemon from my linux box. It expunges my exchange email every 10 minutes. This works great, but I shouldn't have to do this.
  7. edmartin thread starter macrumors member

    Jul 23, 2007
    Thanks. I dropped you a PM.

    I have my deleted items folder set to regular Exchange server trash/deleted items.

  8. edmartin thread starter macrumors member

    Jul 23, 2007
    Hmm. I just changed the location of my deleted items on my iPhone to my iPhone (instead of the Exchange server deleted items). It seems to work.

    Was it really that simple?
  9. dmn8 macrumors member

    Sep 27, 2007
    Just sent you a message. For anyone else I verified the following:

    My advanced Mail Settings are the following:

    Deleted Mailbox – Deleted Items

    Other than that I didn't change anything else, it just started working after the update.

    Needless to say, very happy. Let me know if I can offer any more info.

Share This Page