Solution for those annoying clicks on 7200 rpm HDD's :)

Discussion in 'MacBook Pro' started by mike1123, Jul 9, 2009.

  1. mike1123 macrumors 6502

    Joined:
    Sep 19, 2007
    #1
    I found this fix for those annoying clicks you get when the head parks on some HDD's, mostly 7200 rpm drives, I believe. Specifically, the 320GB WD Scorpio Black (which I have) and the Seagate 7200.4 500GB, as well as the Seagate 7200.3 320GB seem to have the problem a lot. The clicking is the head parking to save power when not being used, but for whatever the reason, OS X wakes the drive up right away.

    Note: There is a difference between safe clicking and bad clicking. The safe clicking, at least for me, happens once every 10-15 seconds and sounds like the head is parking. The HDD should make the same noise when you close the MBP to put it to sleep, which confirms the HDD is simply parking the head. Bad clicking is a lighter, more annoying sound that happens pretty constantly.

    And of course, the obligatory statement: use at your own risk; I didn't make this nor am I affiliated with it in any way. It worked great for me, so I thought I'd share. If you've had the drive for a while and haven't noticed clicking until recently, it might be a sign of impending doom.

    As for me, my drive made the sound right out of the box. After using this tool for a couple of days, my HDD has made NO clicks except for when going to sleep, which is perfectly normal. While I'm not sure if this method drains the battery anymore than normal, I have not noticed any significant decreases. YMMV. My Scorpio Black's temperature still hovers around 35 degrees celsius.

    1. Download HDAPM from mckinlay.net.nz/hdapm (hdapm stands for hard drive advanced power management) This is for OS X 10.4 and 10.5 only, I believe.

    2. Reveal hidden files in the finder by typing in "defaults write com.apple.finder AppleShowAllFiles -boolean true" (without quotes) and then "killall Finder" (also without quotes) to reset the Finder.

    3. Open a new finder window and go to Macintosh HD>usr>bin. Put the hdapm program (not the plist) into the bin folder (you will need to type your password).

    4. Go to Macintosh HD>Library>LaunchDaemons and place the hdapm.plist into this folder (password required again).

    5. Reboot.

    6. Now the next step involves typing a command into Terminal in order to stop the clicking. Open Terminal and type "hdapm disk0 0xfe" (without quotes). It should spit out: Setting APM level 0xfe: Success. That's it! But...

    7. Unfortunately, you need to retype it every time the computer is cold-booted. So what I did is create an Applescript that runs the command every time the computer starts. Open the Script Editor (applications>applescript). Next, enter in "do shell script "hdapm disk0 0xfe"" Make sure to include the bolded quotes. Then hit the "compile" button. It should redo what you typed a bit by making some of it turn blue. Then go to file>save as. Type a name for it, and SAVE AS AN APPLICATION. Next, go to system preferences>accounts. Hit "login items" under your username, and add the script application to the list. Then check the hide box.

    8. Hide hidden files in the Finder by typing "defaults write com.apple.finder AppleShowAllFiles -boolean false" (without quotes) into the Terminal, followed by "killall Finder" (without quotes).

    All done! I hope this allows more people to run the HDD's they want without having to worry about that annoying sound. I was about ready to return my Scorpio Black, which I really didn't want to do because the thing is a monster, but now it runs almost silently, with only a faint fan hum. I can hardly tell the difference between it and the stock 5400rpm Hitachi that it came with!
     
  2. t0mat0 macrumors 603

    t0mat0

    Joined:
    Aug 29, 2006
    Location:
    Home
    #2
    That's a do everytime it's cold booted hack, not a fix i'd say. Current solutions include swapping to SSD, using a different 7200rpm drive (e.g. the non G-Force version of the Seagate drive!) or using the 5,400rpm option.
     
  3. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #3
    Best solution is to turn off the sudden motion sensor.

    If you are using Time Machine anyway..
     
  4. YoYoMa macrumors 6502

    Joined:
    Aug 3, 2006
    #4
    There's an option in time machine that lets you turn off Apples motion sensor which solves the click beep? Where is the option?
     
  5. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #5
    No, I mean if you are using Time Machine, it isn't as much of a disaster if you dropped your Mac and the hard drive crashed because the Sudden Motion Sensor was off.

    It is a Terminal command to turn it off.
     
  6. t0mat0 macrumors 603

    t0mat0

    Joined:
    Aug 29, 2006
    Location:
    Home
    #6
    Except turning it off doesn't help the situation as reported by several eiththe issue
     
  7. Mmerovingian macrumors newbie

    Joined:
    Jul 13, 2009
    #7
    I recently upgraded my hd on my macbook pro (late 2008) to WD scorpio black 320gb 7200rpm disk.

    about two days later I started hearing this annoying sound as you describe.. used your fix and all is good....


    .... exept.

    when I restart the computer I get an error message from the applescript application that starts... something about value must be between 1-273 something.. I forget the exact number.. so I have to manually open terminal and enter the command. Any way to fix this?

    and any reason to think this will be fixed in future firmware upgrades from Apple?

    and.... any reason to think this will damadge my disk?

    thanks in advance
     
  8. eron macrumors 6502

    Joined:
    Dec 2, 2008
    #8
    Well, except I'm using an Intel SSD on my 15" MBP and the beep is still there. Oh, I've switched off the motion sensor too.
     
  9. Mmerovingian macrumors newbie

    Joined:
    Jul 13, 2009
    #9
    I've never heard a beep from my computer, only the clicking sound
     

Share This Page