Solution of error 1013 in iPhone 4

Discussion in 'iPhone Tips, Help and Troubleshooting' started by marckmaching, Nov 24, 2010.

  1. marckmaching macrumors newbie


    Nov 14, 2010
    For many of you who have iPhone 4′s and tried to update to iOS 4.2.1, you may encounter Error 1013 on iTunes. This seems to be a widespread issue and widely discussed on Apple’s forum. Fear not, there is already a way to fix this Error 1013.

    Due to the rush of releasing this iOS version, a bug like this is bound to come out. This has been reported to Apple but if you don’t intend to wait any longer, please see the following for the instructions. Methods on Fixing the Error 1013 are available for Mac and PC.

    Mac OS X

    1. On your Mac, go to “Applications” folder.

    2. Go to the “Utilities” folder.

    3. Start “Terminal”.

    4. Type “sudo nano /etc/hosts” (without quotes) and hit enter.

    5. Enter your login password

    6. Use the down arrow key to find “”. Add “#” in front of the text e.g.

    7. Save the file by hitting CONTROL+O.

    8. Exit the nano editor.

    9. Restore your iPhone.


    1. Go to Start > Programs > Accessories

    2. Run Notepad. Note: on Windows 7, right click on Notepad icon and select “Run As Administrator”

    3. Click File > Open

    4. Go to Windows/System32/drivers/etc

    5. In “files of type:” select all documents

    6. Open “hosts”

    7. Delete any entry with “”

    8. Click Save

    9. Restore your iPhone

    Good luck!!!:apple::apple::apple:
  2. shandyman Suspended

    Apr 24, 2010
    Dublin, Ireland
    i have 2 points.

    1. this release was in no way rushed, if you were in the Dev program you'd have known this....

    2. the 1013 error is not native to this release, it did it to me on 4.1 and also 4.0 on my 3G. 4.2 went on without a hitch for me.

    but thanks for the guide, if i encounter the problem again, i'll try it.
  3. marckmaching thread starter macrumors newbie


    Nov 14, 2010
  4. Kiirk macrumors member

    Jun 15, 2010
    Generally only jailbreakers or those who have saved their SHSH to have this issue.

    It's only when the host file has been modified.
  5. dukebound85 macrumors P6


    Jul 17, 2005
    5045 feet above sea level
  6. billyfoil macrumors member

    Jul 10, 2008
    marckmaching I want to thank you very much for this. I did this and it worked and saved me a trip to apple store to argue with them lol

    I dont know alot about this type of stuff but after reading this stuff noticed a lot of people saying tiny umbrella modifies the thing i just fixed... :(

    thanks again :):apple:
  7. phreebsd macrumors regular

    Aug 6, 2010
    ^ this is exactly right
  8. -MRB macrumors 6502

    Jul 1, 2010
    I followed the intructions for windows, with no avail.

    I then followed the instructions for OSX, and it worked :) Thanks!
  9. justinleon macrumors newbie

    Aug 6, 2010
  10. Ezdezat macrumors newbie

    Dec 13, 2010
    I just wanted to say thanks, what's your address i'll send you an Xmas present?! :D

    2 days of trying everything to get out of recovery & i found this post. It worked!
  11. bdubk20 macrumors newbie

    Feb 16, 2011
    error 1013

    what if your notepad doesn't have anything related to apple in it??
  12. neko girl macrumors 6502a

    neko girl

    Jan 20, 2011
    Can somebody explain why this step is necessary? Why is the failure occuring at all?
  13. 1013sucks macrumors newbie

    Sep 19, 2011
    Big help

    I don't ever post in forums, at all, but this tip will work 100%, I've tried everything the last 4 hours including TinyUmbrella, and RecBoot to try and kick it out of the recovery loop and neither worked until i stumbled across this forum and it worked on the first try. So do what he/she said and use....

    sudo nano /etc/hosts

    Good Luck!
  14. solius macrumors regular

    Jul 15, 2010
    Decatur AL
    so this isnt working for me. I do have 2 hosts files though. one is the regular hosts file and there is a second one that says lmhost file do i delete the line from both?
  15. Kyotoma macrumors 68000


    Nov 11, 2010
    Carnegie and Ontario
    Unles you have SHSH blobs saved for 4.2.1, there is no way of upgrading to 4.2.1, as apple no longer signs iOS 4.2.1 for any iPhone other than the iPhone 3G and the second-generation iPod Touch.

Share This Page