Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

davedee65

macrumors regular
Original poster
Apr 7, 2010
106
7
UK
Hi all apologies if this solution has already been posted.

I've been trying to update my iPhone 4 to 4.0.1 for hours but it kept failing 3/4 of the way through and bricking my phone due to an error 9 message.

Tried all the usual fixes for this problem, even tried different Macs but still had same result. But found this solution posted elsewhere. Tried it and it worked, out of recovery mode update complete, all I need to do is restore from back-up.

Download RecBoot 1.0.2
I found it here: http://www.sebby.net/659-released-recboot-1-0-2/
Plug in your iPhone.
Close iTunes.
Run "RecBoot Exit Only"
Click the "Exit Recovery Mode" button.
The screen on the iPhone will go black. At this point, UNPLUG the iPhone (before it starts back up)
It will boot up correctly after finishing the firmware install.
Now plug your iPhone back in and complete a normal restore.

Hope it helps all those stressed users out there with the same problem.

Just to say that have tried the death grip with 4.0.1 in a location where I normally have poor signal and I still get signal drop, it does hang on in there on one bar for slightly longer than before but then it goes to no service!!

Cheers
 

Bistromaths

macrumors newbie
Jul 9, 2007
3
0
This is a fantastic solution, and worked for me, meaning I now don't have a bricked phone.

Trouble is, now when I try restoring from my old backups, my app save states aren't transferred over. Things like texts and email settings are, but NOT app saves.

I have quite a number of games, and do not want to face the prospect of having lost two years of progress in them. Why can't apple make game saves more transparent? :(

*EDIT* I've now solved my issue. I had evidently chosen the wrong backup, as Apple doesn't label them clearly, or show previews of what they look like. Now chosen right backup, and everything works fine. Therefore, can now FULLY endorse this fix :)
 

Axford

macrumors newbie
Jun 15, 2010
2
0
I've tried this version of the Recboot solution, too, but I'm still stuck. After running Recboot, getting the "plug into iTunes" screen, and plugging back into my Mac, the restore process still hangs at the exact same place as before. And it won't progress any further, even if I let it run for hours.

Can anyone help? I'd sure appreciate any guidance.
 

nazzo1

macrumors newbie
Jul 16, 2010
1
0
West Midlands
Worked for me also. I've frustrated all morning trying various cables and my windows pc as well as my mac and ports. then spent 45 mins to apple support. no luck until i came across this.

Thank you very much for this solution :)
 

woodbird25

macrumors newbie
Dec 5, 2008
5
0
Hi all apologies if this solution has already been posted.

I've been trying to update my iPhone 4 to 4.0.1 for hours but it kept failing 3/4 of the way through and bricking my phone due to an error 9 message.

Tried all the usual fixes for this problem, even tried different Macs but still had same result. But found this solution posted elsewhere. Tried it and it worked, out of recovery mode update complete, all I need to do is restore from back-up.

Download RecBoot 1.0.2
I found it here: http://www.sebby.net/659-released-recboot-1-0-2/
Plug in your iPhone.
Close iTunes.
Run "RecBoot Exit Only"
Click the "Exit Recovery Mode" button.
The screen on the iPhone will go black. At this point, UNPLUG the iPhone (before it starts back up)
It will boot up correctly after finishing the firmware install.
Now plug your iPhone back in and complete a normal restore.

Hope it helps all those stressed users out there with the same problem.

Just to say that have tried the death grip with 4.0.1 in a location where I normally have poor signal and I still get signal drop, it does hang on in there on one bar for slightly longer than before but then it goes to no service!!

Cheers

This is exactly what I did last night after 6 hours of trying every other so called solution on the web and it worked perfectly.
 

iHeartapple2

macrumors 6502
Jun 29, 2010
336
3
Just to say that have tried the death grip with 4.0.1 in a location where I normally have poor signal and I still get signal drop, it does hang on in there on one bar for slightly longer than before but then it goes to no service!!

Cheers

The update does not solve the death grip issue and it never was suppose to. All it does is simply change the way the bars are displayed for signal strength.
 

incoherent1

macrumors member
Jun 5, 2007
72
0
Thank you -- this saved my life. If I hadn't found this, I would've been stuck on a business trip with a bricked phone.

Have to say I'm extremely displeased with how Apple has handled these problems. They release an update that bricks a bunch of phones and requires a backdoor solution, when the update solves no [major] problems and merely displays signal bars differently.

I'll see what Steve has to say at 1pm Eastern, but this is the first time in my 10 years as an Apple customer I've considered walking away...
 

aneks

macrumors regular
Aug 29, 2006
132
0
thanks, this was the most useful thing ever. I am donating to the guy who wrote RecBoot now !
 

Aaron Spencer

macrumors newbie
Jul 17, 2010
1
0
Wow. iPhone 4.0 worked almost 24 hours

Tonight after watching Steve Jobs press conference online I promptly started to update my new iPhone to 4.0.1. I have had this phone for not quite 24 hours and went ahead with the purchase even though rumors of problems have been bubbling up. I tried to duplicate the "death grip" and only got dropped one time, while in a fringe, rural area. So far, so good until tonight when "unknown error occured (9)." I am left with a paperweight and nine printed pages of errors listed in my iPhoneupdater log.
I hope my situation is an isolated incident and these phones don't start turning into bricks over the next 24 hours.
1. I will be at Apple today when they open dead phone in hand. I nursed a failing Motorola Razor on for months and months waiting for this phone. I think I should be able to walk out with a functional or replacement phone.
2. I am not a Mac novice. I manage nine Macs in my brother's office. They range from a three week old Mac mini server all the way back to an iMac PPC G3 running 10.3.9.

I am not angry, I am exasperated.
 

akyla06

macrumors newbie
Jul 17, 2010
1
0
error 9 with 4.0.1 update

Thank your for the solution WoodBird25, this is the key to bring back your iphone 4 to life. I was so upset after the 4.0.1 upgrade that made my iphone unusable (error 9). The only answer from the apple support was to exchange it. The solution is like to take the hammer to kill the fly. Recboot is the only way for now to solve the problem without having to exchange the iphone in a applestore. So error 9 while upgrading is not a hardware issue but a 4.0.1 firmware issue :-(( bigger than the reception pb which for me was not a problem by the way on mine. I could not imagine that this upgrade would make my iphone 4 unusable.
 

creamme

macrumors newbie
Jul 18, 2010
1
0
This worked

I have to say this worked for me after talking to AppleCare representatives on the phone for 2 hours. Although it kept my contacts, all of my apps and music gone. But luckly, my iPhone 4 functions again! Thanks for the RecBoot writer and the who found this (although hacky) solution!!
 

BanjoTed

macrumors newbie
Apr 17, 2009
4
0
Trying to update my iPhone 4 has completely bricked it. Tried every fix suggested here - the restore never completes. Booked in with a Genius on Wednesday :-(
 

BanjoTed

macrumors newbie
Apr 17, 2009
4
0
Success! Though RecBoot didn't do the job on my PC at home it did on my Mac at work. No just need to get home tongith and see if I can restore all my backed up data. Fingers crossed!
 

mista2

macrumors newbie
Apr 8, 2009
9
0
Thanks this worked out! Only downside was I still had to restore from an old backup.

My 3G bricked during the upgrade from 4.0 to 4.0.1. It got 2/3 through then just stuck there. I left it all night with no progress. Still stuck in the morning, on the same point. Hung. Started a restore. Waited an hour with no progress.
I ended up taking the phone to work and setting up itunes again on a PC, and restoring from three. I've got my phone back, but no settings - I'll try again from my home mac again tonight to do a restore, but actually most of the performance problems I had under 4.0 have gone, so I'm not sure if that is 4.0.1, or just the fresh, un-cluttered restore. Maybe this "Defrags" the storage on the phone.
My home machine is a Mac Mini with OS X 10.6.2, updated iTunes just before the update.
 

Appolu

macrumors newbie
Aug 7, 2010
1
0
Hi guys.

I got my Iphone 4 yesterday and i also got the same problem. I found this solution on google and it worked perfect. But i got only one problem: I can't restore my phone without using recboot, is that the same thing for everyone else here? because i think it shouldnt be like this, if anyone knows the solution please post it or otherwise i will return the phone!
 

Zwhaler

macrumors 604
Jun 10, 2006
7,026
1,485
I ran into this problem tonight and I was linked to this thread. It worked like a charm. Thanks for sharing! :)
 

Hind

macrumors newbie
Aug 11, 2011
3
0
Error 9

On updating my iphone 4 (32GB) software to 4.3.5 it gave me error 9. I cant restore it back and it only shows the connect to itunes screen

I tried to restore it more than once and I used Tinyumbrella, Thats the last log I got
http://pastebin.com/Ji8MPyy5


and thats another one I got after
http://pastebin.com/7RAUshue

It is factory unlocked and I am using windows vista

I dont know how to fix it
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.