SOLUTION to iPhone "freeze" after installing apps

Discussion in 'Jailbreaks and iOS Hacks' started by GNice, Aug 31, 2008.

  1. GNice macrumors 6502

    Joined:
    Aug 7, 2007
    #1
    First let me state this worked for me and I don't guarantee it will work for anyone else though it's worked for many others.

    I have posted in the recent past about spending many, many hours restoring my phone because it would "freeze" when installing an app and would get stuck at the Apple logo upon restart. It has been so frustrating that despite my love of Cydia I had almost given up on using it.

    Anyway, after scouring the web I found a tip that worked for me. I would post the link to the location where I found the tip but not sure of the policy of linking to the site...so here are the steps copied and pasted below:

    1. turn ipod or iphone off
    2. connect cable
    3. turn on ipod iphone
    4. listen for ding dong (window) or what ever the mac sound is
    5. ssh to your ipod iphone
    6. goto /var/mobile/
    7. rename Applications to Applications2
    8. wait 5 second and your springboard will pop up
    9. now rename Applications back and restart

    Now, this didn't work precisely for me. Step 8 didn't actually happen and I had to restart. Also after renaming the Applications folder to Applications2 the "base icons" that appear on the dock where gone. However, after a sync (which only took a few minutes since all the apps are really still there) and a restart my iPhone was back to working condition. I just had to arrange my icons back to their original locations. The whole process didn't take long at all. I wasn't timing it, but it had to be less than 10 minutes.

    So what would have taken me several hours in the past...restore, install my apps, install my music, set up my email accounts, etc. took just a few minutes.

    Please note all my "freezes" happened after installing Cydia apps up until the last time when I tried this tip. My phone froze and was stuck on the Apple logo after installing an app from the store app.

    In any event I hope this helps someone else save a LOT of time as it did me.

    G

    EDIT: The reason it didn't work precisely for me as described is I messed up and didn't follow the directions to the letter. If you follow the directions correctly the above should work fine (i.e. - Step 8 will occur).
     
  2. Trip.Tucker Guest

    Joined:
    Mar 13, 2008
    #2
    ....or you could just ssh and correct the permissions issue you had with one command. :D
     
  3. Trajectory macrumors 6502a

    Joined:
    Nov 13, 2005
    Location:
    Earth
    #3
    Are these instructions for an unlocked phone only? What is springboard?
     
  4. GNice thread starter macrumors 6502

    Joined:
    Aug 7, 2007
    #4
    If I was aware of how to do it with one command I would posted a one command approach. I was merely trying to help others frustated users. Thx for the info though I'm not sure how to "fix the permissions". Sorry if my post is suboptimal.
     
  5. GNice thread starter macrumors 6502

    Joined:
    Aug 7, 2007
    #5
    You just need to be able to SSH to your phone.
     
  6. Bear Hunter macrumors 6502a

    Bear Hunter

    Joined:
    Aug 10, 2008
    #6
    Can you elaborate? Thanks
     
  7. clancemasterj macrumors regular

    clancemasterj

    Joined:
    Jan 31, 2007
    Location:
    Somewhere outside of time.
    #7
    For those with jailbroken iPhones and SSH installed, there is a fix "or workaround" for the infinite apple logo loop. This method disables watchdog and allows the springboard to load. Once it's reloaded, you have to enable watchdog because "as well as monitoring Springboard and killing/restarting it, the watchdog also has to periodically reset the HARDWARE watchdog, if this doesn't happen the device will spontaneously reboot. The hardware watchdog is 10 and a bit minutes, so without the watchdog installed and working your device will reboot itself every 10 minutes."

    a more thorough explanation is on the link:

    http://www.hackint0sh.org/forum/showthread.php?t=49782

    terminal commands to send to the device via ssh:

    Disable watchdog:
    mv /System/Library/SystemConfiguration/mobilewatchdog.bundle/ /
    reboot

    enable watchdog:
    mv /mobilewatchdog.bundle /System/Library/SystemConfiguration/
    reboot
     
  8. peterrosen macrumors newbie

    peterrosen

    Joined:
    Jul 3, 2007
    #8
    myDictation Pro has been Freezing my Phone - Apple Genius Saves Day!

    I have been thru five iPhones in less than a year, because of this one app!! I thought the phone was at fault. After exhaustive testing, I discovered with the help of "System Activity Monitor" to establish the culprit: MyDictationPro version 3. It is the only app after process of elimination that causes memory loss and constant "nagging" of the CPU eventually heating up the phone, causing poor battery performance and locking the phone up. When I removed this application, the phone operated normally. STAY AWAY FROM THIS APP. I would demand my money back and sue them for pain and suffering if I could!!! Hope this helps someone!

    I had to restore my phone, and set up a set of applications, when it ran fine for a day, I'd add some more and see if the System Activity App indicated an application sucking all the CPU power. I narrowed it down to MyDictationPro. When adding only that and the Sys tool to the normal start up set of apps, sure enough, the CPU meter in the System tool, was pinned! Without that App, I would never have discovered the problem...

    I spent days with a Apple employee who had me restoring and putting in apps, but not one by one, and without any feedback tool other than the phone freezing. Thanks to the Apple Store Genius in Garden State Mall, Paramus, NJ who suggested getting the System Activity Monitor for iPhone.
     

    Attached Files:

  9. ncdasa macrumors member

    Joined:
    May 11, 2009
    #9
    I hope this thread isnt too old...

    I really need some advice here. I just came across this solution but i dont know how to do it!

    Basically i need to know how to "SSH to iphone" (step 5 of the original post).

    Is there software I need to download ( i read something about an 'OpenSSH')?

    I could follow the instructions above if i knew how and what was involved in steps 5 and 6. I think I could figure out 6 if I got that far (I am guessing something like entering commands in terminal, but on the iphone), but I am basically clueless about 5.

    PLease drop in and post if you know whats up with this process (or if you know another solution for successfully rebooting your phone after a cydia app freezes it).

    (BTW, not that it matters, but mine freezes not on the apple logo, but on the lock screen. The button wont slide and nothing responds... :( )
     
  10. rwd hero macrumors 6502

    Joined:
    Aug 6, 2008
    Location:
    Baltimore, Maryland
    #10
    you on a mac or a pc?

    for a mac...
    1.download openssh in cydia
    2.download cyberduck on your computer
    3.connect to wifi on both
    4.open settings app in phone and get wifi address
    5.open cyberduck
    6.select SFTP (ssh file transfer protocol) in the dropdown menu
    7.enter wifi address in the server field
    8.username is root
    9.password is alpine
    10.hit connect and you are officialy SSHed into your iPhone
     
  11. ncdasa macrumors member

    Joined:
    May 11, 2009
    #11
    Wow, thats awesome. Thanks for the quick reply. And yes, I am on a mac.

    Ok, so now just a few more questions remain. In the situation mentioned in the original post, where the iphone is stuck trying to reboot or is frozen, and needs to be connected to through SSH, how exactly do i do that?

    I mean in the instructions it says "plug in phone,... ssh to phone" (and this is frozen phone remember), so iam wondering how that is done? I guess i just open cyberduck and try to connect through that. I mean what else is possible to do right? If the phone is stuffed?


    Anyway, please let me know if aim missing something. Also I started reading the original forum that the instructions came from (http://www.hackint0sh.org/forum/showthread.php?t=49782), and it got me to worrying. I thought it didnt matter that my phone was freezing on the slide screen and not the :apple: . Now, at least from what i read, it seems that that may not be the case :mad: ...

    I guess I'll just have to try and see what happens next time this phone goes into a coma.
     
  12. TMar macrumors 68000

    TMar

    Joined:
    Jul 20, 2008
    Location:
    Ky
    #12
    So I'm guessing the only reason you plug the phone in is so that you know when it has started up enough to SSH into the phone?
     
  13. ncdasa macrumors member

    Joined:
    May 11, 2009
    #13
    (I am not sure, was this question directed at me?)

    Anyway, I dont know. I am just looking at the instructions given by the OP. SSHing is something I know nothing about. I dont know if plugging it in is necessary. I guess if SSHing is done through wi-fi, then conceivably it shouldnt be.

    Beats me :confused:
     
  14. TMar macrumors 68000

    TMar

    Joined:
    Jul 20, 2008
    Location:
    Ky
    #14
    Yes, it was direct at the OP and yes SSH is over the Wi-fi connection.
     

Share This Page