Solution: when iMovie or FCE will not import AVCHD HD files or MTS / M2TS files

Discussion in 'Digital Video' started by ingenagelhus, May 29, 2010.

  1. ingenagelhus macrumors newbie

    Joined:
    May 29, 2010
    #1
    Problem 1: iMovie or FCE will not import your footage from SDHC camera with files in AVCHD structure, or cannot import .mts or .m2ht files (which you may have copied from AVCHD structure. When mounting camera, you can see the camera as disk but iMovie will not try to import footage. If you point Final Cut Express (FCE) to the file structure, it fails to recognize it as a valid file structure. (I have Canon HF10, but understand that this problem is common on many camera models, maybe camera has been turned off at the wrong moment?)

    Cause 1: Faulty file structure on camera or disk

    Problem 2: You have MTS or M2TS files that you want to import to iMovie or FCE without loss (and do not want to use or buy conversion software)

    Soultion: Rebuild AVCHD file structure using an AVCHD editing tool. I found multiAVCHD (multiavchd.deanbg.com), which is not perfect, but will do the job. And it is freeware:) (possible to donate).

    I would like comments about others experience - but at least this worked for me:

    * Download and install the software (Yes, you need Windows):mad: (Anybody knows a mac program doing this???)
    * Set the right parameters: mostly default, I didn´t want any recoding. But tick off to keep the source files!
    * Select the AVCHD source (or source .mts or m2ts files) and destination
    * Start rebuilding: select output for Sony Playstation 3
    * Put the AVCHD file structure on a USB stick


    If using iMovie:
    Start iMovie and plug the USB into the mac (virtual disk (.dmg file) or other media should work fine as well). The USB may contain other files as well, but the root of AVCHD must be named AVCHD.
    iMovie recognizes the drive as a camera. All is not 100% well, as the dates for making the footage is lost, and the thumbnails are distorted if seen at all, until clicked on. But then import worked for most clips. Some clips gave an error message, but FCE was able to import these (Log&transfer).

    If using FCE: Use Log and transfer on this file structure (need not be on external disk)

    I suppose there are other tools out there which may correct the file structure with less side effects and no errors.
    If you go for this solution - remember the author of multiAVCHD, he will surely appreciate a donation. I guess everybody will agree that this is worth at least as much as you paid for your SDHC card.

    Why a function to correct faulty AVCHD file structure is not included in iMovie and FCE is beyond my understanding!

    I notice many users salvage their footage by converting the .MTS files, using Handbrake etc. But I believe rebuilding the file structure is faster and with no quality reduction.

    By rebuilding the AVCHD file structure (or making a new one, adhering to the standard), iMovie and FCE can import the footage as intended, using the Apple Intermediate Codec. This is the way it was supposed to be imported from camera to FCE and iMovie by Apple developers.:)
     
  2. pretzelmonster macrumors newbie

    Joined:
    Jan 21, 2011
    #2
    Great, this indeed IS the solution!

    Hi ingenagelhus,

    you made my day! I was looking around for a long time and only found solutions like rebooting, change the USB cable, buy this 30$ conversion solution, etc. for using my films from the Sony HDR-SR11 with iMovie '09.

    This solution works perfectly. multiAVCHD works quite well under Parallels (except for some error pop-ups which have to be closed without bad effect) and the import from a fairly quick USB into iMovie works flawlessly!

    Thanks a lot and keep posting solutions! ;)

    pretzelmonster.
     

Share This Page