SOLVED - 1st gen iPhone battery not taking a charge

Discussion in 'iPhone Tips, Help and Troubleshooting' started by dudecati, Nov 20, 2009.

  1. dudecati macrumors newbie

    Joined:
    Oct 8, 2007
    #1
    Hi All, I've got a 4 gig 1st gen iPhone that has been working perfectly until today. Today the battery has decided not to take a charge. I've used the adaptor and plugged it into the wall and it just stays in the red zone. Is this normal behavior for the battery to completely fail that quickly? It had been taking and holding charges just fine until now and battery life had been strong. Any suggestions?

    Thanks!
     
  2. superflush macrumors 6502a

    Joined:
    Apr 6, 2009
    #2
    Have you tried different cords? It could be that the USB cord has a problem
     
  3. dudecati thread starter macrumors newbie

    Joined:
    Oct 8, 2007
    #3
    Solved - just needed a reset

    Thanks for that reply, that is a good thought and I'll keep it in mind for next time.

    This time it was as simple as resetting the phone - I guess the 'gage' needed to be cleared out. After the reset it shows fully charges and appears to be reading accurately.
     

Share This Page