[SOLVED] Airport Express printer disappears, but internet OK

Discussion in 'macOS' started by TechnoBob, May 17, 2009.

  1. TechnoBob macrumors newbie

    Joined:
    May 13, 2009
    #1
    Using Airport Express (AE), iBook can connect to internet, but can no longer connect to printer.
    Simultaneously, iMac can do both (just as iBook did until recently).
    Airport Utility on iBook is "unable to find any Apple wireless devices", which is ridiculous (because iBook is connected to the internet via AE).

    Why can iBook suddenly not see the printer over Airport Express?


    ---- Detailed description of problem follows -------

    ** SITUATION
    iBook G4 14"
    iMac G5 2.1 GHz
    OS 10.5.4
    AIrport Express (AE) w/Ethernet to cable modem and w/USB to printer

    iMac (via AE)
    - Wirelessly connects to internet
    - Wirelessly connects to printer

    iBook (via AE)
    - Wirelessly connects to internet
    * CANNOT wirelessly connect to printer (Although it always did until yesterday)

    ** BACKGROUND
    Trouble began after purposely discharging iBook's new battery as part of conditioning/calibrating. Afterward, iBook's Airport card came up with a self-assigned IP address, and only way to reconnect to AE (after resetting PRAM, deleting prefs, changing network settings, etc) was turning the Firewall off and back on.

    ** PROBLEM
    Thought everything was fine until I tried to print, at which time the iBook could no longer find the printer over the Airport Express. Troubleshooting with Airport Utility (v 5.4.1):
    - iMac: AU immediately finds the Airport Express
    - iBook: AU "unable to find any Apple wireless devices"

    Oh, really? Then how is it that the iBook is connected to the internet via an Apple wireless device?!

    The iBook now cannot find this printer at all. In the Print dialog, when I select "Add Printer", the printer that's USB-connected to the AE does not come up as a Bonjour printer (as it correctly does when I try this process on the iMac).

    ** QUESTION
    How can this situation arise? What setting am I missing? Did I somehow disconnect the printer myself, or did the discharged-battery condition make the iBook forget something?
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    Fix you printing system the easy way by downloading the shareware application Print Therapy (it has a 7 day trial) and use it to reset your printing system. This might help.
     
  3. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #3
    You're absolutely certain that the iBook didn't randomly connect to your neighbor's open unsecure network?
     
  4. TechnoBob thread starter macrumors newbie

    Joined:
    May 13, 2009
    #4
    Print Therapy didn't help Airport Express printer problem

    satcomer, thanks for the suggestion. The Print Therapy app certainly appeared to be covering everything related to printing, but found only one problem--an improperly set permission (one out of 1525 checked).

    Repaired the permission, restarted computer, used the PT app to reset the printing system, crossed my fingers, and tried again. No joy.

    No printer available.
    Clicked Add Printers, but the window in which the printer should have appeared as a Bonjour printer (as it does when I do this on the iMac) was empty.​

    Clearly there's still something not set correctly...
     
  5. TechnoBob thread starter macrumors newbie

    Joined:
    May 13, 2009
    #5
    In answer to JediMaster's question...
    Absolutely. The network the iBook is connected to (and through which it has internet access) is my home network.

    [Only once or twice has my only nearby neighbor's secured network even been visible in the Network pull-down menu.]
     
  6. TechnoBob thread starter macrumors newbie

    Joined:
    May 13, 2009
    #6
    Printer problem persists for alternate user

    I have a separate account (which I seldom need to use) on my wife's iBook. It just occurred to me that perhaps the problem is with some preference file associated with her username.

    Logged in as myself. Tried to print from TextEdit. Same symptoms as above: no printer selected, and Add Printers comes up with nothing (specifically, no Bonjour printers).

    Just another data point.
     
  7. TechnoBob thread starter macrumors newbie

    Joined:
    May 13, 2009
    #7
    Out of ideas.

    I have an appointment at the local Apple store's Genius Bar tomorrow...hope they can figure this out. I'll update this thread with whatever new info I get.
     
  8. TechnoBob thread starter macrumors newbie

    Joined:
    May 13, 2009
    #8
    Fortunately, the iBook misbehaved the same way in the store: it connected to the Apple network there for internet access, but Airport Utility couldn't find any Apple wireless devices, and no Bonjour printers appeared.

    Apple Genius Adrianna figured it out. She verified that the hardware was OK (and thus that it was a system software problem) by booting from an external drive, whereupon the iBook behaved normally.

    Turns out that the Firewall settings were messed up in some strange way. Turning the Firewall off allowed Airport Utility to see the Airport Express; wireless printing now works fine.

    Only remaining problem
    is how to get rid of the spurious Firewall setting. In System Preferences, under Security > Firewall, deleted all the applications for which I had entered Block or Allow. Nevertheless, even with nothing in that window now, turning Firewall on (either "Set access for specific services..." or "Allow only essential services") causes the problem to recur. Is there some more basic way--some prefs to delete, for example--that will wipe the bad setting?
     

Share This Page