[SOLVED] App Store - Cannot download any apps.

Discussion in 'iOS 8' started by KlytusLord, Feb 19, 2015.

  1. KlytusLord, Feb 19, 2015
    Last edited: Feb 19, 2015

    KlytusLord macrumors regular

    Joined:
    Apr 11, 2011
    #1
    Hello, everyone.

    This problem is on my iPhone 6 Plus with iOS 8.1.3

    I cannot download any apps from within the App Store app in iOS. I don't get any errors, and the app icon does no appear on the home screen at all. The only thing that appears is the animated circle next to the app name (in the App Store app) as if the store preparing the download, but it never gets beyond that.

    This is not happening on any other iOS device on my account.
    I can still install apps on my iPhone via iTunes
    It does not matter if the app is already in my purchased history or not.
    There is never a time out. it just keep trying until I close the App Store app.
    Wifi and cellular connection = same result.
    All other connections on the phone work fine. i.e. cloud sync, browsing, etc.
    I can navigate the App Store fine, and look at my purchase history, I just can't download/install anything.
    No restrictions are turned on.
    Hard reset already tried.

    That's about all I can think of including.

    Any suggestions? At this point my last remaining option to wipe the phone and start over, and hope that fixes the issue.
     
  2. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #2
    Restart your phone (hold power + home button until Apple logo appears)
     
  3. KlytusLord thread starter macrumors regular

    Joined:
    Apr 11, 2011
    #3
    Thanks, Armen. I should have included that restarting is one of the very first things I had already tried, with no luck.

    I completely wiped the phone (using the full reset option in settings) and now everything is fine.
     
  4. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #4
    Glad to hear. Was hoping you didn't have to take that route though although I do restore my phone once in a while as part of my maintenance habits :)
     

Share This Page