iPhone [SOLVED]Are my blobs corrupted? 5.1.1 iPhone 3GS issue

Discussion in 'Jailbreaks and iOS Hacks' started by novice121, Apr 7, 2013.

  1. novice121, Apr 7, 2013
    Last edited: Apr 8, 2013

    novice121 macrumors member

    Joined:
    Feb 15, 2013
    #1
    So I just got out of a really bad white screen of death, and a stuck DFU black screen with all sorts of errors. Basically I had to take my iPhone 3GS apart from the motherboard to the battery for a hard reset, and invent a weird way to get iRecovery to work (had to use "Just boot" in redsnow and right when the white screen came out for only 2 second, use the command iRecovery -s to get out of it into another black screen).

    Yes, I know about pwned DFU mode being different from DFU mode, I can manually get into DFU mode with my eyes closed by now, and used all possible tools to get out, but NOTHING worked in my particular case.

    Basically the phone came with 5.1.1 installed, so the first thing I did was save the blobs for it with redsnow.

    Redsnow said it saved the blobs locally and to cydia successfully, but after hitting Query, only a blank screen would show up:

    [​IMG]

    No problem, I stitched the local blobs to a 5.1.1 firmware and restored successfully with it!!! The first time at least... when I tried doing it again, all hell broke loose, and it took me days to get out of the white screen of death and many other issues.


    Later, for whatever reason, using many different tools, iFaith somehow submittef 5.1.1 blobs and 4.1 blobs to cydia, and was able to install 4.1 ALLELUYAH... (4.1 is still being signed though
    Code:
    http://theiphonewiki.com/wiki/SHSH
    )


    And now, Redsnow shows me these blobs:

    [​IMG]
    [​IMG]

    However, Tinyumbrella shows me that my 5.1.1 blobs (I think) are invalid:
    [​IMG]

    And iFaith says that I only have blobs for 4.1.

    I know about editing the host file in windows, creating custom IPSW's, stitching blobs, and restoring, but I think all the issues came off a successful restore with a phone with serial number 83944XXXXXX when I did that restore, because even if the cut off time for fixed BR was week 45 of 2009, Redsnow said that those in week 44 like mine were mixed results.


    So my question is; Can I use those 5.1.1 blobs from cydia and restore from 4.1 (currently) to 5.1.1, or will it get me into a blank screen of death again?

    Are my 5.1.1 corrupted?
     
  2. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #2
    Use iFaith (v1.5.6) to create a signed ipsw package and see if it says your 5.1.1 shsh are valid or not
     
  3. novice121 thread starter macrumors member

    Joined:
    Feb 15, 2013
    #3
    Yes!!! This worked using my local blobs for 5.1.1. Some issues though in case someone goes through the same thing.

    I have done all my testing on 3 different machines with XP, Windows 7, and 8, freshly reformatted, and with no third party firewalls, or antivirus/antispyware.

    All gave me same results.

    I successfully restored to 5.1.1 using "broken" blobs, before doing that I restored to 4.1 with full valid blobs to install the iPad baseband, and downgrade from it in order to IMEI unlock...(trying to do that in 5.1.1 gave me so many problems).

    After an IMEI unlock on iOS 4.1 and baseband 05.13.04 that went smooth and successful, only THEN, I restored back to 5.1.1 and whatever baseband (once the IMEI unlock was done in 4.1, upgrading to 5.1.1 or whatever version wouldn't matter).


    One thing though, something nobody mentions here is that Redsnow will fail while upgrading to the iPad baseband, saying something about this firmware can not be an unthetered... don't panic, simply press "Back" in Redsbow, and click Jailbreak again, and it will go through smoothly (learning to get into DFU mode by yourself is very useful once you memorize the procedure).




    So now I'm on 5.1.1 BUT DO NOT JAILBREAK WITH REDSNOW, doing so, will either give me a bad cydia that doesn't boot, or a white screen of death that no tool out there will fix, unless I take the phone apart...


    I had to use abesinth to jailbreak 5.1.1, for whatever reason it worked, but cydia was still having issues, I had to fix it by re-installing the Rocky Recoon jailbreak again.


    So now everything is good.
     

Share This Page