SOLVED: Broken Down: XP SP2 w/ No Reformat Screen, Disk Error, & Hal.dll Issues

Discussion in 'Windows, Linux & Others on the Mac' started by thebreadking, Jun 29, 2009.

  1. thebreadking macrumors member

    Joined:
    Nov 26, 2008
    #1
    Hey guys, I'm at my wits end here, and I could really use some help. This might be a little long, but please bear with me. For the past two days I've been trying to install Windows XP SP2 on my Mini via Bootcamp with no luck. I've had a trio of problems that seemingly most people only have one or two of. They are as follows:

    1. When doing the preliminary Windows setup (blue screen), there is no option to reformat the selected Bootcamp partition (apparently this occurs on some of the disks). Selecting a partition, it then tries to install directly on to it, which leads to:

    2. Disk Error. Because the XP disk does not have the reformat utility, the Windows setup results in a Disk Error (forcing a hard reboot) because it can't install on the un-formatted drive. So I've tried a workaround:

    3. Instead of directing it to install on the Bootcamp-created partition, in the original Windows setup screen I direct it to delete the Bootcamp partition and create a new one in that now unpartitioned space. Doing so allows me to choose the formatting options to use. However, as it gets through its process, its eventually restarts at a certain point and I get the dreaded "Missing or Corrupt Hal.dll" black screen (which also requires a hard reboot). This is likely the cause of an incorrect Boot.ini file...the problem being I can't get anywhere in the process far enough to edit that file (right?).


    At this point in time, I feel that I've read everything that I can about the issues, but since I have all three of these issues, I can't find any solution that relates directly to me; I'm lost and don't know where to go.

    Apart from the above-mentioned process, here are some of the other things I've tried:

    -creating an .iso from the install disk, removing the "Winnt.sif" file (apparently this causes my lack of a reformat screen), repackaging the .iso and burning it to disk at a slow speed. This can't be read as a boot disk.

    -creating an untouched .iso from the install disk and burning it to a blank disk (hoping it was a problem on surface of the original disk). This reads as bootable, but has the same problems as the original disk.

    -reformatting the unpartitioned raw space, after deleting the Bootcamp partition, into NTFS, NTFS (Quick), FAT32, and FAT(32) quick. All result in the "hal.dll" issue.

    -ejecting the install disk and booting from the Bootcamp partition after hard rebooting due to the "missing or corrupt hal.dll". Result is the same error.

    -using the Bootcamp utility to create a FAT32 partition at less than 32GB (apparently Bootcamp's 32gig partition is actually larger than 32gigs, which causes problems with formatting), to no avail. Likewise, trying to force a reformat screen by creating a partition that is larger than 32GB.


    I've tried almost anything that I can think of, but I've hit a wall (obviously). I don't know enough about the process to know how to successfully get through this obstacle. From what I read, it looks like the Boot.ini file is the likely culprit...how do I solve this?

    A couple of posts I've read mention deleting Apple's own 200meg EFI partition, but conflicting posts mention horrendous circumstances to doing that. Other posts have mentioned slipstreaming the install disk using "nlite", but I don't have immediate access to a PC to do so (is there a Mac equivalent?). And I don't want to install just via VMWare because I need all the processing power I can to run AutoCAD, so Bootcamp is my starting point.

    Lastly, some might say to just buy a new XP disk, but that's unfortunately out of my budget due to current financial situation.

    Again, I think the major hurdle is the "Boot.ini" file mislabeling the correct XP partition, so if anyone knows how to accomplish that in the situation I'm currently in I would be ecstatic. Or if you know of an easier way to go around the problem I would be equally ecstatic.

    ...actually, as long as I can get Bootcamp to work I'll be ecstatic. All the help you can give is extremely appreciated!!!

    EDIT: Sorry its so long, I figured I'd give as much info as possible!

    EDIT2: Solved. See the solution in my post below.
     
  2. tezro macrumors regular

    tezro

    Joined:
    Sep 7, 2007
    #2
    I made a post on this myself, so I will just say here what I did. Sorta.

    For me it was removing the 200MB partition and the Bootcamp partition (not 100% sure the latter is needed too though).
    Then I created the Windows/Bootcamp partition and all went fine.

    HOWEVER!!! Removing that 200MB partition makes it unable (for me at least) to select the startup disk in the Mac OS Preferences. It now only shows Network Boot.

    So, now I have to press the Alt/Option key every time I want to boot into Windows.
    Not a too big a deal, but it would be nicer to do it the proper way.
     
  3. thebreadking thread starter macrumors member

    Joined:
    Nov 26, 2008
    #3
    Thanks for the reply. I'm getting closer to just going that way, since I'm incredibly frustrated, but I'd love to be able to do it the proper way, as well.

    UPDATE: Here is the solution I used to get everything working:

    Boot into OS X, put the XP CD in. Use the Boot Camp Assistant to start the XP install.
    Once your mac reboots and starts the windows install you will get a blue screen with white text in the upper left hand corner that says "Windows Setup." On the bottom of the screen there will be some info telling you this and that is loading. Keep an eye on this. It will slowly list a bunch of things that it is loading. Toward the end, it will say something like "Starting Windows Setup." At this point, press and hold the F10 button. Keep holding it until you get a black screen with white text.

    You are now in the Recovery Manager. You will be asked what volume you want. The only choice you should have is 1. This is your new Windows partition, it is not your Mac OS partition. You may safely type "1" (without quotes) and press return. Then, the prompt will look like this:

    C:\WINDOWS\

    At the prompt, you type "cd\" (without quotes) and press return, the prompt will now look like this:

    C:\

    Now, to format your windows partition. To do so, at the prompt type the following without quotation marks "format c: /fs:FAT32" When typed into the prompt, it will look like this (pay close attention to spacing)

    C:\format c: /fs:FAT32

    It will give you a warning and ask if you are sure. Type "y" and press return.
    It will take some time to format and you will see a percentage counter counting up from 1% to 100%. When it is done, you will be back at the C:\ prompt where you will just type "exit" and press return.

    Now, Windows Setup should proceed normally.

    Source: http://www.mac-forums.com/forums/windows-classic-linux-other-os/97498-cant-format-partition-during-windows-install.html
     
  4. tezro macrumors regular

    tezro

    Joined:
    Sep 7, 2007
    #4
    How large is your Bootcamp partition?
    Mine is 50GB so I can't format that. No clue how Bootcamp formats 50GB as FAT32 though...
     
  5. Mush Tush macrumors newbie

    Joined:
    Jan 3, 2010
    #5
    Solution did not work

    I couldn't manage to fix the lack of a reformat screen during the setup. I tried doing the Recovery Mode format but I got the same error message from before. :mad:

    (I'm using the latest version of Snow Leopard with Bootcamp 3.0.1 on a late model MBP purchased in Sep.)


    Addendum: Any help is greatly appreciated. I don't know why this is even a problem? I've been at it for over FIVE HOURS! Is it because I'm using an OEM disk purchased off of eBay??

    Thank you!
     

Share This Page